Using and Administering Contribute
Trademarks

1 Step RoboPDF, ActiveEdit, ActiveTest, Authorware, Blue Sky Software, Blue Sky, Breeze, Breezo, Captivate, Central, ColdFusion, Contribute, Database Explorer, Director, Dreamweaver, Fireworks, Flash, FlashCast, FlashHelp, Flash Lite, FlashPaper, Flex, Flex Builder, Fontographer, FreeHand, Generator, HomeSite, JRun, MacRecorder, Macromedia, MXML, RoboEngine, RoboHelp, RoboInfo, RoboPDF, Roundtrip, Roundtrip HTML, Shockwave, SoundEdit, Studio MX, UltraDev, and WebHelp are either registered trademarks or trademarks of Macromedia, Inc. and may be registered in the United States or in other jurisdictions including internationally. Other product names, logos, designs, titles, words, or phrases mentioned within this publication may be trademarks, service marks, or trade names of Macromedia, Inc. or other entities and may be registered in certain jurisdictions including internationally.

Third-Party Information

This guide contains links to third-party websites that are not under the control of Macromedia, and Macromedia is not responsible for the content on any linked site. If you access a third-party website mentioned in this guide, then you do so at your own risk. Macromedia provides these links only as a convenience, and the inclusion of the link does not imply that Macromedia endorses or accepts any responsibility for the content on those third-party sites.

Opera ® browser Copyright © 1995-2002 Opera Software ASA and its suppliers. All rights reserved.

Copyright © 2002-2005 Macromedia, Inc. All rights reserved. This manual may not be copied, photocopied, reproduced, translated, or converted to any electronic or machine-readable form in whole or in part without written approval from Macromedia, Inc. Notwithstanding the foregoing, the owner or authorized user of a valid copy of the software with which this manual was provided may print out one copy of this manual from an electronic version of this manual for the sole purpose of such owner or authorized user learning to use such software, provided that no part of this manual may be printed out, reproduced, distributed, resold, or transmitted for any other purposes, including, without limitation, commercial purposes, such as selling copies of this documentation or providing paid-for support services.

Acknowledgments

Project Management: Jennifer Rowe
Writing: Chris Bedford, Jennifer Rowe
Managing Editor: Rosana Francescato
Editing: Mary Kraemer, Barbara Milligan, Lisa Stanziano, Anne Szabla
Production Management: Patrice O’Neill
Media Design and Production: Adam Barnett, Aaron Begley, John Francis, Mario Reynoso
Special thanks to Ken Sundermeyer, Eric Lerner, Chris Denend, Joel Huff, Lawson Hancock, Erik Larson, Sheila McGinn, Emilio Passi, Yoko Bayer, Scott Richards, Melissa Baerwald, Deb Galles, Kimberly Osloh, Dennis Griffon, Jon Varese, Brady Kroupa, Josh Margulis, Gavin Anderson, Deje Cooley, Vickie Chapman, Kaori McLister, and the Contribute engineering and QA teams.

Third Edition: July 2005

Macromedia, Inc.
601 Townsend St.
San Francisco, CA 94103
# CONTENTS

## PART I: Using Contribute

### CHAPTER 1: Welcome to Macromedia Contribute
- Website development and maintenance overview .......................................................... 11
- Contribute resources ........................................................................................................ 12
- Where to start .................................................................................................................. 14

### CHAPTER 2: Getting Started
- The Contribute workflow ............................................................................................... 15
- Setup requirements .......................................................................................................... 16
- Installing and starting Contribute .................................................................................. 16
- Connecting to a website .................................................................................................. 17
- Starting Contribute without a network connection ....................................................... 18

### CHAPTER 3: Exploring the Contribute Workspace
- The Contribute workspace .............................................................................................. 22
- Switching between browsing and editing ....................................................................... 25
- Browsing to web pages .................................................................................................... 26
- Opening pages without browsing .................................................................................... 26
- Setting up access to commonly used pages .................................................................... 28
- Setting Contribute preferences ...................................................................................... 30
- Changing or disabling the Contribute startup password ............................................... 31
- Setting browser encoding ............................................................................................... 31
- Using Contribute accessibility features ......................................................................... 32

### CHAPTER 4: Working with Pages
- About working with pages .............................................................................................. 36
- Editing existing web pages .............................................................................................. 39
- Saving drafts .................................................................................................................... 41
- Getting drafts and files reviewed by others ..................................................................... 42
- Working with pages based on Dreamweaver templates ............................................... 48
- Using Contribute to work offline .................................................................................. 50
- Editing web page content in an external application ...................................................... 52
- Adding Google search functionality to your web page .................................................. 53
# Contents

- Editing web page source in an external application ........................................ 53
- Canceling a draft or new page ........................................................................ 54
- Deleting a web page ..................................................................................... 55
- Exporting a Page (Windows only) ................................................................. 55
- Printing a page ............................................................................................. 56

## CHAPTER 5: Adding Pages and Documents .................................................... 57
- About converting documents with FlashPaper ........................................... 57
- Creating or copying a page on your website ................................................. 58
- Creating a stand-alone web page ................................................................. 63
- Setting page properties ............................................................................. 64
- Adding keywords and a description for a page ............................................. 65
- Converting documents with FlashPaper ..................................................... 66
- Adding Microsoft Word and Excel documents to a website ....................... 71

## CHAPTER 6: Working with Text ................................................................. 73
- About HTML and CSS styles in the Contribute Style menu ....................... 73
- Adding text to a web page ......................................................................... 74
- Changing text appearance on the page ..................................................... 76
- Positioning text on the page .................................................................... 82
- Creating lists .............................................................................................. 83
- Checking spelling ..................................................................................... 88
- Finding and replacing text ...................................................................... 89

## CHAPTER 7: Working with Images and Graphical Elements ....................... 91
- About inserting images and buttons ........................................................... 92
- Adding an image to a page ...................................................................... 93
- Inserting shared assets into a web page .................................................... 96
- Changing image properties ..................................................................... 97
- Changing an image's position or orientation .......................................... 98
- Editing an image in Contribute ................................................................. 100
- Editing an image in an external application ........................................... 104
- Inserting Flash content into your web page .......................................... 105
- Inserting a movie into your web page ................................................... 106
- Adding and deleting a horizontal rule ..................................................... 107
- Inserting PayPal e-commerce buttons ..................................................... 109

## CHAPTER 8: Working with Tables ............................................................. 111
- About conflicts in table formatting .......................................................... 111
- Inserting a table on a page ...................................................................... 112
- Selecting table elements ....................................................................... 113
- Resizing tables, rows, and columns ....................................................... 115
- Aligning tables ....................................................................................... 116
- Cutting, copying, and pasting cells ....................................................... 117
- Adding, deleting, and merging table rows and columns ...................... 119
- Modifying table appearance ................................................................. 121
- Sorting tabular data ............................................................................... 126
<table>
<thead>
<tr>
<th>CHAPTER 9: Working with Links</th>
<th>127</th>
</tr>
</thead>
<tbody>
<tr>
<td>Creating text and image links</td>
<td>127</td>
</tr>
<tr>
<td>Setting the advanced linking options</td>
<td>137</td>
</tr>
<tr>
<td>Editing links</td>
<td>142</td>
</tr>
<tr>
<td>Testing links</td>
<td>144</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>CHAPTER 10: Working with Pages with Frames</th>
<th>145</th>
</tr>
</thead>
<tbody>
<tr>
<td>About frames</td>
<td>145</td>
</tr>
<tr>
<td>Editing frame content</td>
<td>147</td>
</tr>
<tr>
<td>Saving and publishing a page with frames</td>
<td>148</td>
</tr>
<tr>
<td>Targeting frame content</td>
<td>149</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>CHAPTER 11: Publishing Your Page</th>
<th>151</th>
</tr>
</thead>
<tbody>
<tr>
<td>About the Rollback feature</td>
<td>152</td>
</tr>
<tr>
<td>Previewing a page in your default browser</td>
<td>152</td>
</tr>
<tr>
<td>Publishing a page to your website</td>
<td>152</td>
</tr>
<tr>
<td>Publishing a file from your computer to your website</td>
<td>157</td>
</tr>
<tr>
<td>Replacing a file on your website</td>
<td>158</td>
</tr>
<tr>
<td>Rolling back to a previous version of a page</td>
<td>160</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>PART II: Administering Contribute</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>CHAPTER 12: Learning to Administer Contribute</td>
<td>165</td>
</tr>
<tr>
<td>Intended audience</td>
<td>165</td>
</tr>
<tr>
<td>Typographical conventions</td>
<td>166</td>
</tr>
<tr>
<td>Learning to administer Macromedia Contribute</td>
<td>166</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>CHAPTER 13: Deploying Contribute to Departments and Enterprises</th>
<th>169</th>
</tr>
</thead>
<tbody>
<tr>
<td>Contribute deployment responsibilities</td>
<td>170</td>
</tr>
<tr>
<td>Deployment tasks</td>
<td>171</td>
</tr>
<tr>
<td>Deployment issues</td>
<td>172</td>
</tr>
<tr>
<td>User management models</td>
<td>185</td>
</tr>
<tr>
<td>Contribute user roles</td>
<td>185</td>
</tr>
<tr>
<td>Contribute and website security</td>
<td>187</td>
</tr>
<tr>
<td>Website connection distribution</td>
<td>190</td>
</tr>
<tr>
<td>Deploying Contribute across an organization</td>
<td>190</td>
</tr>
<tr>
<td>The draft review process and site structure</td>
<td>191</td>
</tr>
<tr>
<td>Content design considerations</td>
<td>193</td>
</tr>
<tr>
<td>Contribute Publishing Server</td>
<td>198</td>
</tr>
<tr>
<td>Contribute case studies</td>
<td>198</td>
</tr>
<tr>
<td>Resources</td>
<td>205</td>
</tr>
</tbody>
</table>
Learn how to use Contribute to update and publish web pages within your website.

This part contains the following chapters:

Chapter 1: Welcome to Macromedia Contribute ....................... 11
Chapter 2: Getting Started ........................................... 15
Chapter 3: Exploring the Contribute Workspace ...................... 21
Chapter 4: Working with Pages ....................................... 35
Chapter 5: Adding Pages and Documents .............................. 57
Chapter 6: Working with Text ......................................... 73
Chapter 7: Working with Images and Graphical Elements .......... 91
Chapter 8: Working with Tables ....................................... 111
Chapter 9: Working with Links ........................................ 127
Chapter 10: Working with Pages with Frames ......................... 145
Chapter 11: Publishing Your Page .................................... 151
CHAPTER 1
Welcome to Macromedia Contribute

Macromedia Contribute enables users to easily create and edit web pages on existing websites. Whether you’re using Contribute to update web pages or to manage the website, you’ll find Contribute a very useful tool for browsing, editing, and publishing content to a website.

This chapter contains the following sections:

• “Website development and maintenance overview” on page 11
• “Contribute resources” on page 12
• “Where to start” on page 14

Website development and maintenance overview

Contribute works with your existing website, whether it’s an intranet or a public website. It often takes a team of people to get a website up and running and to keep the content current.

The team may include the following people:

Web developers create the website. The web developer (or design team) uses a website-creation application, such as Macromedia Dreamweaver, to build the website. This person is responsible for planning, designing, developing, testing, and publishing the website. For some websites, the developer might use templates to maintain a consistent look and feel across the website.

Dreamweaver web developers should see Dreamweaver Help for more information.

Contribute users maintain the website. These are the marketers, managers, educators, students, small business owners, administrative assistants, project managers, and so on, who use Macromedia Contribute to keep their websites up-to-date. The user needs no experience in HTML or web design. Because Contribute works like a word processor, the user experience is intuitive and familiar. Users can add or update text, images, tables, links, and Microsoft Word and Excel documents.

This guide is designed for Contribute users.
Contribute administrators set up Contribute users and help them use Contribute to maintain the website. The Contribute administrator is also responsible for setting folder and user permissions, which determine who can edit website content and what contents they can edit. Only one Contribute administrator can be designated for each website in Contribute. However, more than one person can administer the website if the Contribute administrator shares the administration password for the website.

Contribute administrators can find more information in Administering Contribute.

Contribute resources

Contribute includes media resources to help you learn the program quickly. These resources include a Quick Start guide, a How Do I panel, a tutorial, and an online help system. In addition, you can find regularly updated tips, TechNotes, examples, and information at the Contribute Support Center at www.macromedia.com/support/contribute.

Note: Contribute administrators can access additional resources for Contribute Publishing Server. For information, see “About Contribute Publishing Server Help” on page 167 and “About the Deploying Contribute Publishing Server PDF” on page 167.

For information on which resources to use first, see “Where to start” on page 14. For information on conventions used in the resources, see “Typographical conventions in the Contribute resources” on page 13.

Contribute Quick Start

The Contribute Quick Start guide helps you get started with Contribute. The guide provides instructions on installing Contribute, connecting to your website, and completing common Contribute tasks. Use this guide to learn the basics.

To view the guide, select Help > Quick Start Guide.

Contribute How Do I panel

The Contribute How Do I panel in the sidebar provides quick step-by-step instructions on completing some common Contribute tasks. If you don’t find a task in the How Do I panel, or if you need more information about a task, use Contribute Help to get more detailed information.

Contribute tutorial

The Contribute tutorial guides you through representative Contribute tasks, step by step. As you complete the tutorial, you’ll update the web pages of a sample website and quickly become familiar with Contribute features.

A link to information on the tutorial appears on the Start page when you first start Contribute. The tutorial is available in the How Do I panel in the sidebar. Click the Contribute Tutorial link to start the tutorial.

When you install Contribute, the sample website for the tutorial is copied to your computer at: c:\documents and settings\yourname\Application Data\Macromedia\Contribute\Configuration\Content\Tutorial.
Contribute Support Center

The Contribute Support Center (www.macromedia.com/support/contribute/) is updated regularly with the latest information on Contribute, plus examples, tips, TechNotes, and other updates.

Contribute Help

Contribute Help provides comprehensive information about all Contribute features, optimized for online reading. Contribute Help appears in the help viewer provided by your operating system: Microsoft HTML Help (Windows) or Help Viewer (Macintosh).

The Contribute online help system has two sections: Using Contribute, for Contribute users, and Administering Contribute, for Contribute administrators.

To use Contribute Help:

1. Select Help > Macromedia Contribute Help or click the Help button in any dialog box for information about that dialog box.
   
   *Note:* A PDF version of Contribute Help is included on your Contribute CD.

2. Use any of these features to find information in the help system:
   
   ■ Use the table of contents to see all the information organized by subject. Click top-level entries to view subtopics.
   ■ Use the index to look up specific terms or concepts. It is organized like a traditional book index.
   ■ Use the search feature to find instances of a term or topic. Type any character string in the Search text box to find that text anywhere in the help system.
   ■ Use the Previous and Next arrows to move through the topics in a section.

Typographical conventions in the Contribute resources

The following typographical conventions are used in this guide:

- Menu commands are shown in this format: Menu name > Menu command. Commands in submenus are shown in this format: Menu name > Submenu name > Menu command.
- Code font indicates HTML tag and attribute names, as well as literal text used in examples.
- Italic code font indicates replaceable items (sometimes called metasymbols) in code.
- **Bold roman text** indicates menu selections, option names, button and icon names, and text that you should enter verbatim.
Where to start

Your role on the website team determines which Contribute resources you start with and use regularly.

**Contribute administrators** should start with the Quick Start guide to install Contribute and help users get connected. As you work with Contribute, refer to the How Do I panel to complete common administration tasks quickly, and use the online help to get detailed information about Contribute administration tasks and features.

**Contribute users** should start with the Quick Start guide to understand how to complete basic tasks. Then complete the tutorial to update some sample web pages and learn more about Contribute. As you work with Contribute, refer to the How Do I panel to complete common tasks quickly, and use the online help to get detailed and complete information about Contribute tasks and features.

For more information about all the resources, see “Contribute resources” on page 12.
If Macromedia Contribute is not already installed on your computer, you need to install it. Before you install it, be sure that your computer meets the minimum setup requirements.

Before you can use Macromedia Contribute to edit and update your website content, you must create a connection to the website—actually, to the web server that stores your website. By creating a connection, you enable Contribute to access the web pages on your website, and you can then edit pages and publish any changes you make.

In most cases, your Contribute administrator sets up Contribute for you or provides the information you need to connect to your website. Your Contribute administrator is the first person to contact if you have questions about connecting to your website.

This chapter contains the following sections:

- “The Contribute workflow” on page 15
- “Setup requirements” on page 16
- “Installing and starting Contribute” on page 16
- “Connecting to a website” on page 17
- “Starting Contribute without a network connection” on page 18

The Contribute workflow

Contribute uses a browse-edit-publish workflow to help you easily find the page you want to edit, make changes to the page, and then update the page on your website.

**Note:** You must connect to a website before you can edit and publish pages on that website. For more information, see "Connecting to a website" on page 17.

Here’s an overview of the Contribute workflow:

1. **Browse to a page.** Use the Contribute browser to find the web page you want to edit. The browser’s behavior, as well as its look and feel, will be familiar to users of Microsoft Internet Explorer and other popular browsers. The browser toolbar has the normal navigation buttons plus a Choose button to help you navigate to files that aren’t linked on your website. You can create bookmarks in Contribute and view your Internet Explorer bookmarks. You can also use shortcuts to view current drafts quickly.
2. Edit your content. After you browse to the page you want to edit, click the Edit Page button in the toolbar to open the page in the Contribute editor. Contribute copies the file from your web server and locks it on the server so that no one else can edit the page while you’re working on it.

The Contribute editor works much as a word processor does. You can edit text, images, tables, and links on the page, and you can even add Microsoft Word or Excel documents to your website. The toolbar contains familiar editing buttons, plus buttons for saving your edits until later, canceling your edits, or publishing your edits to the website.

3. Publish the changes. When you finish editing your page, you are ready to publish the page to your website. Simply click the Publish button, and Contribute replaces the existing page on your web server with your edited version so that it is live on your website. Contribute also unlocks the file on the server so that other users can edit the page if necessary.

Note: Depending on your role, you might not be able to publish. In that case, you should use the Send for Review option to transfer the draft to another user.

Setup requirements

Before you install Contribute, make sure your computer meets the minimum hardware and software requirements.

Your computer must be connected to the Internet. If you are connecting to the Internet from a business location, you may be connecting through a local area network (LAN). Many home or small business computers connect to the Internet through an Internet service provider (ISP), such as Earthlink or America Online. If you can read e-mail or browse the web, you have an Internet connection.

In addition to having an Internet connection, you need the system requirements to run Contribute. For more information, see www.macromedia.com/go/contribute_sysreqs.

Installing and starting Contribute

Before you install Contribute, make sure your computer meets the minimum system requirements (see “Setup requirements” on page 16). Then you are ready to install and start Contribute.

To install and start Contribute:

1. Insert the Contribute CD into your computer CD drive.
   The Contribute installer starts.
2. Follow the onscreen instructions for installing the application.
3. When the installation is complete, double-click the Contribute icon on your desktop to start Contribute.

   Note: You can require a startup password for Contribute in Preferences. For more information, see “Setting Contribute preferences” on page 30.

4. The first time you start Contribute you’ll see the Product Activation screen. Enter your product serial number, and click Next to activate Contribute.
   Now you’re ready to start using Contribute.
Connecting to a website

Contribute lets you connect to your website quickly and easily. Your Contribute administrator will do one of the following to help set up a connection for you:

- Send you an e-mail message with a website connection key file (see “Using a website connection key” on page 17).
  
  The connection key contains all the network information that Contribute needs to connect to your website.

- Give you the necessary connection information and have you enter the information in the Connection Wizard (see “Creating a Contribute website connection” on page 211).

If you are using a Macintosh and have a .Mac account, Contribute detects the .Mac account and asks if you want to create a connection to it.

If your website is managed by Contribute Publishing Server, your administrator will send you a connection key or give you connection information to enter in the Contribute browser address bar.

Using a website connection key

Your Contribute administrator might provide a connection key, which you can use to establish a connection to your website. The connection key contains all the network information that Contribute needs for connecting to your website.

The Contribute administrator will send you an e-mail message with the key. The connection key is either a file or a URL.

*Note:* Your Contribute administrator might give you the network location from which to download the connection key instead of sending you an e-mail message.

To import a website connection key:

1. Open the e-mail message containing the connection key.
   
   The connection key is attached as a file.

2. Double-click the connection key.

3. Do one of the following:
   
   ■ If the Import Connection Key dialog box appears, enter your name, your e-mail address, and the password for the connection key, and then click OK.
   
   ■ If the Log in to Publishing Server dialog box appears, enter your user name and password, and then click OK.

   *Note:* If you don’t know the password, contact the Contribute administrator who sent you the connection key.

4. If you are prompted for other connection information, such as FTP, type that information, and then click OK.

   When the connection is complete, the home page of the website appears in the Contribute browser.
Entering a Contribute startup password

If the Require Contribute startup password option is selected in the Security category of Preferences, Contribute prompts you for your startup password when you start the program.

A startup password protects unauthorized users from publishing pages to your website. After you enter the correct startup password, you can make updates and publish changes to the connected websites until you close Contribute.

In addition to providing secure access, when the Require Contribute Startup password option is selected, Contribute uses a stronger encryption method when saving your connection information on your computer.

Note: If you receive a connection key that requires a Contribute startup password, you must create a startup password before you can import that connection.

To enter a Contribute startup password:
1. In the Enter Password dialog box, type the Contribute startup password.
   You can enter the password incorrectly only three times before Contribute locks you out. If you are locked out, you can restart Contribute and reenter the startup password.
   If you forget your password, you have to delete all of your website connections and add them again.
2. Click OK.
   Note: If you click Skip, you bypass the password prompt and Contribute starts. When you skip the password, you can only edit or cancel existing drafts for the website. You won’t be able to edit pages other than drafts, or publish changes to drafts until you restart Contribute and enter the correct startup password.

Starting Contribute without a network connection

When you start Contribute, it checks your network connection so that it can connect to your website. Contribute alerts you if it does not detect a connection.

If you start Contribute without a network connection and receive the Connection Failure alert, you have two choices:

- Select Work Offline if you know that you’re not connected to the network and you want to work offline. For more information, see “Using Contribute to work offline” on page 50.
- Select Try to Connect Anyway if you aren’t sure what the problem is and you want Contribute to try to connect again. If Contribute still cannot connect, you can disable the website and continue checking your other website connections, if any. For more information, see “Disabling your website at startup” on page 19.

For more information about solving connection problems, see Chapter 16, “Troubleshooting,” on page 259.
Disabling your website at startup

Contribute alerts you if it detects a problem with any of your website connections when it starts. Contribute displays the alert after the first website connection problem it encounters.

You can have Contribute try to connect again. If Contribute still can’t connect, you can disable the website connection and try to connect to your other websites, if any. If you disable a website, you can enable it after you resolve your network connection problem.

*Note:* You can disable a website at any time—not just at startup—when there’s a problem. If you have multiple websites, you can disable websites that you aren’t currently working on, so that Contribute does not maintain the connection for an extended period of time. For more information, see “Disabling website connections” on page 236.

**To disable a website when your network connection fails:**

1. Start Contribute.
   
   The Connection Failure dialog box appears.
2. Select **Try to Connect Anyway** to force Contribute to continue checking for a network connection.
3. If Contribute still fails to connect, Contribute displays an error message with two options:
   - Click **Yes** to continue trying to connect to other websites.
   - Click **No** to disable the rest of your websites.
4. Click **OK**.

**To enable a disabled website:**

1. Browse to any page in the website, and then click **Connect** in the toolbar.
2. Select **Edit > My Connections** (Windows) or **Contribute > My Connections** (Macintosh).
   
   The My Connections dialog box appears.
3. Select a disabled website from the list, and then click **Enable**.
4. Click **Close**.
You can use Macromedia Contribute as a web browser and as a web page editor. You can easily switch between browsing web pages and editing web pages. The Contribute workspace makes it easy for you to access pages, whether you're browsing or editing.

You can navigate the Contribute dialog boxes and workspace without using your mouse. You can also set preferences to customize Contribute.

This chapter includes the following sections:

- “The Contribute workspace” on page 22
- “Switching between browsing and editing” on page 25
- “Browsing to web pages” on page 26
- “Opening pages without browsing” on page 26
- “Setting up access to commonly used pages” on page 28
- “Setting Contribute preferences” on page 30
- “Changing or disabling the Contribute startup password” on page 31
- “Setting browser encoding” on page 31
- “Using Contribute accessibility features” on page 32
The Contribute workspace

The Contribute workspace has three main areas: the Contribute browser/editor, the toolbar, and the sidebar.

The Contribute browser/editor

The main window in Contribute is used for browsing and editing. If you are not sure whether you are browsing or editing in Contribute, look at the toolbar. The toolbars are different when you are browsing and when you are editing a draft (see “The Contribute toolbars” on page 22). When you use the Contribute browser, you can browse to any web page—not just to pages on your website. The Contribute browser functions as a true web browser: Simply click links in web pages to browse to the page you want to edit. You can also create bookmarks to pages that you visit frequently.

When you use the Contribute editor, you can edit pages in websites you have connected to (see “Connecting to a website” on page 17). You can edit text, images, tables, links, and even pages with frames. Then, you can publish your changes to make the updated web page live on your website.

It’s easy to browse and edit in Contribute, and to switch between browsing and editing. For more information, see “Switching between browsing and editing” on page 25.

The Contribute toolbars

The Contribute toolbar changes according to whether you are browsing or editing a page. When you are editing, the editor toolbar enables you to edit text or images, depending on the content you’ve selected.
Depending on the role the Contribute administrator assigned you, some buttons in the toolbars might not be enabled for you.

The browser toolbar contains buttons for navigating your website or creating a new page.

The editor toolbar contains buttons for common operations from the File, Insert, Format, and Table menus.

The text formatting toolbar contains buttons for formatting text.

Note: If your Contribute administrator has restricted editing to text only, some formatting options are not available. Also, options might be disabled if a Cascading Style Sheet has been applied to a text selection.

The image editing toolbar contains buttons for editing images.
The Contribute sidebar

The Contribute sidebar makes it easy to switch between editing and browsing, and gives you quick access to your drafts. You can also use the sidebar to get quick instructions for performing tasks in Contribute.

The sidebar has two parts:

- **The Pages panel** gives you access to the web browser and all drafts you’re currently editing. There is also a link to the Draft Console, which shows the status of your drafts.

  *Note:* The Draft Console is not available if your website doesn’t have an administrator assigned.

- **The How Do I panel** provides quick step-by-step instructions to help you complete some common Contribute tasks. The panel shows a list of browsing tasks while you are browsing, and a list of editing tasks while you are editing.

Click any link in the How Do I panel in the sidebar to get more information on that task. If the task you’re looking for is not in the list, see Contribute Help (Help > Macromedia Contribute Help) to get detailed information.

*Note:* For more information about using Contribute resources to get help, see “Contribute resources” on page 12.

You can expand, collapse, or resize the panels and the sidebar.

**To expand or collapse the sidebar,** do one of the following:

- Select View > Sidebar.
- In Windows, click the arrow on the splitter bar between the sidebar and the Contribute browser/editor.
- On the Macintosh, double-click the grabber on the splitter bar between the sidebar and the Contribute browser/editor.
To resize the sidebar:
• Drag the splitter bar between the sidebar and the Contribute browser/editor.

To expand or collapse a panel in the sidebar:
• Double-click the panel title bar.

To resize panels vertically in the sidebar:
• Drag the title bar in the How Do I panel.

Switching between browsing and editing

You can use Contribute to browse or edit web pages. You can switch between browsing and editing at any time. When you leave a draft you’re editing, Contribute saves your changes so that you can return to the draft later and continue editing where you left off.

When you switch to browsing, Contribute does not publish your draft. While you are browsing the page, the message area advises you that you have an unpublished draft of the page.

If you are not sure if you are browsing or editing in Contribute, look at the toolbar. When you are browsing, you’ll see the browser toolbar, with the Edit Page (or Create Connection) button and when you are editing, the editor toolbar appears (see “The Contribute toolbars” on page 22).

To switch from browsing to editing, do one of the following:
• Click the Edit Page button in the toolbar.

  ![Edit Page](Edit.png)

  *Note:* Edit Page is enabled only for pages in a website that you are connected to and that you have permission to edit.

• Click a draft title in the Pages panel in the sidebar.

  ![MyPage](MyPage.png)

To switch from editing to browsing, do one of the following:
• Click Browser in the Pages panel in the sidebar.

  ![Browser](Browser.png)

• Click the Save for Later button in the toolbar.

  ![Save for Later](Save for Later.png)

• Select View > Browser.
Browsing to web pages

The easiest way to find a web page you want to edit is to browse to the page in Contribute, just as you would browse to a page in any web browser.

Tip: See "Opening pages without browsing" on page 26 to learn other ways to find your web pages.

Note: (Windows only) If you use Microsoft Internet Explorer as your primary web browser, the Contribute browser inherits preferences from Internet Explorer. To change basic settings, such as fonts, cookies, or plug-ins, change your preferences in Internet Explorer; then start Contribute again.

You can browse to any website with Contribute, but you can edit only pages that are in your websites; that is, websites that you’ve created connections to (see “Connecting to a website” on page 17). When you browse to a page that is in your website and that you have permission to edit, the Edit Page button is enabled in the toolbar.

To browse to a web page in Contribute, do one of the following:
• Click links in web pages to navigate to other pages.
• Type the web address (URL) of the page in the Address text box; then click Go. You can also press Enter or Return.
• Select View > Go to Web Address, enter the web address (URL), and click OK.

Related topics
• “Editing existing web pages” on page 39

Opening pages without browsing

Contribute gives you quick access to the following pages:
• Current drafts
• Home pages of the websites you are connected to
• Recently published pages
• Pages or files that aren’t linked from another page on your website
Viewing drafts and new pages

The Pages panel displays the names of drafts you are currently editing. You can also access drafts from the File menu.

To view a draft, do one of the following:

- Click the title of the draft in the Pages panel in the sidebar.
- Select File > Drafts, and then select a draft from the pop-up menu.

Viewing home pages for your websites

You can use the toolbar to view the home pages for all your websites. The View menu also gives you access to these pages.

To view the home page for a website you’re connected to, do one of the following:

- Click the Home Pages button on the toolbar, and then select a home page.
- Select View > Home Pages, and then select a home page from the pop-up menu.

Viewing recently published pages

The File menu gives you quick access to pages you’ve recently published.

To view a recently published page:

- Select File > Recent Pages, and then select a page from the pop-up menu.
Viewing pages and files that you can't browse to

Contribute gives you access to pages and files that are associated with your website but that you can't browse to. Use the Choose button in the toolbar to view pages and files that are saved in a website folder but aren't linked from any page on your website.

**To view a page or file that is not linked from another page:**
1. In the Contribute browser or editor, select View > Choose File on Website or click the Choose button in the browser toolbar.
   The Choose File on Website dialog box appears.
2. Select a file by doing one of the following:
   ■ If the file is in a folder on the website you are currently browsing, then select a file.
   ■ If the file is not in a folder on the current website, use the Look In pop-up menu to navigate to the correct website folder, and then select a file.
   Depending on the type of the file you select, a preview may appear so that you can confirm that you’re selecting the correct file.
3. Click OK.
   The page or file appears in the Contribute web browser.

   **Note:** If you select a file type that the Contribute browser can’t display, you’ll see the File Placeholder page.

Setting up access to commonly used pages

Contribute lets you keep a list of bookmarks for pages that you visit frequently. You can add a bookmark for any page—not just pages in websites you’re connected to.

Viewing pages in your bookmarks list

You can select pages in your list of bookmarks to quickly view those pages.

In Windows, Contribute also includes your Internet Explorer bookmarks (up to 2000 bookmarks) in the Other Bookmarks list under your Contribute bookmarks.

**To view a page in your list of bookmarks, do one of the following:**
- To view a Contribute bookmark, select the Bookmarks menu, and then select a bookmark from the list.
- (Windows only) To view an Internet Explorer bookmark, select Bookmarks > Other Bookmarks, and then select a bookmark from the list.

Related topics
- “Deleting a page from your bookmarks” on page 29
Adding a page to your bookmarks

You can add any web page—not just pages in websites you’re connected to—to your bookmarks list. You can have up to 1000 bookmarks.

To add a page to your list of bookmarks:
1. Browse to the page you want to add to your bookmarks list.
2. Select Bookmarks > Add Bookmark.
   The Add Bookmark dialog box appears.
3. If you want to change the name of the bookmark, enter a new name in the Name text box.
   This is the name that appears in your bookmarks list.
4. If you want to add the page to a folder, click an existing folder name or click New Folder to add a folder.
5. Click OK.
   Contribute adds the page to your bookmarks list in the Bookmarks menu.

Related topics
• “Viewing pages in your bookmarks list” on page 28

Deleting a page from your bookmarks

You can delete any page from your bookmarks list, or you can delete a bookmarks folder.

To delete a bookmark:
1. Select Bookmarks > Delete Bookmark.
   The Delete Bookmark dialog box appears.
2. Select the name of the bookmark or the folder you want to delete.
3. Click Delete.
   Contribute removes the page from your bookmarks list in the Bookmarks menu.
4. If you want to delete another bookmark or folder, select it, and then click Delete again.
5. Click Close when you finish deleting bookmarks.

Related topics
• “Viewing pages in your bookmarks list” on page 28
• “Adding a page to your bookmarks” on page 29
Setting Contribute preferences

You use the Preferences dialog box to set your user preferences for Contribute. You can set preferences for general editing, file editors, firewall settings, invisible elements, and password security.

To edit user preferences:

1. Select **Edit > Preferences** (Windows) or **Contribute > Preferences** (Macintosh).

   The Preferences dialog box appears.

2. Select a category from the list on the left:
   - Select **Editing** to set general editing options, such as how Contribute handles table editing, or to select a spelling dictionary.
   - Select **File Editors** to select primary application editors by file type.
   - Select **FTP Proxy** to add or change settings for your FTP proxy server.
   - Select **Invisible Elements** to hide or show invisible elements.
   - (Windows only) Select **Microsoft Office Documents** to determine how Contribute handles Office documents.
   - Select **Security** to set up a Contribute startup password.
Changing or disabling the Contribute startup password

You can change your Contribute startup password as often as you like. Before you can change the startup password, you must first successfully enter the current Contribute startup password and start Contribute.

If the Require Contribute startup password option is selected in the Contribute Preference dialog box, you must enter the correct password to start Contribute and edit website pages. If you forget or don’t know the Contribute startup password, you can’t use Contribute to edit pages unless you disable the Contribute startup password requirement. Before you can change the startup password requirement, you must remove all your existing website connections.

To change the Contribute startup password:
1. Select Edit > Preferences (Windows) or Contribute > Preferences (Macintosh).
   - The Preferences dialog box appears.
2. Select Security from the category list on the left.
3. Type the new password, and then type the new password again.
4. Click OK.

To disable a Contribute startup password:
1. Select Edit > My Connections (Windows) or Contribute > My Connections (Macintosh).
2. Under Website Name, select a website connection, and then click Remove.
   - Note: You might have to cancel any unpublished drafts before removing the website connections.
3. Repeat step 2 until you remove all website connections.
4. Click Close.
5. Select Edit > Preferences (Windows) or Contribute > Preferences (Macintosh).
6. In the Preferences dialog box, select Security.
7. Deselect the Require Contribute startup password option.
8. Click OK.

Setting browser encoding

To specify how a page should appear in the Contribute browser, you can set the browser encoding for that page. You might need to set encoding if characters aren’t displayed properly in the Contribute browser.

To change browser encoding:
1. In the Contribute browser, right-click (Windows) or Control-click (Macintosh) on the page.
2. Select Encoding, and then select an option from the pop-up menu.
Using Contribute accessibility features

Accessibility refers to making websites and web products usable by people with visual, auditory, motor, and other disabilities. Contribute provides features that make it accessible to users with disabilities.

Using screen readers with Contribute

A screen reader recites text that appears on the computer screen. It also reads nontextual information, such as button labels or image descriptions.

You can use a screen reader when you edit your web pages. The screen reader starts reading at the upper left corner of the application.

Contribute supports the following screen readers:
- JAWS for Windows, from Freedom Scientific (www.freedomscientific.com)
- Window Eyes screen readers, from GW Micro (www.gwmicro.com)

Related topics
- “Using the keyboard to navigate Contribute” on page 32
- “Authoring for accessibility” on page 34

Using operating system accessibility features

Contribute supports the Windows operating system high-contrast setting. You activate this setting through the Windows Control Panel.

When high contrast is on, Contribute responds as follows:
- Dialog boxes and panels use system color settings.
  For example, if you set the color to White on Black, then all Contribute dialog boxes and panels appear with a white foreground color and black background.
- The Contribute editor uses the background and text colors you set in Format > Page Properties so that your pages render colors as a website visitor’s browser will render them.

Related topics
- “Using screen readers with Contribute” on page 32
- “Authoring for accessibility” on page 34

Using the keyboard to navigate Contribute

While you are editing, you can use the keyboard to navigate the Contribute workspace, dialog boxes, and tables without a mouse.

You can also use keyboard shortcuts to open some dialog boxes and perform some commands. For a list of shortcuts, see “Windows Keyboard Shortcuts” on page 277.

Related topics
- “Using screen readers with Contribute” on page 32
Navigating the workspace

You can use keyboard shortcuts to navigate the Contribute workspace—that is, to select commands from the menus and to switch between the Contribute browser and editor. For a complete list of Contribute keyboard shortcuts, see “Windows Keyboard Shortcuts” on page 277. All the items in the Pages panel and toolbar are accessible through the menus. To view task information in the How Do I panel, use Contribute Help (Help > Macromedia Contribute Help).

To use the keyboard to switch from the Contribute browser to the editor, do one of the following:

• Press Control+Shift+E (Windows) or Command+Shift+E (Macintosh), to edit the current page.
  
  **Note:** This has the same effect as clicking the Edit Page button in the toolbar.

• (Windows Only) Press Alt+F, press Alt+F again, and then use the arrow keys to select a current draft or new page from the pop-up menu.
  
  The drafts and new pages listed in the Pages panel appear in this list.

To use the keyboard to switch from the Contribute editor to the browser:

• Press Control+Shift+B (Windows) or Command+Shift+B (Macintosh).

  **Note:** This has the same effect as clicking Browser in the Pages panel.

Related topics

• “Navigating tables” on page 34

Navigating dialog boxes

You can use the keyboard to navigate dialog boxes.

To navigate a dialog box:

• To move through dialog box options, press Tab.
  
  On the Macintosh, pressing Tab moves the insertion point from one text field to the next.

• To accept a choice and exit the dialog box, press Enter or Return.

• To close the dialog box without making any changes, press Escape or Alt+F4 (Windows).

• (Windows Only) To move through choices for an option, use the arrow keys.
  
  For example, if an option has a pop-up menu, move focus to that option, then use the Down Arrow key to move through the choices.

• (Windows Only) To move through a category list, press Control+Tab to shift focus to the category list, and then use the arrow keys to move up or down the list.

  To see an example of a category list, select Edit > Preferences.
• (Windows Only) To shift to the options for a category in a category list, press Control+Tab.

Related topics
• “Navigating the workspace” on page 33

Navigating tables
After you select a table, you can use the keyboard to navigate through it.

To navigate a table:
1. In the Contribute editor, do one of the following to select the table:
   ■ If the insertion point is to the left of the cell, press Shift+Right Arrow.
   ■ If the insertion point is to the right of the cell, press Shift+Left Arrow.
2. Press the Down Arrow key to position the insertion point in the first cell.
3. Use the arrow keys or press Tab to move to other cells as necessary.
   Tip: Pressing Tab in the rightmost cell of a row adds another row to the table.
4. To select a cell, press Control+A (Windows) or Command+A (Macintosh) while the insertion point is in the cell.
5. To exit the table, use the Select Table Cell command (Control+A) or Command+A (Macintosh); then press the Up, Left, or Right Arrow key.

Related topics
• “Navigating the workspace” on page 33
• “Navigating dialog boxes” on page 33

Authoring for accessibility
It’s important to make your web pages accessible to all your website visitors.

The U.S. government and other organizations have established accessibility legislation and guidelines. For more information about two significant initiatives, see the World Wide Web Consortium Web Accessibility Initiative (www.w3.org/wai) and Section 508 of the Federal Rehabilitation Act (www.section508.gov).

Also, as you edit your pages, remember that some visitors will be using screen readers. Contribute helps you make your images and tables more accessible in the following ways:

• You can add text that screen readers will recite to describe images on your pages. Your Contribute administrator can have Contribute prompt you for descriptive text whenever you insert an image. For more information, talk to your Contribute administrator or see “Setting page-editing and paragraph settings” on page 249.
• You can include table headings to be recited by screen readers. To insert tables with headings, see “Inserting a table on a page” on page 112.

Note: Screen readers do not read boldface headings centered in a row or column.
Macromedia Contribute enables you to edit existing pages and content on your website. You can cancel your edits or cancel a new page if you need to. If you have permission, you can delete pages and other files on your website. You can also export a page to an HTML file.

*Note:* For information about creating new pages, see “Creating or copying a page on your website” on page 58.

Before you publish your edits, you can send your draft to another user for review. Contribute updates the existing page on your website with your edited page when you publish the draft (see “Publishing Your Page” on page 151).

This chapter contains the following sections:

- “About working with pages” on page 36
- “Editing existing web pages” on page 39
- “Saving drafts” on page 41
- “Getting drafts and files reviewed by others” on page 42
- “Working with pages based on Dreamweaver templates” on page 48
- “Using Contribute to work offline” on page 50
- “Editing web page content in an external application” on page 52
- “Adding Google search functionality to your web page” on page 53
- “Editing web page source in an external application” on page 53
- “Canceling a draft or new page” on page 54
- “Deleting a web page” on page 55
- “Exporting a Page (Windows only)” on page 55
- “Printing a page” on page 56
About working with pages

Contribute enables you to edit existing pages on your website, including pages based on templates. You can use the draft review process or the e-mail review process to have your edits reviewed by another user before you publish.

Editing pages

You can edit pages on websites that you’re connected to (see “Connecting to a website” on page 17) and have permission to edit. You cannot edit a page if the page is locked—that is, if someone else is currently editing it. When you browse to a page, the message area under the toolbar indicates whether you can edit that page.

While you edit a page, Contribute saves it as a draft, and the draft title appears in the Pages panel in the sidebar.

For more information, see “Opening a page on your website for editing” on page 40. For information about working with drafts, see “Saving drafts” on page 41.

Note: If you want to edit a Microsoft document that you’ve linked to on your website, see “Editing web page content in an external application” on page 52.

There might be restrictions on which parts of a draft you can edit. Your template designer can create a template with locked regions or your Contribute administrator can set up editing constraints that restrict editing to text only.

Note: If you do not have permission to edit a page or part of a page that you need to edit, talk to your Contribute administrator or see “Managing Users and Roles” on page 239.

Related topics

• “Editing existing web pages” on page 39
Understanding the draft review process

The Contribute draft review process enables you to send a draft to other Contribute users to get feedback or to collaborate before you publish the draft. Or, if your role doesn't allow you to publish directly to the website, you might need to send the draft to someone who can review the draft and publish it.

You can send a draft for review to anyone who has connected to the website; Contribute stores user names when users connect to the website. You can send the draft to multiple reviewers at one time, but only one person can edit the draft at a time. When you send a draft for review, you transfer “ownership” of that draft to the reviewer. That means the reviewer has to take action on the draft. After you send a draft for review, you can track the draft to see what action the review takes on the draft.

When you receive a draft for review, it appears in your Pages panel in Contribute. You might also receive an e-mail message from the sender to alert you that you have a draft to review. As a reviewer, you can decide to edit the draft, send it to another user for review, or discard all changes by canceling the draft. Depending on your role, you might also be able to publish the draft.

---

**Draft review process**

**Related topics**
- “Using the draft review process” on page 42
Understanding the e-mail review process

The Contribute e-mail review process uses your default e-mail application to create a message containing a web address where reviewers can see a temporary copy of your draft. Contribute automatically creates the temporary copy on the same server where you publish your website. The recipient clicks the web address (URL) link in the e-mail message to view your draft.

**Note:** If you belong to a role that cannot publish, then you cannot use the e-mail review process. In that case, use the draft review process (see “Understanding the draft review process” on page 37).

When you send an e-mail review request, Contribute displays a message under the toolbar to alert you that you sent the draft for review; the message includes the date you sent the review request. You can then save the draft for later, until you get feedback from your reviewer, or you can continue editing the draft.

After reviewing your draft, the reviewer can send you feedback by e-mail. The reviewer cannot edit the review draft. You can make changes to your draft based on the reviewer’s feedback, and then publish the draft or request another review. When the draft is canceled or published, Contribute removes the temporary copy of the draft that it placed on the server for the reviewer.

**E-mail review process**

**Related topics**
- “Making your draft available for review by e-mail” on page 47

**About templates**

A Macromedia Dreamweaver template contains a preset page layout and includes elements such as text and images. A template gives you a starting point for new web pages and can ensure that the pages on your website have a consistent look.

For example, the company employee template might contain basic elements and provide sections for employee information. Suppose the template has the company logo and address, and blank sections for the employee’s name, department, phone number, and picture. Any new employee page based on the company employee template inherits the same page layout.
In a template, the designer creates regions to control which elements of a template-based page you can edit. There are *editable* regions in a template, which you can edit, and *locked* regions, which you can't edit. In the employee template example, the company logo and address might be in a locked region. The employee information sections would be editable regions.

**Related topics**
- “Working with pages based on Dreamweaver templates” on page 48

**Editing existing web pages**

You can edit any pages on your website, as long as you have permission and someone else is not currently editing the page.

For more information about editing existing web pages, see “Editing pages” on page 36.

**Related topics**
- “Setting page properties” on page 64
- “Adding keywords and a description for a page” on page 65
Opening a page on your website for editing

After you've connected to a website, you can easily open and edit pages on that website. To open a page for editing, you simply browse to the page.

To edit a page on your website:
1. Browse to the page you want to edit (see “Browsing to web pages” on page 26).
2. Do one of the following:
   ■ Click the Edit Page button in the toolbar.
   ■ Select File > Actions > Edit Page.

The page appears in the Contribute editor as a draft, and the draft title appears in the Pages panel.

Related topics
• “Editing pages” on page 36
• “Undoing mistakes” on page 41
• “Saving drafts” on page 41

Opening a page for editing that is on your computer

You can use Contribute to edit pages that aren't on a website you've connected to; you can simply open an HTML page saved on your computer and make your edits. The experience is similar to using Notepad or TextEdit, but it has the ease of use and functionality of Contribute.

For example, suppose you receive an HTML page in e-mail that you need to edit for a coworker. Even if the page isn't associated with a website you've connected to, you can save the page to your computer, open and edit the page in Contribute, and return it to your coworker.

Note: You should not create a connection to your local drive. If you do, Contribute will treat files saved on your computer as files on a website, and the Direct Edit feature will not work properly.

To edit a web page that is on your computer:
1. In the Contribute browser or editor, select File > Open.
   The Open dialog box appears.
   Note: You cannot use this feature to open and edit TXT files saved on your computer.
2. Navigate to and select the file you want to edit, and then click Open.
   The page opens as a draft in the Contribute editor; the toolbar contains Save and Close buttons instead of Publish and Cancel buttons.

Note: Administrator preferences are not applied because this page is not part of a website. If you need to enforce preferences for pages that are edited this way, see the Contribute Support Center at www.macromedia.com/go/direct_edit_settings.
Undoing mistakes

In Contribute, as in most applications, you can undo individual mistakes as you make them. You can also redo an edit if you decide that you don't want to undo it.

**Note:** In Contribute, you can also discard changes, after you publish your draft, by reverting to a previously published version of a page. For more information, see “Rolling back to a previous version of a page” on page 160.

To undo an edit:
- Select Edit > Undo.

To redo an edit:
- Select Edit > Redo.

Saving drafts

You can save a draft while you work (see “Saving a draft while you work.” on page 41), or you can save a draft and switch to another draft or to the browser (see “Saving a draft until later” on page 42).

**Saving a draft while you work.**

Contribute automatically saves a copy of your draft when you switch to the browser, switch to another draft, publish the draft, or exit Contribute; but you can also periodically save your work if you want.

When you edit a page (see “Editing existing web pages” on page 39), Contribute automatically saves the page as a draft, and the draft title appears in the Pages panel in the sidebar.

**To save a draft and continue working:**
- Select File > Save.

**Note:** When you save a new page draft for the first time, you do not give it a filename until you publish it. For more information, see “Publishing a new page” on page 154.
To save a draft that is on your computer and continue working, do one of the following:

- Click Save in the toolbar.

  **Note:** This option is only available for drafts saved on your computer, not drafts that are associated with a website.

- Select File > Save.

**Saving a draft until later**

You can save a draft you’re editing and work on another draft, switch to browsing, or close Contribute.

Contribute saves your draft whenever you leave it and keeps the draft in the Pages panel until you publish (see “Publishing Your Page” on page 151), cancel (see “Canceling a draft or new page” on page 54), or send for review (see “Using the draft review process” on page 42).

**To save a draft until later:**

1. Do one of the following to leave your draft:
   - Click Browser in the Pages panel to switch to the browser.
   - Select View > Browser to switch to the browser.
   - Click the Save for Later button in the toolbar to close the draft and switch to the browser.
   - Click another draft title in the Pages panel to edit that page.
   - Close Contribute.

2. If you closed Contribute, restart the application.

3. Click the draft title in the Pages panel to return to the draft you were previously editing.

   The draft appears in the Contribute editor for you to continue editing.

**Related topics**

- “Saving a draft while you work.” on page 41

**Getting drafts and files reviewed by others**

You can use the draft review process to get drafts and files reviewed before they are published. You can use the e-mail review process to post drafts for review.

**Related topics**

- “Understanding the draft review process” on page 37
- “Understanding the e-mail review process” on page 38

**Using the draft review process**

The Contribute draft review process enables you to easily send drafts to other Contribute users for review. You can also send files for review directly from your computer.
This review process enables you to get feedback and collaborate with others on a draft or file. Reviewers can see your draft, then edit it, publish it, and send it to another reviewer, or delete it. For more information, see “Understanding the draft review process” on page 37.

**Note:** This feature is not available unless your website has an administrator. The administrator can set publishing and deleting permissions for each user role in the draft review process. For more information, see “Setting general role settings” on page 245.

**Related topics**
- “Making your draft available for review by e-mail” on page 47

### Sending a draft for review

The Contribute draft review process enables you to send a draft to other Contribute users so that you can get feedback before you publish it. Or, if your role doesn't allow you to publish directly to the website, you might need to send the draft to someone who can review the draft and publish it.

For more information about the draft review process, see “Understanding the draft review process” on page 37.

**To send a draft for review:**

1. Click **Send for Review** in the toolbar, or select **File > Actions > Send for Review**.

   The Send for Review dialog box appears.

2. Select the **Send the draft to another Contribute user** option, and then complete the dialog box.

   You can send the draft to any user who has connected to this website.

   For information about options in the dialog box, click the Help button.

3. Click **Send**.
4. If the Send New Page dialog box appears, you can change the draft’s filename or click **Choose Folder** to save this draft in another location. Then click **Send** or **Next**.
   
   **Note:** The current folder location appears in the web address under the filename.

5. If the Send Linked New Files dialog box appears, you can click the names of the unpublished linked pages, and then change the filenames and folder location. Then click **Send All**.

Contribute sends the draft to the reviewer.

**To undo the sending of a draft:**

1. Click the **Draft Console** link in the Pages panel.

   The draft console appears.

   **Tip:** If you have just sent the draft and are still viewing it in the Contribute window, you can click the Undo Send button and skip the rest of this procedure.

2. Select a draft in the **Sent Drafts** section.

   Contribute displays the draft.

3. Click the **Undo Send** button in the toolbar.

   You can use this option if you were the last person to send the draft for review. If, however, you send the draft to someone to review, and that person sends the draft to another reviewer, you cannot retrieve the draft because you were not the last person to send it for review.

   The draft disappears from the reviewer's Pages panel and appears in your Pages panel.

**Sending a file for review from your computer**

You can send a file that is on your computer to another person to review or publish for you.

**Tip:** You can also publish a file directly from your computer, depending on the role the Contribute administrator assigned you. For more information, see "Publishing a file from your computer to your website" on page 157.

**To send a file for review directly from your computer:**

1. Select **File > Send File from My Computer for Review**.

   The Select File dialog box appears.

2. Select the file you want to add to the website, and then click **Select**.

   **Note:** You cannot select HTML files or dynamic file types, such as JSP. If you select an invalid file type, Contribute warns that you cannot select this file and provides a complete list of invalid file types.

   If you have connections to more than one website, the Select Website dialog box appears.

3. If the Select Website dialog box appears, select the website where you want to add the draft for the file for review, and then click **OK**.

   The website list includes any website you are connected to. The reviewer you want to send the file to must also be connected to the website you select.

   The Send for Review dialog box appears.
4. Select the name of the person you want to review the file you are sending from your computer, enter comments for the reviewer, and then click Send.

The Send New Page dialog box appears.

5. Change the filename if you want, or click the Choose Folder button to save this draft in another location if you want, and then click Send.

*Note:* The current folder location appears in the web address under the filename.

Contribute sends the file to the reviewer.

**Related topics**
- “Publishing a file from your computer to your website” on page 157

### Tracking your drafts

After you send a draft for review, you can track it to see what the reviewer does with the draft.

**To track your drafts:**

1. Click the Draft Console link in the Pages panel.

   *Note:* The Draft Console is not available if you don’t have a website connection that has an administrator assigned.

   The Draft Console displays links to all the drafts you have sent and all the drafts you’re editing or reviewing. Each sent draft also has status information.

   *Tip:* Contribute removes published and deleted drafts from the Draft Console every 30 days. If you would like to manually remove outdated drafts, press Control+Shift while selecting View > Refresh Drafts.

2. If you would like to view a draft, select the draft title.

   The draft appears in Contribute; you can click the Draft Console link to return to the Draft Console.

3. To update your view at any time, do one of the following:
   - Click the Refresh drafts icon in at the bottom of the Pages panel.
   - Click the Refresh button in the Draft Console.
   - Select View > Refresh Drafts.

4. When you finish viewing the Draft Console or the draft you selected, select the browser or another draft in the Pages panel.

**Related topics**
- “Sending a draft for review” on page 43
Reviewing a draft

When someone sends you a draft to review, the draft appears in your Pages panel in Contribute. You can manually refresh the Pages panel to check for drafts to review.

When you review a draft, depending on your user role, you can edit the draft, publish it, send it for review, or delete it. You can also view all the comments that previous senders have attached to the draft.

To manually retrieve drafts that have been sent to you for review, do one of the following:

• Click the Refresh Drafts icon in at the bottom of the Pages panel.
• Select View > Refresh Drafts.

If any drafts have been sent to you for review, they appear in the Pages panel.

To review a draft:

1. Select a draft in the Pages panel to review.

   The draft appears in the Contribute window for you to review; the draft status pane at the bottom of the window contains information about the draft.

   Note: If the draft status pane is not expanded, click the expander arrow at the bottom right of the Contribute window to display the pane.

2. Do one of the following:

   ■ Click the Publish button in the toolbar to make the draft live on your website.

     Note: Depending on the role the Contribute administrator assigned you, you might not be able to publish drafts.

   ■ Click the Send for Review button in the toolbar to send the draft to another reviewer.

     Note: Use this button to send to any reviewer, including the original sender.

     Complete the Send for Review dialog box, and then click Send.

   ■ Click the Edit Draft button in the toolbar to make changes to the draft.

     The draft appears in the Contribute editor. After you finish editing, click the Send for Review, Publish, or Cancel button.

     Note: Depending on the role the Contribute administrator assigned you, you might not be able to publish drafts.

   ■ Click the Delete button in the toolbar to discard this draft.

     Note: Depending on the role the Contribute administrator assigned you, you might not be able to delete drafts.
To view comments for a draft you are reviewing:
1. While you are reviewing a draft, click the expander arrow at the bottom right of the Contribute window to display the draft status pane, if it is not already showing.
2. Do one of the following:
   ■ Click the Draft History button in the draft status pane.
   ■ Select View > Draft History.
   The Draft History dialog box appears.
3. Select a sender’s name to see comments by that person.
4. To close the comments, click Close.

Making your draft available for review by e-mail
You can make the draft available for others to review—even if they don’t have Contribute.

Note: If the page to be reviewed is in a frameset, the web address is for the single page that you edited, not the entire frameset.

For more information about the e-mail review process, see “Understanding the e-mail review process” on page 38. If you belong to a role that cannot publish, then you cannot use the e-mail review process. In that case, use the draft review process (see “Understanding the draft review process” on page 37).

To use the e-mail review process:
1. In your draft, click the Send for Review button in the toolbar, or select File > Actions > Send for Review.
   The Send for Review dialog box appears.

2. Select the Send e-mail with a link to a preview of the draft option, and then click Send.
3. If the Send New Page dialog box appears, you can change the draft’s filename or click **Choose Folder** to save this draft in another location. Then click **Send** or **Next**.

   **Note:** The current folder location appears in the web address (URL) under the filename.

4. If the Send Linked New Files dialog box appears, select each unpublished linked page to change the filename and folder location as necessary. Then click **Send All**.

   Contribute creates a new e-mail message in your default e-mail application.

   On the Macintosh, Contribute works with the following default e-mail applications: Mail, Eudora, and Entourage.

   **Note:** If Contribute does not find a default e-mail application or cannot start your e-mail application, you can create the e-mail message by clicking the **Click here** link in the message area under the toolbar. Copy the web address (URL) for the draft that appears in the browser window and paste the address in an e-mail message to send to reviewers.

5. Enter the reviewer’s name and a message, and then send the e-mail message.

   In Contribute, you can work on another draft or switch to the Contribute browser until you receive feedback from the reviewer. When you receive feedback from the reviewer, click the draft title in the Pages panel to return to the draft and update it.

   **Note:** When you cancel or publish the draft, Contribute removes the temporary copy of the draft that it placed on the server for the reviewer.

**Related topics**
- “Using the draft review process” on page 42

**Working with pages based on Dreamweaver templates**

A Macromedia Dreamweaver template is a special type of page that contains a preset page layout and includes elements such as text and images. In Contribute, you can create a page based on a template. You can also edit a template-based page or edit the template properties of the page.

**Tip:** If you have a lot of templates on your website, Contribute can take longer to start. For faster startup, consider disabling your websites connections when you start Contribute. You’ll be able to work on existing drafts; you can enable your website when you’re ready to publish or edit another page. For more information, see “Disabling website connections” on page 236.

**Related topics**
- “About templates” on page 38
- “Creating a page based on a template” on page 62

**Editing a template-based page**

On a page based on a Dreamweaver template (a template-based page), there are editable regions, where you can add or edit content, and there are locked regions, where you cannot add or edit content.

**Note:** If you try to edit a locked region in a document based on a template, the pointer changes to indicate that you can’t click in that region.
When you view a template-based page, you see outlines around the editable regions. The editable regions each have a tab at the upper left giving the name of that content area. The tabs show you where you can add or update content on the page.

For example, a product template-based page might have a Title region, for the product title, and a Description region, for a product description. You add content to the appropriate sections.

You can edit the editable regions of a template-based page as you would edit any other web page.

**To edit a template-based page:**
1. Browse to the template-based page you want to edit.
2. Do one of the following:
   - Click the **Edit Page** button in the toolbar.
   - Select **File > Actions > Edit Page**.
   
   The page opens as a draft in the Contribute editor. You can make edits in the editable regions.

**Related topics**
- “About templates” on page 38

**Setting template properties**

The Dreamweaver template designer might make it possible for you to show or hide parts of the page. You control this content in the Template Properties dialog box. Pages based on a template might have *editable attributes*, such as background color, that you can edit in template properties.

**To modify template properties:**
1. Browse to a template-based page; then click the **Edit Page** button in the toolbar.
2. Select **Format > Template Properties**.
   
   The Template Properties dialog box opens.
3. In the Name list, select a property.
   Contribute updates the bottom of the dialog box to show the label of the selected property and
   its assigned value.
4. In the field to the right of the property label, edit the value to modify the property.
5. Click Apply to apply changes without closing the dialog box, or click OK to apply changes and
   close the dialog box.

Related topics
• “About templates” on page 38
• “Editing a template-based page” on page 48

Using Contribute to work offline
Contribute gives you the freedom to edit web pages without a network connection. Using the
work offline feature of Contribute, you can work on an airplane, at home, or anywhere.

While you are working offline, you can edit drafts, but you cannot use the Contribute browser.
Contribute remains offline—even if you establish a network connection—until you switch to
working online.

To use Contribute to work offline:
• If Contribute is running and has a network connection, select File > Work Offline (Windows)
  or Contribute > Work Offline (Macintosh).
• If Contribute is not running, start Contribute without a network connection; select Work
  Offline in the Connection Failure dialog box, and then click OK.

The Contribute browser displays the Working Offline page. Click a draft title in the Pages panel
to start editing.

Switching between working online and working offline
If you start Contribute offline without a server connection, or switch to working offline during an
online Contribute session, then you can switch to working online whenever you establish a server
connection.

Note: Contribute does not reestablish the connection to your web server. You must connect to the
server before you switch to working online in Contribute.

To switch from working online to working offline:
• Select File > Work Offline (Windows) or Contribute > Work Offline (Macintosh).

Switching to working offline does not disconnect your network connection.
To switch from working offline to working online:
1. Restore your network connection, if necessary.
2. Do one of the following:
   ■ Select File > Work Offline (Windows) or Contribute > Work Offline (Macintosh).
   The check mark next to this menu option disappears.
   ■ Click the Work Online button in the toolbar.

Working offline in the Contribute editor
When you’re working offline, the Contribute browser displays information about what you can
do offline. You cannot browse to other pages or websites when you are offline.

You can edit current drafts in the Pages panel or create new pages while you’re offline. Some
Contribute editor functions are not available when you’re offline. For example, you can’t publish
pages until you are online again.

Tip: Before you work offline, be sure to click Edit Page to create drafts for any pages you want to
edit offline. You cannot access home pages or recently published pages while you are offline.

To edit a draft while working offline:
• Click a draft title in the Pages panel of the sidebar.
  The draft opens in the Contribute editor.

To create a new page while working offline:
• Select File > New Page.
  The new page opens as a draft in the Contribute editor, and its title appears in the Pages panel.

To delete a new page while working offline:
1. Open any new page that you created while working offline.
   Note: You can delete only those pages that you created while working offline. You cannot cancel
   changes to a draft while working offline.
2. Click the Cancel button in the toolbar or select File > Actions > Cancel Draft.
   Contribute removes the new page from the Pages panel and opens the Contribute Working
   Offline page.

Related topics
• “Switching between working online and working offline” on page 50
Editing web page content in an external application

If you want to edit images, Microsoft Word documents, Macromedia Fireworks content, or files of other types on your website, you need to edit that content in the application in which it was created. You can open the appropriate application from within Contribute to edit the file.

**Note:** You need to use Contribute to edit the file in an external application; changes you make to the local, original source file do not appear on your website.

Before you can use Contribute to start an external application editor, you may need to associate an editor with the type of the file you intend to edit. Contribute has preassigned editors for common file types.

**To edit content in an external application:**

1. To find the content you want to edit, do one of the following:
   - Browse to the page or file that contains the content you want to edit, and then click **Edit Page**.
   - Click the **Choose** button in the toolbar, navigate to the file you want to edit, and then click **OK**.

   **Note:** If the Contribute browser cannot display the page or file you’ve selected, you’ll see the File Placeholder page.

2. Do one of the following:
   - If you browsed to a page and opened it as a draft, right-click (Windows) or Control-click (Macintosh) the element you want to edit, and then select **Edit in External Application**.
   - If you browsed to a file, click the **Edit** button in the toolbar.

Contribute displays the External Application Editing page and starts an external editing application.

3. If you are editing an image in Macromedia Fireworks, click **No** in the Find Source dialog box to indicate that you do not want to edit the source file for this image; you want to edit the image for your website only.

4. In the external application, make changes as necessary; then save your changes and close the application.

   **Note:** If you are editing in Fireworks, click the **Done** button in the editing window.

5. In Contribute, click one of the action buttons in the toolbar.

   **Tip:** Click the **Launch** link on the External Application Editing page to open the content in the external editor again, if you need to make additional changes.
Adding Google search functionality to your web page

You can add a Google™ search field to your web page, so that your website visitors can search the entire web or just your website.

To insert a Google search field:
1. In your draft, place the insertion point where you’d like the search field to appear.
2. Select Insert > Google Search Field.
   The Insert Google Search Field dialog box appears.
3. Set the options on each screen, and then click Next.
   For information about any of the options in a screen, click the Help button.
4. Review the summary, and then click Done.
   The Google search field appears on your draft.

To change Google search field properties:
1. In your draft, select the Google search field.
2. Select Format > Google Search Field Properties.
   The Google Search Field Properties dialog box appears.
3. Click any tab at the top of the dialog box, and then change options as necessary.
   For information about any of the options in the tab, click the Help button.
4. When you finish, click OK.

Editing web page source in an external application

You can edit web page source in an external application to make quick modifications or to do testing, such as link checking or accessibility testing. Contribute opens the source in an external editing application.

Note: If your Contribute administrator has not enabled source editing, you will not be able to edit the source in an external application. For information, talk to your Contribute administrator or see “Setting page-editing and paragraph settings” on page 249.

Caution: Editing web page source in an external application is very different than the editing experience in Contribute. If you are unsure about editing the source directly, talk to your Contribute administrator.

To edit a web page’s source in an external application:
1. In the Contribute browser or editor, view the page you want to edit the source for.
   Contribute displays the External Application Editing page and starts an external editing application.
3. In the external application, make changes as necessary, and then save your changes and close the file or application.

**Warning:** Be careful when you edit web page source—you can easily alter style and formatting and get unexpected results. If you are unsure about editing the source directly, talk to your Contribute administrator.

4. In Contribute, do one of the following:
   - Click the **Edit in Contribute** link on the External Application Editing page to reload the draft in Contribute.
     This option enables you to see your changes and resume editing.
     **Note:** If Contribute warns you that you must save and close the file in the external application, click **OK**.
   - Click the **Launch** link on the External Application Editing page to reopen the content in the external editor.
     This option enables you to make additional changes, and provides a convenient way to switch back and forth between Contribute and the external editing application.
   - Click the **Publish** button in the toolbar to publish your changes to the website.
   - Click the **Send for Review** button to send the draft to another user to review your changes.
   - Click **Cancel** if you are unhappy with the results of editing in an external application.
     This option discards all changes you've made in Contribute or in the external application since you started editing this draft.

**Related topics**
- “Editing web page content in an external application” on page 52

**Canceling a draft or new page**

When you are editing a draft of an existing page, you can decide to discard all changes and retain the currently published version of the page. When you are editing a new page that you created, you can discard the new page.

Also, depending on your role, you might be able to delete pages that are published on your website. For more information, see “Deleting a web page” on page 55.

**To cancel changes to a draft of a published page:**
- In your draft, click the **Cancel** button in the toolbar.
  The published version of the page appears in the Contribute browser, without any edits.

**To cancel a new page:**
- In the new page draft, click the **Cancel** button in the toolbar.
  Contribute discards the new page.
Deleting a web page

Depending on your role, you might be able to delete pages from your website. If you can delete pages, you can delete files of any type on your website, including image files.

**Note:** If you do not have permission to delete a page that you need to delete, talk to your Contribute administrator or see “Setting folder and file access settings” on page 247.

You do not need special permission to delete a new page that you created and haven’t published yet. For more information, see “Canceling a draft or new page” on page 54.

**To delete a page or file:**
1. Do one of the following to find the page or file:
   - Browse to the page or file you want to delete.
   - Click the **Choose** button in the toolbar; then select a file and click **OK**.

**Note:** If Contribute cannot display the page or file you browse to, you’ll see the File Placeholder page. You can still delete the page or file, even though you can’t view it.

2. Select **File > Actions > Delete Page**.

**Note:** This menu item is disabled if you do not have permission to delete pages on your website.

An alert appears.

3. Click **Yes** to confirm that you want to delete the file.

Contribute deletes the page and displays the last page you viewed in the browser.

**Related topics**
- “Canceling a draft or new page” on page 54

Exporting a Page (Windows only)

Contribute lets you export a page from Contribute to an external HTML file. You can save the file anywhere you choose on your computer or network.

If you export a new page with images—that is, a page you haven’t published yet—you’ll see the images in your exported page. If you edit an existing page—a previously published page—you might not see all the images on your exported page. This is because the new page references local versions of the images, and the existing page references images that are saved on your website.

**To export a page:**
1. Browse to the page you want to export; then click the **Edit Page** button in the toolbar.
2. Select **File > Export**.

   The Export dialog box appears.

3. Select a location to save the exported file.
4. Enter a filename.
5. Click **Save**.

   The exported file appears in the folder you selected.
Printing a page

You can browse to a page and print it, or you can print a page you are editing to check your changes.

To preview a page before you print:
1. Do one of the following:
   - Select File > Print Preview (Windows).
   - Select File > Print, and then click the Preview button (Macintosh).
     The page appears in a browser window.
2. If you want to print the page, click Print or OK.
3. Click Close to close the preview when you finish viewing it.

Tip: To preview a page in a browser, see “Previewing a page in your default browser” on page 152.

To print a page:
1. Select File > Print.
   
   Note: (Windows only) In the Contribute browser you can also right-click, then select Print.
   
   The Print dialog box appears.
2. Click Print or OK.
   
   Your default printer prints the page.
With Macromedia Contribute you can add pages to your website. You can create a copy of a page, create a blank page, create a copy of a sample page, or create a page based on a template. In addition to creating web pages, you can add existing content, such as Microsoft Word or Excel, to your website.

You can also use Contribute to create a new stand-alone page that is not associated with one of your websites by saving the new page to your computer. And, finally, you can add a printable document to your website by converting it to a Macromedia Flash document.

After you create a page, you can change its properties, or even add keywords or a description for the page so that website visitors can use a search engine to find the page.

This chapter contains the following sections:

- “About converting documents with FlashPaper” on page 57
- “Creating or copying a page on your website” on page 58
- “Creating a stand-alone web page” on page 63
- “Setting page properties” on page 64
- “Adding keywords and a description for a page” on page 65
- “Converting documents with FlashPaper” on page 66
- “Adding Microsoft Word and Excel documents to a website” on page 71

**About converting documents with FlashPaper**

When you install Contribute on a Windows machine, you automatically install Macromedia FlashPaper. FlashPaper lets you create Flash documents from any type of printable document. Flash documents are typically much smaller than other document types, and you can view them in any browser that supports Flash, or directly in Flash Player.

You can view Flash documents across platforms, and retain the formatting, graphics, fonts, special characters, and colors of source documents, regardless of the application and platform used to create the document. For example, if you created a Microsoft Excel spreadsheet on a Windows XP computer, you can use FlashPaper to convert it to a Flash document (SWF file), and then send it to a Macintosh user.
Because you can embed a Flash document in a web page, you can publish file types that most people can’t easily view on the web today, such as Microsoft Project, Microsoft Visio, and even QuarkXPress and AutoCAD. When a user opens your web page, the Flash document opens instantly, so the user can view the file without leaving the web page.

Flash documents also work well as stand-alone files. Anyone who has Flash Player installed on their computer can view Flash documents, and anyone who has Adobe Acrobat Reader installed on their computer can view PDF files.

By using the FlashPaper Printer utility that automatically installs with Contribute, Windows and Macintosh users can easily convert any printable document to a Flash document (SWF file) and insert it in a web page. The FlashPaper Printer works on Macintosh OS 10.2.6 and later, and Microsoft Windows XP and Windows 2000 operating systems.

You can convert a document to a Flash document in Contribute (Windows only) or in another application (Windows and Macintosh). You cannot edit a Flash document; if you need to update the document, make changes to the original document, then convert it again to a Flash document.

Note: Currently the stand-alone version of the FlashPaper application is not supported on the Macintosh. However, Macintosh users can still create Flash documents by using the FlashPaper Printer utility that installs with Contribute.

Related topics
• “Creating and inserting Flash documents within Contribute (Windows only)” on page 66
• “Using the FlashPaper toolbar” on page 68
• “Creating a Flash document in another application” on page 69
• “Selecting a Microsoft Excel print area to convert to a Flash document” on page 70

Creating or copying a page on your website

You can create or copy any of the following types of pages on your website:

• Copy of Current Page
• Blank Web Page
• Starter Web Page
• Template

Note: If your Contribute administrator has restricted the types of new pages you can create, you won’t see all of these options when you create or copy a page. For more information, talk to your Contribute administrator or see “Settings for new web pages” on page 252.

Related topics
• “Creating a stand-alone web page” on page 63
Copying a page on your website

You can create a copy of the page you are currently viewing on your website. You must be viewing the page in the Contribute browser. You cannot create a copy of a page that is a draft in the Contribute editor. Also, you cannot copy a page from one website to another website.

Remember to add a link to the page before you publish; otherwise, website visitors cannot navigate to the page.

To create a copy of a web page:

1. Browse to the page you want to copy, and then click the New Page button in the toolbar or select File > New Page.

   Note: You cannot create a copy of a page that contains frames.

   The New Page dialog box opens.

2. In the Create new page for section, select Copy of Current Page.

   Note: If you cannot select this option, you are viewing a page in your browser that you cannot copy. If you do not see this option, your Contribute administrator has restricted the types of new pages that you can create. For more information, talk to your Contribute administrator or see "Settings for new web pages" on page 252.

   A preview of the page appears in the Preview pane on the right side of the dialog box.

3. Enter a page title in the Page title text box.

   This title appears in the browser title bar when a website visitor views the page; it does not appear on the page itself.

4. Click OK.

   The new page opens as a draft in Contribute. Be sure to add a link to your new page before you publish it (see "Creating text and image links" on page 127).

   Note: Contribute creates the new page in the same folder as the page you copied. You can change the folder location when you publish the new page, if you need to.

Creating a blank web page

You can create a blank web page to add to your website. Remember to add a link to the page before you publish; otherwise, website visitors cannot navigate to the page.

Note: It’s a good idea to create the new page and a link to that page at the same time. To do that, see "Linking to a new page" on page 129.

To create a blank web page:

1. In the Contribute browser, click the New Page button in the toolbar, or in the browser or editor, select File > New Page.

   The New Page dialog box opens.

2. In the Create new page for section, expand the website in which you want to create the new page, if it is not already expanded.
3. In the **Create new page for** section, select **Blank Web Page**.

   **Note:** If you don’t see this option, then your Contribute administrator has restricted the types of new pages that you can create. For more information, talk to your Contribute administrator or see “Settings for new web pages” on page 252.

4. Enter a page title in the **Page title** text box.

   This title appears in the browser title bar when a website visitor views the page; it does not appear on the page itself.

5. Click **OK**.

   The new page opens as a draft in Contribute. Be sure to add a link to your new page before you publish it (see “Creating text and image links” on page 127).

   **Note:** Contribute creates the new page in the same folder as the page you were viewing when you created the page (unless you selected another website in step 2). You can change the folder location when you publish the new page, if you need to.

**Related topics**
- “Setting page properties” on page 64
- “Adding keywords and a description for a page” on page 65

**Copying a starter web page**

Contribute comes with built-in starter web pages that you can copy and use on your website. Use any of these pages as a starting point for your web page.

Remember to add a link to the page before you publish it; otherwise, website visitors cannot navigate to the page.

   **Note:** It’s a good idea to create the new page and a link to that page at the same time. To do that, see “Linking to a new page” on page 129.

**To copy a starter web page:**

1. In the Contribute browser, click the **New Page** button in the toolbar, or in the browser or editor, select **File > New Page**.

   The New Page dialog box opens.

2. In the **Create new page for** section, expand the website in which you want to create the new page, if it is not already expanded.

3. In the **Create new page for** section, expand the **Starter Web Pages** folder, and then select a starter web page.

   **Note:** If you don’t see the **Starter Web Pages** folder, then your Contribute administrator has restricted the types of new pages that you can create. For more information, talk to your Contribute administrator or see “Settings for new web pages” on page 252.

   A preview of the page you select appears in the **Preview** pane on the right side of the dialog box.
4. Enter a page title in the **Page title** text box.
   This title appears in the browser title bar when a website visitor views the page; it does not appear on the page itself.

5. Click **OK**.

   The new page opens as a draft in Contribute. For information about editing the starter web page, see "Editing a starter web page" on page 61. Also, be sure to add a link to your new page before you publish it (see “Creating text and image links” on page 127).

   **Note:** Contribute creates the new page in the same folder as the page you were viewing when you created the page (unless you selected another website in step 2). You can change the folder location when you publish the new page, if you need to.

### Editing a starter web page

The Contribute starter web pages were created by a professional design firm. You can copy any of the sample pages and use them in your website. You can use any of the pages as a starting point to create your own page, or simply replace the existing content with your information.

After you create a new page based on a starter web page, you can modify the page. This page is not a template, in which some parts can be modified but other parts are restricted. The page is simply a starting point for your web page; you can change it as needed.

**Note:** The hypertext links on the page do not work automatically; you need to edit each link on the page so that it refers to a page in your website.

The following are guidelines for working with text, images, and links on the starter pages. These are tips to help you get started; there are many ways to modify the starter web pages to make them your own.

**To modify text in a draft based on a starter page:**

- To replace existing text, select any text on the draft and type over it.
  When you replace existing text, Contribute retains the formatting established by the design of the starter web page. You can apply formatting to any text to override the design.

- To add text to draft, copy text from the draft or from another source (such as Microsoft Word), place the insertion point on the page or select text you want to replace, and then select **Edit > Paste Text Only**.

**Note:** If you want to delete the date object from your page, you must deselect Protect Scripts and Forms in the administration settings. For more information, talk to your Contribute administrator or see “Setting page-editing and paragraph settings” on page 249.

For more information about working with text, see Chapter 6, “Working with Text,” on page 73.

**To replace an image or graphic element in a draft based on a starter page:**

- Select the image, press **Delete**, and then drag a new image to the draft.

Most images and graphics on the starter web pages have dimensions on them. When you replace an image, try to use an image that’s close in size to the one you’re replacing, so that you retain the page design.
Note: If you see a yellow shield icon, it’s probably a placeholder for the current date. When you publish the page, it displays the current date.

For other ways to insert images and more information about working with images, see Chapter 7, “Working with Images and Graphical Elements,” on page 91.

To enable links in a draft based on a starter page:

• To replace existing link text, select a link, and then type your link text.

  Note: Not all links on the starter web pages look like typical links, with blue, underlined text. Links might not be underlined and might have a different design treatment applied to them. When you click an intended link on a draft based on a starter page, the status bar at the bottom of the Contribute editor indicates that it is a link.

• To make a link work, select a link, click the Link button in the toolbar, and then select Browse to Web Page. Click the Browse or Choose button in the Insert Link dialog box to find and select a page, and then click OK to close the Insert Link dialog box.

  You need to make the links work, or delete the ones you don’t want.

  Tip: You can also link to a new web page, such as another starter web page, and modify the new starter web page later. For more information, see “Linking to a new page” on page 129.

• To add a link to a vertical navigation bar, select the row that contains the last link in the series, and then select Edit > Copy. With the row still selected, click the Insert Row Below button in the toolbar. Select the new row, and then select Edit > Paste.

  For more information about working with links, see Chapter 9, “Working with Links,” on page 127.

Related topics

• “Copying a starter web page” on page 60

Creating a page based on a template

You can create a new page based on a template, which can help you maintain a consistent look across your website. In Contribute there are two types of templates:

• A template created in Macromedia Dreamweaver (see Dreamweaver Help > Using Dreamweaver). A Dreamweaver template is a template that a designer creates for you with editable and locked regions.

• A page that your Contribute administrator designated as a template. Your Contribute administrator can designate any page on your website as a template.

You can create a copy of either type of template to use as a starting point for your new page. The only difference is that a Dreamweaver template has editable and locked regions (see “Working with pages based on Dreamweaver templates” on page 48), and a page designated as a template by your Contribute administrator might not.

Remember to add a link to the new page before you publish it; otherwise, website visitors cannot navigate to the page.

Note: It’s a good idea to create the new page and a link to that page at the same time. To do that, see “Linking to a new page” on page 129.
To create a new page based on a template:
1. In the Contribute browser, click the New Page button in the toolbar, or in the browser or editor, select File > New Page.
   The New Page dialog box opens.
2. In the Create new page for section, expand the website in which you want to create the new page, if it is not already expanded.
3. In the Create new page for section, expand the Templates folder, and then select a template.
   
   **Note:** If you don't see the Templates folder, then your Contribute administrator has restricted the types of new pages that you can create. For more information, talk to your Contribute administrator or see “Settings for new web pages” on page 252.
   
   A preview of the page you select appears in the Preview pane on the right side of the dialog box.
4. Enter a page title in the Page title text box.
   This title appears in the browser title bar when a website visitor views the page; it does not appear on the page itself.
5. Click OK.
   The new page opens as a draft in Contribute. Be sure to add a link to your new page before you publish it (see “Creating text and image links” on page 127).
   
   **Note:** Contribute creates the new page in the same folder as the page you were viewing when you created the page (unless you selected another website in step 2). You can change the folder location when you publish the new page, if you need to.

Creating a stand-alone web page

You can use Contribute to create pages that aren't on a website you've connected to. You can save the page on your computer or network.

To create a new draft that is not associated with a Contribute website:
1. In the Contribute browser, click the New Page button in the toolbar, or in the browser or editor, select File > New Page.
   The New Page dialog box appears.
2. In the Create new page for section, expand My Computer (Windows) or This Mac (Macintosh), and then select Blank Web Page.
   
   **Note:** Be sure to select the option under My Computer (Windows) or This Mac (Macintosh) and not under a website that you have a connection to.
3. Enter a title for the new page.
4. Click OK, and then click OK again at the prompt. The Save As dialog box appears.
5. Browse to the location where you want to save the file, and then click OK. The new page opens as a draft in the Contribute editor.

Related topics
- “Creating or copying a page on your website” on page 58

Setting page properties

For each page, you can specify layout and formatting properties, including the default font family and font size, background color, margins, link styles, and many other aspects of page design.

The page properties you select apply only to the current web page. If a page uses an external CSS style sheet, Contribute does not make changes to the external style sheet, because those changes affect all other pages that use that style sheet.

Note: If you are editing a draft based on a template, or if you are restricted to text-only editing by your Contribute administrator, then you might be able to change the page title only. For more information, contact your Contribute administrator or see “Setting page-editing and paragraph settings” on page 249.

To set page properties:

1. In your draft, click the Page Properties button in the toolbar, or select Format > Page Properties.

The Page Properties dialog box appears.
2. Select categories from the list on the left and make changes as necessary.

By default, Contribute uses CSS to assign page properties. If your Contribute administrator has set the preference to use HTML tags instead of CSS, you will see only the Title/Encoding and Appearance categories on the left side of the dialog box. For more information about this setting, contact your Contribute administrator or see “Setting style and font settings” on page 251.

**Note:** If you cannot select the Links or Headings categories, then your Contribute administrator has set options to prevent you from changing those page properties. Likewise, if you can only change page margins in the Appearance category, the administrator has restricted access to the other properties in that category. For more information, talk to your Contribute administrator or see “Setting style and font settings” on page 251.

For information about options in any of the categories, click the Help button.

3. Click **Apply** to see changes without closing the dialog box or click **OK** to apply changes and close the dialog box.

### Adding keywords and a description for a page

You can associate keywords and a description with your web page. Visitors who type one of your keywords in a search engine can find your page.

**To add or change keywords and a description for a page:**

1. Browse to the page you want to add keywords and a description for, and then click the **Edit Page** button in the toolbar.

   A draft opens in the Contribute editor.

2. Select **Format > Keywords and Description**.

   The Page Keywords and Description dialog box appears.

3. Enter or change keywords in the **Keywords** pane.

   Separate each keyword with a single space (for example, meeting minutes planning committee holiday party).

4. Enter or change the page description in the **Description** pane.

5. Click **OK**.
Converting documents with FlashPaper

By using the FlashPaper Printer utility that is automatically installed with Contribute, you can easily convert your documents (such as Microsoft PowerPoint, Word, or Excel documents) to Flash documents that users can view in a browser.

Windows users can convert a document to a Flash document directly in Contribute, and then insert it into a web page (see “Creating and inserting Flash documents within Contribute (Windows only)” on page 66). Macintosh users must create a Flash document in another application, then use Contribute to insert it into a web page (see “Creating a Flash document in another application” on page 69).

Creating and inserting Flash documents within Contribute (Windows only)

You can use Contribute to convert any printable document to a Flash document and insert it into your web page. For more information about the flexibility of Flash documents, see “About converting documents with FlashPaper” on page 57.

In Contribute, Windows users can use the Insert menu or drag a document to convert it and insert it into a page. Macintosh users must convert the document in another application, and then use Contribute to insert it into a page (see “Creating a Flash document in another application” on page 69).

Note: If you are inserting a Microsoft Excel document, and want to specify the area of the document to convert, you should convert the document while working in Excel, and then insert it in your page in Contribute. For more information, see “Selecting a Microsoft Excel print area to convert to a Flash document” on page 70.

To create and insert a Flash document using the Contribute Insert menu:

1. In the draft, place the insertion point where you want the Flash document to appear.
2. Select Insert > Document with FlashPaper.
   - The Open dialog box appears.
3. Navigate to the file you want to convert to a Flash document, and then click **Open**.
The FlashPaper Options dialog box appears.

![FlashPaper Options dialog box](image)

4. Select the options you want to apply to the document you are inserting.
   For information about options in the dialog box, click the Help button.
5. Click **OK**.
   Contribute converts the document to a Flash document (SWF file) and inserts it into your draft.

   **Tip:** Select **Edit > Undo FlashPaper** if you want to remove the Flash document (SWF file) you just inserted.

**To create and insert a Flash document by dragging:**

1. In the draft, place the insertion point where you want the Flash document to appear.
   **Tip:** Reduce the size of the Contribute window so that you can also see the application that contains the file you plan to drag.
2. Drag the document that you want to convert to the insertion point.
3. If the Insert Microsoft Office Document dialog box appears, select **Insert the document with FlashPaper**, set options as necessary, and then click **OK**.
   Contribute converts the document to a Flash document (SWF file) and inserts it into your draft.

   **Tip:** Select **Edit > Undo FlashPaper** if you want to remove the Flash document you just inserted.

**To delete a Flash document from a draft:**

1. In the draft, click the Flash document (SWF file) to select it.
2. Press **Delete**.

**Related topics**

- “About converting documents with FlashPaper” on page 57
- “Creating a Flash document in another application” on page 69
Using the FlashPaper toolbar

The FlashPaper toolbar contains options that enable you to resize a document for viewing, navigate through the document pages, select text, search the document, and print the document. The FlashPaper controls are active whether you are using the Contribute browser or editor.

To print a document:
• Click the Printer button.

To select text in the document:
1. Click the Select button.
2. Drag to select text in the document window.
   
   Tip: You can Shift-click to select multiple words or lines of text.
3. Click the Pan button to return to viewing the document.

To search the document:
1. Type words that you want to search for in the Search text field, and then click the Search button.
   FlashPaper selects the first instance of the matching words.
   
   Note: The Search feature requires that you have Flash Player 7 installed on your computer. If you have Flash Player 6 or earlier, you cannot use the Search feature.
2. To find the next instance of the matching words, click the Search button again.

To resize the document, do one of the following:
• Use the Zoom slider to dynamically resize the document.
  You can adjust the document magnification range from 25% to 250%. The Zoom text box updates as you use the slider.
• Enter a number in the Zoom text box to resize the document to a specific magnification.
• Click the Fit in Viewer button to see the entire page in the viewer.
• Click the Fit Width button to resize the document so that the width of the page fills the viewer.
To navigate or page through the document, do one of the following:

- Enter a number in the Page Navigation text box to view a specific page.
- Click the Previous arrow or the Next arrow to page backward or forward through a document.
- Drag the page scroll box, located to the right of the document, to scroll through multiple-page documents.

To open a document in a new browser window:

- Click the Open in New Browser button.

Related topics

- “About converting documents with FlashPaper” on page 57
- “Creating and inserting Flash documents within Contribute (Windows only)” on page 66

Creating a Flash document in another application

You can convert any printable document type to a Flash document in an application other than Contribute, and then use Contribute to insert it into your page. For more information about Flash documents, see “About converting documents with FlashPaper” on page 57.

Windows users can use Contribute to both convert and insert the document (see “Creating and inserting Flash documents within Contribute (Windows only)” on page 66).

Note: In some cases, you may find it easier to work in an application other than Contribute when you want to specify a particular area of the document to convert. For information about converting Microsoft Excel documents in this way, see "Selecting a Microsoft Excel print area to convert to a Flash document” on page 70.

To use another application to convert a document to a Flash document:

1. In the application that you are using to convert a document to a Flash document, select File > Print.

   The Print dialog box appears.

2. For the printer name, select Macromedia FlashPaper, and then set the printer options you want to apply to the converted document.

3. (Windows only) Click Properties if you want to specify the page orientation and page size of the Flash document.

4. Click OK (Windows) or Print (Macintosh).

5. Save the Flash document (SWF file).

   - In Windows, in the FlashPaper Viewer, select File > Save as Macromedia Flash.
     
     Note: You can also save the document as a PDF file by selecting File > Save as PDF.

   - On the Macintosh, in the Save dialog box that appears, select a location, and then click Save.

6. In your Contribute draft, place the insertion point where you want the Flash document to appear, and then select Insert > Flash.
Related topics
- “About converting documents with FlashPaper” on page 57
- “Creating and inserting Flash documents within Contribute (Windows only)” on page 66
- “Using the FlashPaper toolbar” on page 68

Selecting a Microsoft Excel print area to convert to a Flash document

You cannot define the print area, or print multiple worksheets, when you convert a Microsoft Excel document to a Flash document from Contribute. To specify which worksheets are converted, or to specify certain rows and columns to convert, you must open the document in Excel, and then convert it to a Flash document.

To set a Flash document print area in Microsoft Excel:
1. In the Microsoft Excel document, drag to select the part of the worksheet that you want to convert to a Flash document.
2. Select File > Print Area > Set Print Area.
   The Print dialog box appears.
4. For the printer, select Macromedia FlashPaper.
5. (Windows Only) Click Properties if you want to set page layout properties for the document, and then click OK when you are finished.
6. Click OK (Windows) or Print (Macintosh).

   Note: Macintosh users will need to perform the additional step of selecting a location in which to save the converted file.

To select multiple worksheets to convert to a Flash document:
1. In the Microsoft Excel document, do one of the following to select multiple worksheets:
   - Click the worksheet tab of the first document you want to select; then Control-click (Windows) or Command-click (Macintosh) the tabs of other worksheets you want to select.
   - Right-click (Windows) or Control-click (Macintosh) a worksheet tab, and then select Select All Sheets.
2. Select File > Print.
   The Print dialog box appears.
3. For the printer, select Macromedia FlashPaper.
4. (Windows only) Click Properties if you want to set page layout properties for the document, and then click OK.
5. Click OK (Windows) or Print (Macintosh).

   Note: Macintosh users will need to perform the additional step of selecting a location in which to save the converted file.
Related topics
• “About converting documents with FlashPaper” on page 57
• “Creating and inserting Flash documents within Contribute (Windows only)” on page 66
• “Using the FlashPaper toolbar” on page 68
• “Creating a Flash document in another application” on page 69

Adding Microsoft Word and Excel documents to a website
With Contribute you can easily add Word and Excel documents or content from those documents to your website.

For example, suppose you have a Word table that contains contact information for all of your sales representatives in North America. You don't have to recreate the table on your web page—you can use Contribute to add it to your website.

There are three ways to add Word or Excel content to a web page:
• Add the contents of a Word or Excel document to a new or existing web page (Windows only)
• Insert a link to a Word or Excel document on an existing web page
• Convert the document to a Flash document and insert it into a web page

Tip: In Windows, you can set a user preference so that when you add a Word or Excel document, Contribute always either adds the contents of the document or inserts a link to the document.

Adding Word or Excel content to a page (Windows only)
You can add the contents of a Word or Excel document to a new or existing web page.

When you add content to a page, Contribute converts it to HTML and copies it to your web page. You can then edit the content in Contribute; changes you make to the original file on your computer do not appear on your website.

If the document you are converting to HTML is larger than 300K, Contribute advises that the file is too large to convert and gives you other options for inserting the document: converting the document to a Flash document or inserting a link to the document. For information about these options, see “Converting documents with FlashPaper” on page 66 and “Inserting a link to a Word or Excel document” on page 72.

Note: If you use Microsoft Office 97, you cannot add the contents of a Word or Excel document; you must insert a link to the document or convert the document to a Flash document.

To add the contents of a Word or Excel document to a draft:
1. In your draft, place the insertion point where you want the content to appear.
2. Do one of the following to select the file with the content you want to insert:
   ■ Select Insert > Microsoft Office Document.
   In the Open dialog box, browse to the file you want to add, and then click Open.
   ■ (Windows only) Drag the file from its current location to the Contribute draft where you want the content to appear.
   In the Insert Microsoft Office Document dialog box, click Insert the contents of the document into this page, and then click OK.
The contents of the Word or Excel document appear in your draft.

**Related topics**

- “Creating and inserting Flash documents within Contribute (Windows only)” on page 66

**Inserting a link to a Word or Excel document**

You can insert a link to a Microsoft Word or Excel document in an existing page.

When you publish the page with the link, Contribute copies the document to your website and then links to that copy (not to the original file on your computer).

**Note:** To edit content in the linked page after you publish, see “Editing web page content in an external application” on page 52. Changes you make to the original file do not appear on your website.

**To create a link to a Word or Excel document:**

1. In your draft, place the insertion point where you want the content to appear.

2. Do one of the following to select the file with the content you want to insert:
   - Place the insertion point in your draft where you want the link to appear, or select text or an image on the draft, then click the **Link** button in the toolbar and select **File on My Computer**.
     - In the Insert Link dialog box, enter link text, browse to the file you want to link to, and then click **OK**.
   - (Windows only) Drag the file from its current location to the Contribute draft where you want the link to appear.
     - In the Insert Microsoft Office Document dialog box, click **Create a link to the document**, and then click **OK**.

   **Note:** The link text is the name of the file you link to. To change link text after you create the link, see “Changing link text and destination” on page 142.

A link to the document appears in your draft.

**Related topics**

- “Adding Word or Excel content to a page (Windows only)” on page 71
- “Creating and inserting Flash documents within Contribute (Windows only)” on page 66
You can use Macromedia Contribute to add and format text, much as you do with a basic word processor. You’ll find a few differences in working with text in Contribute and a word-processing program, such as Microsoft Word, because Contribute formats your text using HTML behind the scenes.

This chapter contains the following sections:

- “About HTML and CSS styles in the Contribute Style menu” on page 73
- “Adding text to a web page” on page 74
- “Changing text appearance on the page” on page 76
- “Positioning text on the page” on page 82
- “Creating lists” on page 83
- “Checking spelling” on page 88
- “Finding and replacing text” on page 89

For information about working with text in tables, see Chapter 8, “Working with Tables,” on page 111. For information about aligning text around images, see Chapter 7, “Working with Images and Graphical Elements,” on page 91. For information about editing link text, see “Working with Links” on page 127.

About HTML and CSS styles in the Contribute Style menu

The Style pop-up menu in Contribute lists HTML heading and paragraph styles, plus user-defined Cascading Style Sheet (CSS) styles that you can apply to format your content. All styles in the list appear as they will appear when you apply them to text.

**Note:** If the Style menu is not enabled, your Contribute administrator has restricted the website so you cannot apply styles.

You might also be able to create new CSS styles as you format text; Contribute automatically adds these styles to your style list. This makes applying the same formatting to a block of text much simpler as well as letting you create a more consistent look for your pages.
Note: You will not see HTML heading or CSS styles if your Contribute administrator has disabled one or both of them. To enable or disable CSS styles in Contribute, talk to your Contribute administrator or see “Setting style and font settings” on page 251.

You cannot attach a Cascading Style Sheet to a page in Contribute to add more styles; use Macromedia Dreamweaver to attach a style sheet.

Related topics
• “Applying styles to text” on page 78
• “Creating and managing styles” on page 79

Adding text to a web page

You can add text to a web page by typing text, copying and pasting text, or dragging text from another application or web page to your Contribute draft.

If you are using the Windows version of Contribute, you can add the entire contents of a Microsoft Word or Excel document to a web page. For more information, see “Adding Microsoft Word and Excel documents to a website” on page 71.

Tip: Your Contribute administrator can specify the amount of space that Contribute adds between paragraphs when you press Enter or Return. For more information, talk to your Contribute administrator or see “Setting page-editing and paragraph settings” on page 249.

To add text to a draft, do one of the following:
• Place the insertion point in the draft; then type text directly into your draft.
• Select text in another application; then select Edit > Copy. Place the insertion point in your Contribute draft; then select Edit > Paste.
  Tip: Leave Microsoft Excel running when you copy and paste Excel content to Contribute so that the pasted content retains its formatting.
• Drag selected text from another application to your Contribute draft.
  Note: Contribute might preserve text formatting applied in the other application.

Adding the current date to a page

You can add the current date to a page. The date can also include the day of the week and the time.
To add the date to a draft:
1. Place the insertion point in your draft where you want the date to appear.
2. Select Insert > Date.
   The Insert Date dialog box appears.
3. Select the format for the day, date, and time.
   For information about options in the dialog box, click the Help button.
4. Click OK.
   Contribute adds the current date to your draft.

Adding special characters to a page
You can add special characters, such as a copyright symbol (©) or a pound sign (#), to your page.

Note: You can add special characters only to pages that use Western (Latin 1) encoding. For more information about setting page encoding, see “Setting page properties” on page 64.
To add a special character to a draft:
1. Place the insertion point in your draft where you want the character to appear.
2. Do one of the following:
   - Select Insert > Special Characters, and then select a character from the pop-up menu.
   - Select Insert > Special Characters, and then select Other. In the Insert Other Character dialog box, click the character you want to insert, and then click OK.

The character appears in your draft.

Changing text appearance on the page
Contribute enables you to format text—characters and entire paragraphs—quickly and easily. You can use menu options or use the text formatting toolbar to change text with one click.

For a detailed illustration of the text formatting toolbar, see “The Contribute toolbars” on page 22.

Note: For information about moving text, see “Positioning text on the page” on page 82.

Changing text font and size
You can change the appearance of text by changing its font or size. Select a font or size from the available options; you cannot enter a custom size.

Most browsers can render the fonts in the Contribute font list. It's good web-design practice to use fonts that are generally available to your website visitors.

Each font in the list actually represents a font combination list. To edit your list of available fonts, see “Editing the font list” on page 77.
To change text size:
1. In your draft, select the text you want to change.
2. Do one of the following:
   ■ Select a size from the Font Size pop-up menu in the text formatting toolbar.
   ■ Right-click (Windows) or Control-click (Macintosh), select Size, and then select a size from the pop-up menu.
     Note: This option is not available if you are working in a table.
   ■ Select Format > Size, then select a size from the pop-up menu.

To change text font:
1. In your draft, select the text you want to change.
2. Do one of the following:
   ■ Select a font from the Font pop-up menu in the text formatting toolbar.
   ■ Right-click (Windows) or Control-click (Macintosh), select Font, and then select a font from the pop-up menu.
     Note: This option is not available if you are working in a table.
   ■ Select Format > Font, then select a font from the pop-up menu.

Related topics
• “Applying styles to text” on page 78
• “Creating and managing styles” on page 79
• “Changing text style on the page” on page 80
• “Applying text color” on page 81

Editing the font list
Font combinations in the Contribute font list determine how a browser displays text in your web page. Each font you see in the Font menu represents the first font in that font combination. You can edit the font combinations in Contribute.

A browser uses the first font in a font combination that is installed on the website visitor's computer. If none of the fonts in the combination are installed, the browser displays the text as specified by the visitor's browser preferences.
To edit the font list:

1. In your draft, select Format > Font > Edit Font List.

   The Edit Font List dialog box appears.

2. Select a font combination in the Font list section.

   The fonts in the selected combination appear in the Chosen fonts section. The Available fonts section lists fonts that are installed on your computer.

3. Make changes as necessary.

   You can add or remove a font combination, move a font combination up or down in the list, add or remove fonts from a font combination, or add a font that is not installed on your system.

   For information about options in the dialog box, click the Help button.

4. Click OK when you finish editing the font list.

Related topics
• “Changing text font and size” on page 76

Applying styles to text

You can easily apply styles, such as a heading style, to format your text. The Style pop-up menu in Contribute lists HTML heading and paragraph styles, plus user-defined CSS styles.

Note: If the Style menu is not enabled, your Contribute administrator has restricted the website so that you cannot apply styles.

For more information about the HTML and CSS styles in the Style menu, see “About HTML and CSS styles in the Contribute Style menu” on page 73.
To apply a style to text:
1. In your draft, select the text you want to change or place the insertion point in the paragraph you want to change.
2. Do one of the following:
   - Select a style from the Style pop-up menu in the text formatting toolbar.
   - Select Format > Style, and then select a style from the pop-up menu.
   The text you selected, or the entire paragraph where the insertion point is, changes to the new style.
   **Note:** If you select a built-in heading style, the entire paragraph changes to that style, even if you selected specific text in the paragraph.

When you press Enter or Return after text that has a style applied, Contribute applies the same style to the next line, unless the previous text was a heading. When you press Enter or Return after a heading, the next line of text is in paragraph style.

To clear the current text style:
1. In your draft, select the text you want to change, or place the insertion point within the text.
2. Select Normal from the Styles pop-up menu in the text formatting toolbar.
   **Note:** You can also select Format > Style > Remove Paragraph Breaks. This option clears the style and removes any paragraph tags around the selection.

Related topics
- “Changing text font and size” on page 76
- “Changing text style on the page” on page 80
- “Applying text color” on page 81

Creating and managing styles
As you format text in a page, Contribute keeps track of the styles and builds a library of styles that you can reuse in that page.
   **Note:** If your Contribute administrator has restricted style creation for your website, you can apply formatting properties to text, but Contribute will not save the style for you to reuse. For more information, talk to your Contribute administrator or see “Setting style and font settings” on page 251.

You can manage your list of user-defined CSS styles by renaming them or deleting them as necessary. You cannot rename or delete HTML styles in the list.

For more information about HTML and CSS styles, see “About HTML and CSS styles in the Contribute Style menu” on page 73.
To create a new text style:
1. In your draft, place the insertion point in the paragraph, or select some of the text in the paragraph.
2. Apply the font, size, or color as desired.
   Contribute keeps track of the formatting properties you assign and assigns a label to the new style, using the naming convention: Style1, Style2, Style3, Style n. The label appears in the Style pop-up menu in the text formatting toolbar.
   If you assign the same formatting attributes to two or more text elements, Contribute labels those elements with the same title, eliminating redundant style names.

To rename a style:
1. In your draft, select Format > Style > Rename Style or select Rename Style from the Style pop-up menu in the text formatting toolbar.
   The Rename Style dialog box appears.
2. Select the style you want to rename from the Style pop-up menu.
3. Enter a new name in the New style name text field.
4. Click OK.
   Contribute renames the style and the new name appears in the Style pop-up menu in the text formatting toolbar.

To delete a style:
1. In your draft, select Format > Style > Delete Style or select Delete Style from the Style pop-up menu in the text formatting toolbar.
   The Delete Style dialog box appears.
2. Select the style you want to delete.
3. Click Delete.
   Contribute deletes the style from the Style pop-up menu in the text formatting toolbar.

Related topics
• “Changing text font and size” on page 76
• “Applying styles to text” on page 78
• “Applying text color” on page 81

Changing text style on the page
You can change text style to bold, italic, underlined, strikethrough, emphasis, strong, and fixed width.

Note: If these options are not enabled, your Contribute administrator has restricted the website so that you cannot use these text formatting options.
To make text bold, italic, or underlined:
1. In your draft, select the text you want to change.
2. Do one of the following:
   ■ Click the Bold or Italic button in the text formatting toolbar.
   ■ Right-click (Windows) or Control-click (Macintosh), then select Bold, Italic, or Underline.
      
      Note: This option is not available if you are working in a table.
   ■ Select Format > Bold, Format > Italic, or Format > Underline.

      Tip: It is not good practice to use the underline style in web pages because website visitors might mistake underlined text for link text. You should use a style other than underline to emphasize text.

To make text strikethrough, emphasized, strong, or fixed width:
1. In your draft, select the text you want to change.
2. Do one of the following:
   ■ Right-click (Windows) or Control-click (Macintosh), select Other, and then select one of the options from the pop-up menu.
      
      Note: This option is not available if you are working in a table.
   ■ Select Format > Other, and then select one of the options from the pop-up menu.

      Note: Emphasis and Strong apply the same styles as Italic and Bold, respectively, but use different HTML tags. Your Contribute administrator determines which tag Contribute actually inserts.

Related topics
• “Changing text font and size” on page 76
• “Applying styles to text” on page 78
• “Creating and managing styles” on page 79

Applying text color
You can change the color of text or you can highlight text.

To change text color:
1. In your draft, select the text you want to change.
2. Do one of the following:
   ■ Click the Text Color button in the text formatting toolbar.
   ■ Right-click (Windows) or Control-click (Macintosh), and then select Color.
      
      Note: This option is not available if you are working in a table.
   ■ Select Format > Text Color.

      The color selector appears.
3. Select a color from the color selector.
   The color selector closes and the text color changes in your draft.
To highlight text:
1. In your draft, select the text you want to highlight.
2. Click the Highlight Color button in the text formatting toolbar, or select Format > Highlight Color.
   The color selector appears.
3. Select a color from the color selector.
   The color selector closes and the text is highlighted in your draft.

Related topics
• “Changing text font and size” on page 76
• “Applying styles to text” on page 78
• “Creating and managing styles” on page 79
• “Changing text style on the page” on page 80

Positioning text on the page
To position text on your page, you can add paragraph spacing, align text, or change indentation.

Note: For information about formatting text to change its appearance, see “Changing text appearance on the page” on page 76.

Adding paragraph spacing
Contribute works similarly to many word processing application: you press Enter (Windows) or Return (Macintosh) to create a new paragraph. Web browsers automatically insert a blank line of space between paragraphs. You can add a single line of space between paragraphs by inserting a line break.

To add a paragraph return:
1. In your draft, place the insertion point at the end of a paragraph.
2. Press Enter (Windows) or Return (Macintosh).

To add a line break, do one of the following:
1. In your draft, place the insertion point where you want the line break to appear.
2. Do one of the following:
   ■ Select Insert > Line Break.
   ■ Press Shift+Enter (Windows) or Shift+Return (Macintosh).

Related topics:
• “Indenting text” on page 83
Aligning text
You can select one of four text alignment options: Left, Center, Right, and Justify.

To change text alignment:
1. In your draft, select text, or place the insertion point within the text.
   Note: Contribute applies alignment to the entire paragraph, even if you select specific text in the paragraph.
2. Do one of the following:
   ■ Click one of the alignment buttons in the text formatting toolbar.
   ■ Select Format > Align, and then select an alignment from the pop-up menu.
   The text alignment changes in your draft.

Related topics:
• “Adding paragraph spacing” on page 82

Indenting text
In Contribute you can indent or outdent a paragraph. You can indent or outdent the same paragraph multiple times, further increasing or decreasing the space at the beginning of the text. Indenting and outdenting affects the right margin as well as the left.

To indent or outdent text:
1. In your draft, select the text you want to change or place the insertion point within the text.
2. Do one of the following:
   ■ Click the Indent or Outdent button in the text formatting toolbar.
   ■ Select Format > Indent or Format > Outdent.
   The text indentation changes in your draft.

Related topics:
• “Adding paragraph spacing” on page 82
• “Aligning text” on page 83
• “Indenting text” on page 83

Creating lists
You can create numbered lists, bulleted lists, and definition lists in Contribute. You can also create sublists within your lists.

Creating numbered lists
You can use numbered lists for information organized as a sequence or progression. You can apply numbering as you create the list, or you can add numbering to an existing list.
To create a numbered list:
1. Place the insertion point in your draft where you want to add the list.
2. Do one of the following:
   - Click the Numbered List button in the text formatting toolbar.
   - Select Format > List > Numbered List.
3. Type the first list item.
4. Press Enter (Windows) or Return (Macintosh) to type another item, and repeat for each item.
5. When you finish typing the list, do one of the following to turn off numbering:
   - Press Enter or Return twice.
   - Press Enter or Return, and then click the Numbered List button in the text formatting toolbar.

To create a numbered list from existing text:
1. In your draft, select multiple lines of existing text.
2. Do one of the following:
   - Click the Numbered List button in the text formatting toolbar.
   - Select Format > List > Numbered List.
Contribute adds numbers to your list.

Related topics
- “Creating definition lists” on page 85
- “Creating sublists” on page 85
- “Setting list properties” on page 87

Creating bulleted lists

Use bulleted lists to organize information that is related but in no particular sequence. You can apply bullets as you create the list, or you can add bullets to an existing list.

To create a bulleted list:
1. Place the insertion point in your draft where you want to add the list.
2. Do one of the following:
   - Click the Bulleted List button in the text formatting toolbar.
   - Select Format > List > Bulleted List.
3. Type the first list item.
4. Press Enter (Windows) or Return (Macintosh) to type another item, and then repeat for each item.
5. When you finish typing the list, do one of the following to turn off the bullets:
   - Press Enter or Return twice.
   - Press Enter or Return, and then click the Bulleted List button in the text formatting toolbar.
To create a bulleted list from existing text:
1. In your draft, select multiple lines of existing text.
2. Do one of the following:
   ■ Click the Bulleted List button in the text formatting toolbar.
   ■ Select Format > List > Bulleted List.
Contribute adds bullets to your list.

Related topics
• “Creating numbered lists” on page 83
• “Creating sublists” on page 85
• “Setting list properties” on page 87

Creating definition lists
A definition list is a series of items, each with an indented sub-item.

To create a definition list:
1. Place the insertion point in your draft where you want to create the list.
2. Select Format > List > Definition List.
3. Type the first list item, and then press Enter (Windows) or Return (Macintosh).
4. Type the indented definition, and then press Enter or Return, and then repeat the previous step as necessary.
5. When you finish typing the list, do one of the following to turn off the indenting:
   ■ Press Enter or Return twice.
   ■ Press Enter or Return, and then select Format > List > Definition List.

To create a definition list from existing text:
1. In your draft, select multiple lines of existing text.
2. Select Format > List > Definition List.

Related topics
• “Creating numbered lists” on page 83
• “Creating bulleted lists” on page 84
• “Setting list properties” on page 87

Creating sublists
You can change the level of a numbered or bulleted list item to create a nested list. For example, you might have a bulleted list where one of the bullets has a sublist of bullets.
The nested list does not have to be of the same type as the parent list. For instance, you can nest a bulleted list in a numbered list. You can have multiple nested lists within your list.

To create a sublist:
1. In your draft, place the insertion point at the end of the line within an existing list where you want to create the sublist.
2. Press Enter (Windows) or Return (Macintosh).
3. Do one of the following:
   - Click the Indent button in the text formatting toolbar.
   - Press Tab.
     
     Note: This option is not available for template-based pages or in tables.
   - Select Format > Indent.
     
     Contribute indents the number or bullet of the new line.
4. If you want the sublist and parent list to be different types, click the Numbered List or Bulleted List button in the text formatting toolbar, as appropriate.
5. Type the list item, and then press Enter or Return to add more items to the sublist.
6. When you finish typing the list, do one of the following to leave the sublist:

- Press Enter or Return twice.
- Press Enter or Return, then click the **Outdent** button in the text formatting toolbar.

*Note:* If you changed the sublist to be a different type than the parent list, click the **Numbered List** or **Bulleted List** button to switch back to the type of the parent list.

**Related topics**
- “Creating numbered lists” on page 83
- “Creating bulleted lists” on page 84
- “Creating definition lists” on page 85

**Setting list properties**

You can change the appearance of an entire list, or change the look of an individual list item in a bulleted or numbered list.

To set list properties for an entire list:

1. In your draft, select an entire bulleted or numbered list.
2. Do one of the following:
   - Select **Format > List > Properties**.
   - Right-click (Windows) or Control-click (Macintosh), and then select **List > Properties**.

   *Note:* This option is not available for template-based pages or in tables.

The List Properties dialog box appears.

3. Make changes as necessary.
   - For information about options in the dialog box, click the Help button.
4. Click **OK**.
   - Contribute applies your changes to the list. It also applies the new style automatically to any items you add to the list.
To set list properties for a list item:
1. In your draft, place the insertion point in the bulleted or numbered list item you want to change.
   
   **Note:** If you select multiple items, list properties will be applied to the entire list.

2. Do one of the following:
   ■ Select **Format > List > Properties**.
   ■ Right-click (Windows) or Control-click (Macintosh), and then select **List > Properties**.
     
     **Note:** This option is not available for template-based pages or in tables.

   The List Properties dialog box appears.
3. In the **Selected item** section, change options for the list as necessary.
   For information about options in the dialog box, click the Help button.
4. Click **OK**.
   Contribute applies your changes to the list item.

**Related topics**
- “Creating numbered lists” on page 83
- “Creating bulleted lists” on page 84
- “Creating definition lists” on page 85
- “Creating sublists” on page 85

**Checking spelling**

It’s a good idea to use the Check Spelling command to check the spelling in your draft after you add or edit text.

**To check and correct spelling:**
1. In your draft, select **Format > Check Spelling**.
   If Contribute encounters an unrecognized word, the Check Spelling dialog box appears.
2. Select the appropriate option based on how you want Contribute to handle the discrepancy.
   For information about options in the dialog box, click the Help button.
3. After you finish checking spelling, click the **Close** button in the Check Spelling dialog box or click **OK** in the **Spelling Check Completed** message box.
Finding and replacing text

You can search the draft you’re editing for specific text. You can also search for and replace text in drafts.

To search for text:
1. In your draft, select Edit > Find.
   The Find and Replace dialog box appears.
2. Type the text you want to find, and then click Find next until you finish searching the draft.
   For information about options in the dialog box, click the Help button.
3. When you finish, click Close.

To search and replace text:
1. In your draft, select Edit > Find.
   The Find and Replace dialog box appears.
2. Type the text you want to find, and then type the replacement text.
3. Click Find Next.
4. For each instance, decide whether to replace the text, replace all instances of the text, or find the next instance without replacing the text.
   For information about options in the dialog box, click the Help button.
5. When you finish, click Close.
CHAPTER 7
Working with Images and Graphical Elements

Macromedia Contribute makes it easy for you to edit, add, or delete images on your web pages. You can also add Macromedia Flash movies (SWF files) as easily as you add an image to a page. You can use Contribute to add PayPal buttons for completing e-commerce transactions through your web page.

Note: For information about converting a document to a Flash movie (SWF file), see “Creating and inserting Flash documents within Contribute (Windows only)” on page 66.

For information about making an image a hypertext link (also known as a link), see “Creating text and image links” on page 127.

This chapter contains the following sections:
• “About inserting images and buttons” on page 92
• “Adding an image to a page” on page 93
• “Inserting shared assets into a web page” on page 96
• “Changing image properties” on page 97
• “Changing an image’s position or orientation” on page 98
• “Editing an image in Contribute” on page 100
• “Editing an image in an external application” on page 104
• “Inserting Flash content into your web page” on page 105
• “Inserting a movie into your web page” on page 106
• “Adding and deleting a horizontal rule” on page 107
• “Inserting PayPal e-commerce buttons” on page 109
About inserting images and buttons

There are special considerations when you insert images and PayPal buttons on a web page.

About inserting images

You can add images from several sources, including your computer, local network, website, e-mail, Microsoft Internet Explorer web browser, or another application, such as Microsoft Word or Excel.

Note: Images that you add to your page should be in one of the following web-ready formats: JPG, GIF, or PNG (16). If the image you want to add is in another format, you can use an image-editing tool, such as Macromedia Fireworks, to convert the image to a web-ready format.

When you add an image to a page, it’s a good idea to add descriptive text about the image so that the image is accessible to users with disabilities. Your Contribute administrator can enforce the image-accessibility option so that a dialog box prompts you for a description whenever you add an image.

Note: For more information, talk to your Contribute administrator or see “Setting page-editing and paragraph settings” on page 249.

About PayPal buttons

PayPal buttons, created by WebAssist.com, make it easy for you to add e-commerce functionality to a Contribute page. After you create a payment button, you can instantly accept credit card payments from your customers. PayPal provides a secure, hosted check-out service to process and record all your transactions. If you don’t have a PayPal account, you can open one for free in a few minutes. There are no setup or monthly fees, and PayPal charges you only when a customer payment occurs.

Note: Your Contribute administrator must enable the PayPal feature for your role before you can use it. For more information, talk to your Contribute administrator or see “Setting page-editing and paragraph settings” on page 249.

There are five kinds of PayPal buttons you can insert into a web page:

• **Buy Now button** defines an item offered for immediate purchase, and includes a product name, price, item number, and other shipping and handling costs.

• **Add to Cart button** defines an item that a customer can use to add the item to a shopping cart for purchase.

• **View Cart button** is used with the Add to Cart button, and lets customers view the items in their shopping cart and check out whenever they want to complete their purchases.

• **Subscription button** defines a service that the customer can pay for on a recurring basis, and also provides an option to setup a free trial period. You can define the amount, the subscription period, and how many times to repeat billing.

• **Donation button** enables you to collect donations from a button on your website, or even using a link in an e-mail.
All payment button wizards let you price items in multiple currencies, such as Canadian dollars, British pounds sterling, euros, or Japanese yen. They also provide options that let you display your business name and logo on the checkout page. Finally, you can specify a web address (URL) for a web page you want shown when a customer completes a purchase, such as a “Thank you for your order” page.

You insert the PayPal button and its associated functionality in a page by completing the screens of the PayPal wizard. Through the wizard, you select button images to insert in the page and define multiple options (such as an item number, price, and so on) for each item you are selling. If you need help completing the screens in the PayPal wizard, click the Help button to view additional online help.

You can insert multiple PayPal buttons in the same page. Just be sure not to insert more than one button in the same paragraph or table cell.

If your page contains other HTML forms, make sure you do not insert a PayPal button in an existing HTML form. If you use JavaScript code to reference a form in your page, verify that the JavaScript functionality is still working after you add the PayPal button(s) to your page.

Related topics
• “Inserting PayPal e-commerce buttons” on page 109

Adding an image to a page

There are three ways you can add an image to your web page:
• Use the Insert menu or the Image button to add an image from your computer or website.
• Drag an image from another source to your Contribute draft.
• Copy and paste an image from another source on your Contribute draft.

Note: If your Contribute administrator has restricted the types of images your user role can insert, you might be able to insert images only from shared assets.

Related topics
• “About inserting images” on page 92
• “Inserting shared assets into a web page” on page 96
• “Changing image properties” on page 97
• “Editing an image in Contribute” on page 100
Using the Insert menu or Image button to add images to a page

You can use the Insert menu or Image button in the toolbar to add an image from your computer or website to a page.

You can add images from other sources by dragging them to the page (see “Dragging images to a page” on page 95) or by copying and pasting them on the page (see “Copying and pasting images” on page 95).

To add an image using the Insert menu or Image button:
1. Place the insertion point in your draft where you want the image to appear.
2. Do one of the following:
   - Click the Image button in the toolbar.
   - Select Insert > Image.
3. Select one of the following options from the pop-up menu:
   - From My Computer
   - From Website
   - From Shared Assets
   **Note:** If your Contribute administrator has restricted the types of images your user role can insert, you might be able to insert images only from shared assets.

   The Select Image, Choose Image on Website, or Insert Shared Asset dialog box appears.

   **Tip:** If you have already inserted an image in a page in a Contribute website, and you want to reuse the image, select From Website.

4. Browse to and select the image, and then click the Select or OK button.
5. If the Image Description dialog box appears, enter text to describe the image for users with disabilities or for users whose browsers are set to display text only, and then click OK.

   The image appears in your draft. To make the image web-ready, Contribute reduces large images to the size pre-set by the Contribute administrator, if the administrator has enabled image processing for your role.

   **Note:** If the image you are inserting is from your computer, you can edit the image inline (if your user role has permission to edit inline), but you can't edit the image in an external application until you publish the draft. For more information about editing, see "Editing an image in Contribute" on page 100.

   **Tip:** After you insert the image, double click the image to change image properties. For more information, see "Changing image properties" on page 97.

Related topics
- “Copying and pasting images” on page 95
Dragging images to a page

You can drag an image from another source to your Contribute page.

**Note:** If your Contribute administrator has restricted the types of images your user role can insert, you might be able to insert images only from shared assets.

You can also add images by using the Insert menu or Image button (see “Using the Insert menu or Image button to add images to a page” on page 94) or by copying and pasting them on the page (see “Copying and pasting images” on page 95).

**To add an image by dragging:**

1. Reduce the size of the Contribute application window so you can also see the application that contains the image you plan to drag.

2. In the other application, select the image.

3. Drag the image to your Contribute draft where you want the image to appear.

   **Tip:** You can’t drag an image from a web browser if the image has a link attached to it. Save the image to your computer first, and then drag the image to your Contribute draft, or copy and paste the image.

4. If the Image Description dialog box appears, enter text to describe the image for users with disabilities or for users whose their browsers set to display text only, and then click **OK**.

   The image appears in your draft. To make the image web-ready, Contribute reduces large images to the size pre-set by the Contribute administrator, if the administrator has enabled image processing for your role.

   **Note:** If the image you are inserting is from your computer, you can edit the image inline, but you can’t edit the image in an external application until you publish the draft. For more information about editing, see “Editing an image in Contribute” on page 100.

   **Tip:** After you insert the image, double click the image to change image properties. For more information, see “Changing image properties” on page 97.

**Related topics**

- “Using the Insert menu or Image button to add images to a page” on page 94

Copying and pasting images

You can copy an image from another source, and paste it on your Contribute page.

**Note:** If your Contribute administrator has restricted the types of images your user role can insert, you might be able to insert images only from shared assets.

You can also add images by using the Insert menu or Image button (see “Using the Insert menu or Image button to add images to a page” on page 94) or by dragging them to the page (see “Dragging images to a page” on page 95).
To add an image by copying and pasting:
1. In the application that contains the image you want to copy, select the image.
2. Select Edit > Copy.
3. Place the insertion point in your Contribute draft where you want the image to appear.
4. Select Edit > Paste.
5. If the Image Description dialog box appears, enter text to describe the image for users with disabilities or for users whose browsers are set to display text only, and then click OK.

The image appears in your draft. To make the image web-ready, Contribute reduces large images to the size pre-set by the Contribute administrator, if the administrator has enabled image processing for your role.

Note: If the image you are inserting is from your computer, you can edit the image inline, but you can’t edit the image in an external application until you publish the draft. For more information about editing, see “Editing an image in Contribute” on page 100.

Tip: After you insert the image, double click the image to change image properties. For more information, see “Changing image properties” on page 97.

Related topics
• “Using the Insert menu or Image button to add images to a page” on page 94
• “Dragging images to a page” on page 95

Inserting shared assets into a web page

Contribute enables you to insert images, Macromedia Flash content, or Macromedia Dreamweaver library items from a list of shared assets for your website.

Your Contribute administrator adds assets to the list so they are available to most or all users. Then you can simply insert assets from the list as you need them.

For example, suppose you need to add the official company logo to your draft. As long as your Contribute administrator has added the logo to the list of shared assets for your role, you can easily find the approved logo and add it to your page. For more information, see “Setting options for shared assets” on page 255.

To insert a shared asset into a web page:
1. Place the insertion point in your draft where you want the shared asset to appear.
2. Do one of the following, depending on the type of shared asset you are inserting:
   • For all shared assets, including Dreamweaver library items, select Insert > Shared Asset.
   • For images only, select Insert > Image > From Shared Assets or click the Image button on the toolbar, and then select From Shared Assets.
   • For Flash content only, select Insert > Flash > From Shared Assets.

Note: If library items and Flash content are not available, your Contribute administrator might have indicated that users in your role can insert images only from shared assets.
The Insert Shared Asset dialog box appears.

3. Select a shared asset in the left pane.
   A preview appears in the right pane.
4. Click OK.
5. If the Image Description dialog box appears, enter text to describe the image for users with disabilities or for users whose browsers are set to display text only, and then click OK.
   The shared asset appears on your draft.

Related topics
• “Adding an image to a page” on page 93
• “Inserting Flash content into your web page” on page 105

Changing image properties

After you add an image to a page (see “Adding an image to a page” on page 93), you can change its viewable properties. Image properties include location of image source, display area size, padding, alignment, border, and alternate text.

Modifying image properties only affects the way the image appears on the page. To edit the image, see “Editing an image in Contribute” on page 100.
To change image properties:
1. In your draft, do one of the following:
   - Double-click the image.
   - Select the image, and then click the Image Properties button in the image editing toolbar.
   - Select the image, and then select Format > Image Properties.
   - Right-click (Windows) or Control-click (Macintosh) the image, and then select Image Properties.
   
   The Image Properties dialog box appears.

2. Make changes as desired.
   For information about options in the dialog box, click the Help button.
3. Click OK.
   Contribute applies your changes to the image.

Related topics
- “Adding an image to a page” on page 93

Changing an image’s position or orientation
You can move an image on a page, you can change its alignment in relation to surrounding elements, and you can rotate an image to change its orientation on the page.

Moving an image
You can easily move an image to a new location on a web page.

To move an image on a draft, do one of the following:
- Drag the image to a new location.
- Select the image, and then copy (or cut) and paste the image in a new location.
Aligning an image

You can change image alignment two ways: you can change the alignment of an image on the page (for example, where an image is in a table cell) or you can change how the image aligns with surrounding elements.

To change alignment of an image:
1. In your draft, select the image you want to realign.
2. Click an alignment option in the image editing toolbar.
Contribute aligns the image in the draft.

To change alignment of an image in relation to surrounding elements:
1. In your draft, select the image you want to realign.
2. Do one of the following:
   - Double-click the image, and then select an option from the Alignment pop-up menu in the Image Properties dialog box.
   - Right-click (Windows) or Control-click (Macintosh) the image, and then select an option from the Align pop-up menu.
Contribute aligns the image in relation to surrounding elements, such as text.

Related topics
• “Changing image properties” on page 97
• “Editing an image in Contribute” on page 100
• “Aligning an image” on page 99
• “Rotating an image” on page 103
Editing an image in Contribute

Within Contribute, you can edit an image’s brightness and contrast, sharpening, cropping, and dimensions.

To make more advanced edits, you can edit images in an external image-editing application. For more information, see “Editing an image in an external application” on page 104.

Note: When you edit an image in Contribute, Contribute creates a copy of the image you are editing, so edits affect only this instance of the image. When you use Contribute to edit an image in an external application, you edit the original image source file, so these edits affect all instances of that image on your website.

Adjusting the brightness and contrast of an image

You can adjust the contrast or brightness of an image. This affects the highlights, shadows, and midtones of an image. You typically adjust brightness and contrast to correct images that are too dark or too light.

Note: Changing an image this way affects only this instance of the image; it does not affect the original image source file.

To adjust the brightness and contrast of an image:
1. In your draft, select the image you want to adjust.
2. Do one of the following:
   - Click the Brightness/Contrast button in the image editing toolbar.
   - Select Format > Edit Image > Adjust Brightness and Contrast.
   - Right-click (Windows) or Control-click (Macintosh) the image, and then select Edit Image > Adjust Brightness and Contrast.

   Note: These options are not available if you belong to a user role that the Contribute administrator has restricted from inline image editing. For more information, talk to your Contribute administrator or see “Setting page-editing and paragraph settings” on page 249.

   The Brightness/Contrast dialog box appears.

3. Drag the Brightness and Contrast sliders to adjust the settings.
4. Click OK.

Related topics
- “Adding an image to a page” on page 93
- “Cropping an image” on page 101
- “Resizing an image” on page 102
- “Rotating an image” on page 103
Sharpening an image

Sharpening increases the contrast around the edges of objects to increase the image’s definition.

Note: Changing an image this way affects only this instance of the image; it does not affect the original image source file.

To sharpen an image:
1. In your draft, select the image you want to adjust.
2. Do one of the following:
   - Click the Sharpen button in the image editing toolbar.
   - Select Format > Edit Image > Sharpen.
   - Right-click (Windows) or Control-click (Macintosh) the image, and then select Edit Image > Sharpen.

   Note: These options are not available if you belong to a user role that the Contribute administrator has restricted from inline image editing. For more information, talk to your Contribute administrator or see “Setting page-editing and paragraph settings” on page 249.

   The Sharpen dialog box appears.
3. Specify the degree of sharpening by dragging the slider control, or entering a value between 0 and 10 in the text box.
   As you adjust the sharpness of the image, you can preview the change to the image.
4. Click OK.

To undo sharpening and revert to the original image:
   - Select Edit > Undo Sharpen.

You can only undo the effect of the Sharpen command (and revert to the original image file) before publishing the page containing the image.

Related topics
- “Adding an image to a page” on page 93
- “Adjusting the brightness and contrast of an image” on page 100
- “Resizing an image” on page 102
- “Rotating an image” on page 103

Cropping an image

You can crop (or trim) images.

Note: Changing an image this way affects only this instance of the image; it does not affect the original image source file.
To crop an image:
1. In your draft, select the image you want to crop.
2. Do one of the following:
   - Click the Crop Tool icon in the image editing toolbar.
   - Select Format > Edit Image > Crop.
   - Right-click (Windows) or Control-click (Macintosh) the image, and then select Edit Image > Crop.
   
   **Note:** These options are not available if you belong to a user role that the Contribute administrator has restricted from inline image editing. For more information, talk to your Contribute administrator or see “Setting page-editing and paragraph settings” on page 249.

   Crop handles appear.
3. Adjust the crop handles to surround the part of the image you want to keep.
4. Do one of the following to finish the crop:
   - Double-click inside the bounding box.
   - Press Enter or Return.
   - Right-click (Windows) or Control-click (Macintosh) the image, and then select Edit Image > Finish Crop.

   The shaded part of the image disappears from the image.

To undo the effects of the Crop command and revert to the original image:
- Select Edit > Undo Crop.

You can undo the effect of the Crop command (and revert to the original image file) until you quit Contribute.

Related topics
- “Adding an image to a page” on page 93
- “Adjusting the brightness and contrast of an image” on page 100
- “Sharpening an image” on page 101
- “Rotating an image” on page 103

Resizing an image
You can change the size of an image visually or by entering specific values.

**Note:** Changing an image this way affects only this instance of the image; it does not affect the original image source file.

To resize an image visually:
1. In your draft, select the image you want to resize.
2. Click the Resize button in the image editing toolbar.
3. Drag one of the selection handles to the desired image size.

Contribute changes the height and width of the image by the same percentage so that the image is not distorted.

Tip: Hold the Shift key as you drag if you do not want to change the height and width of the image by the same percentage.

Note: Resizing this way affects the image size and its display area on the page. To change only the display area, see “Changing image properties” on page 97.

To resize an image with specific values:
1. In your draft, select the image you want to resize.
2. Enter Width and Height values in the image editing toolbar.
Contribute changes the height and width of the image.

Note: Resizing this way affects the image size and its display area on the page. To change only the display area, see “Changing image properties” on page 97.

To revert an image to its original size:
• In your draft, select Format > Edit Image > Revert to Original Size.

Related topics
• “Adding an image to a page” on page 93
• “Adjusting the brightness and contrast of an image” on page 100
• “Sharpening an image” on page 101
• “Cropping an image” on page 101

Rotating an image

You can rotate an image to change its orientation on the page.

To rotate an image:
1. In your draft, select the image you want to rotate.
2. Do one of the following:
   ■ Click one of the rotate buttons in the image editing toolbar.
     Tip: You can click the rotate button multiple times to further rotate the image.
   ■ Select Format > Edit Image > Rotate Clockwise or Edit Image > Rotate Counter-Clockwise.
   ■ Right-click (Windows) or Control-click (Macintosh) the image, and then select Edit Image > Rotate Clockwise or Edit Image > Rotate Counter-Clockwise.
Editing an image in an external application

You can use Contribute to start an external image-editing application. You can make simple edits directly in Contribute, using the image editing toolbar (see “Editing an image in Contribute” on page 100).

Note: When you edit an image in Contribute, Contribute creates a copy of the image you are editing, so edits affect only this instance of the image. When you use Contribute to edit an image in an external application, you edit the original image source file, so these edits affect all instances of that image on your website.

To edit an image in an external image-editing application:

1. Do one of the following:
   - In the Contribute browser, click Choose in the toolbar, select the image you want to edit, and then click OK. When the image opens, click Edit in the toolbar.
   - In the Contribute editor, select an image, and then select Format &gt; Edit Image in External Application or right-click (Windows) or Control-click (Macintosh) the image, and then select Edit Image in External Application.

Note: The image you select should be on a published page on your website or in one of your website folders. If you add a new image to a draft, you cannot edit that image in an external editor until it has been published to the website.

Contribute starts an application for you to edit the image.

2. If you are editing an image in Fireworks, click No in the Find Source dialog box to indicate that you do not want to edit the source file for this image.
   
   By clicking No, you edit the image for the website only.

3. In the external application, make changes as necessary, and then save your changes and close the application.

   Warning: Editing an image in an external application permanently changes the original image saved on the server and affects other occurrences of this image throughout your website.

4. If you are editing in Fireworks, click Done in the editing window, and then close the application.
   
   If you need to make additional changes to the image before you publish, click Launch in Contribute to open the content in the external editor again.

5. In Contribute, click Publish to publish your changes to the website.

Note: Depending on the role the Contribute administrator assigned you, you might not be able to publish.

The updated image appears in Contribute.
Inserting Flash content into your web page

Many websites contain Flash assets such as navigation buttons or a banner. You can insert Flash content from your computer, from your website, or from your Shared Assets list.

When you publish a page that contains Flash content, Contribute automatically copies the file to your website.

Note: For information about inserting movie types other than Flash, see “Inserting a movie into your web page” on page 106.

To insert Flash content:
1. Place the insertion point in your draft where you want the Flash content to appear.
2. Select one of the following options:
   - Insert > Flash > From My Computer
   - Insert > Flash > From Website
   - Insert > Flash > From Shared Assets

   The Open, Choose Image From Website, or Insert Shared Asset dialog box appears.
3. Navigate to and select the Flash SWF file you want to insert, and then click Open or OK.

   The Flash movie object appears in your draft.

To reuse a Flash movie (SWF file):
• Select Insert > Flash > From Website.

Setting Flash movie properties

You can set properties for Flash movies (SWF files) that you insert into your web pages.

To set Flash movie properties:
1. In your draft, select the Flash movie object.
2. Select Format > Flash Movie Properties.

   The Flash Movie Properties dialog box appears.
3. Make changes as necessary.
   For information about options in the dialog box, click the Help button.
4. Click OK.

**Related topics**
- “Inserting Flash content into your web page” on page 105

**Inserting a movie into your web page**

You can embed movies in a web page and control them within Contribute. For example, you can insert a video from a still camera, video camera, or a video editor, such as Movie Maker or iMovie.

**Note:** If you are inserting a Flash movie (SWF file), the process is slightly different; for more information, see “Inserting Flash content into your web page” on page 105.

You can insert movies that are saved on your computer or movies that are on your website. You can insert several different movie file types, including QuickTime (MOV and QT), video files (MPG or MPEG), AVI, and Windows Media (WMV).

**Note:** When you edit and save movies for your website, be sure to save the movies for the web, so they are compressed.

**To insert a movie:**
1. Place the insertion point in your draft where you want the movie to appear.
2. Select one of the following options:
   - Insert > Movie > From My Computer
   - Insert > Movie > From Website
   The Select Movie or Choose Movie From Website dialog box appears.
3. Navigate to and select the movie file that you want to insert, and then click **Open**.

   **Note:** If you insert MOV file types in Contribute, your website visitors must have the QuickTime player installed to view the movie on a Windows computer. If you insert WMV file types, your website visitors must have the Windows Media player installed to view the movie on a Macintosh.

   A movie placeholder appears in your draft. The movie does not play in the draft; you must publish your draft to play the movie.

   **Tip:** The default movie display in Contribute is 320 x 240. Check your movie file properties for the size of your movie. Then, double-click the movie placeholder in Contribute to set the display size to the size of your movie, so your web page displays the movie properly.

**Setting movie properties**

You can set properties for movies you insert into your web pages.

**Note:** If you want to edit properties for a Flash movie (SWF file), see “Setting Flash movie properties” on page 105.
To set movie properties:
1. In your draft, select the movie placeholder.
2. Double-click the movie placeholder, or select Format > Movie Properties.
   The Movie Properties dialog box appears.
3. Make changes as necessary.
   For information about options in the dialog box, click the Help button.
4. Click OK.

Related topics
• “Inserting a movie into your web page” on page 106

Adding and deleting a horizontal rule
You can add horizontal rules to your pages to help organize content. For example, you can use rules to group text and other elements into topic areas.
To insert a horizontal rule:
1. Place the insertion point in your draft where you want the horizontal rule to appear.
2. Select Insert > Horizontal Rule.

Contribute inserts the horizontal rule. Content before the insertion point appears above the line, and content after the insertion point appears below the line.

To delete a horizontal rule:
1. In your draft, click the horizontal rule to select it.
2. Press Delete.

Changing the properties of a horizontal rule

You can customize the height, width, and shading applied to a horizontal rule on a page. By default, a horizontal rule in Contribute is 3 pixels high, expands to the width of the page or table cell in which it is inserted, and has a small drop shadow (or shading) applied.

For information about adding and deleting horizontal rules to a page, see "Adding and deleting a horizontal rule" on page 107.

To set horizontal rule properties:
1. In your draft, click the horizontal rule to select it, and do one of the following:
   ■ Select Format > Horizontal Rule Properties.
   ■ Right-click (Windows) or Control-click (Macintosh) the horizontal rule, and then select Properties.

   The Horizontal Rule Properties dialog box appears.

2. Change options as necessary.

   For information about options in the dialog box, click the Help button.
3. Click OK.

   Contribute changes the horizontal rule properties.

Related topics
• “Adding and deleting a horizontal rule” on page 107
Inserting PayPal e-commerce buttons

PayPal is a payment processing service that enables you to sell your products and services online and accept credit card payments from your customers. You can add instant e-commerce functionality by creating payment buttons on your web pages.

**Note:** Your Contribute administrator must enable the PayPal feature for your role before you can use it. For more information, talk to your Contribute administrator or see “Setting page-editing and paragraph settings” on page 249.

This section covers the following topics:

- “Inserting a single PayPal button” on page 109
- “Inserting multiple PayPal buttons” on page 110
- “Editing a PayPal button” on page 110

Related topics

- “About PayPal buttons” on page 92

Inserting a single PayPal button

You can easily insert a PayPal button into your page.

**To insert a PayPal button:**

1. Place the insertion point in your draft where you want the button to appear.

   **Note:** Make sure the insertion point does not overlap another PayPal button.

2. Select Insert > PayPal, and then select the type of button you want to insert.

   **Note:** If you cannot select a button, your Contribute administrator hasn’t enabled the PayPal feature for your role. For more information, talk to your Contribute administrator or see “Setting page-editing and paragraph settings” on page 249.

   The PayPal object wizard opens.

3. In the wizard, complete the screens to set the options you want to apply.

   Click Next to move through the screens in the wizard.


   The PayPal button appears in your draft.

Related topics

- “About PayPal buttons” on page 92
- “Inserting multiple PayPal buttons” on page 110
- “Editing a PayPal button” on page 110
Inserting multiple PayPal buttons

You can insert multiple PayPal buttons in the same page. For example, you might insert an Add to Cart button and a View Cart button in the same page. However, you cannot insert more than one PayPal button in a paragraph or table cell. If you attempt to do so, an error message appears.

Note: Your Contribute administrator must enable the PayPal feature for your role before you can use it. For more information, talk to your Contribute administrator or see “Setting page-editing and paragraph settings” on page 249.

To add a button in a paragraph that already contains a button:
1. In your draft, place the insertion point in the paragraph, and then press Enter (Windows) or Return (Macintosh).
2. Insert a PayPal button.

To add a button to a table cell that already contains a button:
1. In your draft, place the insertion point in the cell, and then select Table > Split Cell.
2. Insert a PayPal button.

Related topics
• “About PayPal buttons” on page 92
• “Inserting a single PayPal button” on page 109
• “Editing a PayPal button” on page 110

Editing a PayPal button

You can edit the setting you originally set for a PayPal button. For example, you might want to raise or reduce the price of an item, update the item name or description, select a different button image and so on.

To edit a PayPal button:
1. In the draft, click to select the PayPal button you want to edit.
   The highlighted button type for the selected button is the only item enabled in the pop-up menu.
3. Click a tab in the Advanced options screen to select the type of information you want to update, and then make your changes.
4. Click OK to save your changes.

Related topics
• “About PayPal buttons” on page 92
• “Inserting a single PayPal button” on page 109
• “Inserting multiple PayPal buttons” on page 110
A table is a powerful tool for presenting tabular data. For example, you might add a table to a web page that lists all your sales reps in one column, with their contact information in another column.

In Macromedia Contribute, you can add text and images to table cells the same way that you add text and images to a page (see “Working with Text” on page 73 and “Working with Images and Graphical Elements” on page 91). After you create a table you can easily modify both its appearance and structure.

This chapter contains the following sections:

• “About conflicts in table formatting” on page 111
• “Inserting a table on a page” on page 112
• “Selecting table elements” on page 113
• “Resizing tables, rows, and columns” on page 115
• “Aligning tables” on page 116
• “Cutting and copying table cells” on page 117
• “Adding, deleting, and merging table rows and columns” on page 119
• “Modifying table appearance” on page 121
• “Sorting tabular data” on page 126

About conflicts in table formatting

When formatting tables, you can set properties for the entire table or for selected cells, rows, or columns in the table.

When a table property, such as background color or alignment, is set to one value for the entire table and another value for individual cells, cell formatting takes precedence over row formatting, which in turn takes precedence over table formatting.

The order of precedence for table formatting is as follows:

1. Cells
2. Rows
3. Table

For example, if you set the background color for a single cell to blue, and then set the background color of the entire table to yellow, the blue cell does not change to yellow because cell formatting takes precedence over table formatting.

*Note:* When you set properties for a column, Contribute changes the attributes of the `td` tag corresponding to each cell in the column.

**Related topics**

- “Modifying table appearance” on page 121

**Inserting a table on a page**

You can insert a table anywhere on a page, including within another table. You can quickly add a standard table with three rows and three columns, or you can modify options to add a custom table.

**Tip:** When you start adding content to your table, use Preview in Browser to see exactly how the table will appear in the browsers of your website visitors (see “Previewing a page in your default browser” on page 152).

**To insert a table:**

1. Place the insertion point in your draft where you want the table to appear.
2. Do one of the following to open the Insert Table dialog box:
   - Click the Table button in the toolbar.
   - Select Insert > Table.
   - Select Table > Insert > Table.

The Insert Table dialog box appears.
3. Complete the dialog box.
   For information about options in the dialog box, click the Help button.
4. Click OK.
   The table appears in your draft.

   **Tip:** After you insert the table, select it, and then click the Table button again to change table properties. For information about changing header properties, see “Modifying row or column properties” on page 123.

**To insert a table within a table:**
1. In your draft, place the insertion point in the table cell where you want the table to appear.
2. Do one of the following to open the Insert Table dialog box:
   - Click the Table button in the toolbar.
   - Select Insert > Table.
   - Select Table > Insert > Table.
   The Insert Table dialog box appears.
3. Change options as necessary.
4. Click OK.
   The table appears in the table cell where you placed the insertion point.

**Related topics**
- “Selecting table elements” on page 113
- “Resizing tables, rows, and columns” on page 115
- “Adding, deleting, and merging table rows and columns” on page 119
- “Modifying table appearance” on page 121

**Selecting table elements**
You can select an entire table, row, or column, or you can select a single cell or a contiguous block of cells within a table.

**Related topics**
- “Modifying table appearance” on page 121
- “Cutting and copying table cells” on page 117

**Selecting an entire table, row, or column**
You might select an entire table, row, or column because you want to paste it onto another page (see “Cutting and copying table cells” on page 117) or because you want to change the background of all the cells in the selection at once (see “Modifying table appearance” on page 121).
To select an entire table, do one of the following:
• Click the upper left corner of the table or click anywhere on the right or bottom edge.
• Click in a table cell, and then select **Table > Select Table**.
  Selection handles appear on the selected table's lower and right edges.

To select rows or columns:
1. Position the pointer to point at the left edge of a row or the top edge of a column.
2. When the pointer changes to a selection arrow, click to select the row or column, or drag to select multiple rows or columns.

Selecting a cell, a block of cells, or nonadjacent cells
You might want to select a cell or group of cells because you want to paste it onto another page (see “Cutting and copying table cells” on page 117) or because you want to change the background of all the cells in the selection at once (see “Modifying table appearance” on page 121).

When you select a block of cells, the block must form a rectangle. When you select multiple nonadjacent cells in a table, you can only modify the properties of those cells. You cannot copy or paste sets of nonadjacent cells.

To select a single cell, do one of the following:
• Click in the cell, and then drag to select the cell.
• Click in the cell, and then select **Edit > Select All**.

To select a line or a rectangular block of cells, do one of the following:
• Drag from one cell to another cell.
• Click in one cell, and then Shift-click another cell.
  All the cells within the linear or rectangular region defined by the two cells are selected.
To select nonadjacent cells:

- Control-click (Windows) or Command-click (Macintosh) the cells, rows, or columns you want to select.

**Note:** If a cell, row, or column you Control-click or Command-click isn’t already selected, it’s added to the selection. If it is already selected, it’s removed from the selection.

Related topics

- “Selecting an entire table, row, or column” on page 113

Resizing tables, rows, and columns

You can resize an entire table or individual rows and columns. When you resize an entire table, all the cells in the table are resized proportionately.

To resize a table:

1. In your draft, select the table you want to resize (see “Selecting table elements” on page 113).
2. Do one of the following:
   - To resize the table horizontally, drag the selection handle on the right.
   - To resize the table vertically, drag the selection handle on the bottom.
   - To resize in both dimensions, drag the selection handle at the lower right corner.

To resize a column’s width, do one of the following in your draft:

- Select the column, and then drag the right border of the column.
- Select the column, and then click the Table button in the toolbar.
  
  In the Table Column Properties dialog box, change the number in the Column width text box, and then select Pixels or Percent for the width. Alternatively, select Fit to contents to clear the set width and resize the columns to accommodate the content you add.

**Note:** If you select any column but the rightmost one, the width of the adjacent column also changes, and Contribute retains the original table width. If you select the rightmost column, the width of the entire table changes, and all the columns grow wider or narrower proportionately.

To resize a row’s height, do one of the following in your draft:

- Select the row, and then drag the lower border of the row.
- Select the row, and then click the Table button in the toolbar.

In the Table Row Properties dialog box, change the number in the Row height text box. Alternatively, select Fit to contents to clear the set height and resize the rows to accommodate the content you add.
Aligning tables

You can indicate how a table aligns on the web page in relation to elements, such as text or images, around it on the page.

You cannot select an alignment option when you create a table. You must insert the table (see “Inserting a table on a page” on page 112), and then change the alignment option in table properties.

To change alignment for a table:
1. In your draft, select the table you want to realign (see “Selecting table elements” on page 113).
2. Do one of the following to open the Table Properties dialog box:
   - Click the Table button in the toolbar.
   - Right-click (Windows) or Control-click (Macintosh), and then select Table Properties from the pop-up menu.
   - Select Table > Table Properties.
   The Table Properties dialog box appears.

3. Select an alignment option from the Table alignment pop-up menu:
   - Default aligns the table to the left of the page. Text or images do not flow around the table.
   - Left aligns the table to the left side of the page. Text or images flow to the right of the table.
   - Center aligns the table in the center of the page.
   - Right aligns the table to the right side of the page. Text or images flow to the left of the table.
4. Click Apply to see changes without closing the dialog box, or click OK to apply changes and close the dialog box.
   The table alignment changes in your draft.

---

116  Chapter 8: Working with Tables
Cutting, copying, and pasting cells

You can cut, copy, or paste a single table cell or multiple cells at once, preserving the cell formatting. You can paste cells at the insertion point or paste over a selection in an existing table.

The selected cells must be contiguous and in the shape of a rectangle. For example, the selection in this illustration is a rectangle of cells, so the cells can be cut or copied.

<table>
<thead>
<tr>
<th>Name</th>
<th>Phone</th>
<th>Role</th>
</tr>
</thead>
<tbody>
<tr>
<td>Derek Brown</td>
<td>X1163</td>
<td>Project Manager</td>
</tr>
<tr>
<td>George Woods</td>
<td>X1162</td>
<td>Director, Operations</td>
</tr>
<tr>
<td>Dana Smith</td>
<td>X7094</td>
<td>Customer Service</td>
</tr>
</tbody>
</table>

The selection in this illustration is not a rectangle, so the cells can't be cut or copied.

Cutting and copying table cells

You can copy a single cell or multiple cells, and cut the cells, or the cells’ content, from the table. You can copy a single cell or multiple cells, and paste the cells in the same or another table (see “Pasting table cells” on page 118).

To copy table cells, rows, or columns:
1. In your draft, select one or more cells, rows, or columns in the table (see “Selecting table elements” on page 113).
2. Do one of the following:
   - Select Edit > Copy.
   - Right-click (Windows) or Control-click (Macintosh), and then select Copy.
Contribute copies the selection to the Clipboard.

To cut table cells, rows, or columns:
1. In your draft, select one or more cells, rows, or columns in the table (see “Selecting table elements” on page 113).
2. Do one of the following:
   - Select Edit > Cut.
   - Right-click (Windows) or Control-click (Macintosh), and then select Cut.
Contribute cuts the selection from the table and copies it to the Clipboard.
To remove cell content but leave the cells intact:

1. In your draft, select one or more cells.

   **Note:** Do not select an entire row or column. If you do, then when you select Edit > Clear or press Delete, Contribute removes the entire row or column—not just its contents—from the table.

2. Select Edit > Clear or press Delete.

   Contribute removes the contents of the cells you selected, but leaves the empty cells in the table.

   • “Deleting rows and columns” on page 120

Pasting table cells

You can copy cells (see “Cutting and copying table cells” on page 117) and then paste them at the insertion point in a table or paste over a selection in an existing table.

When you paste multiple table cells, the contents of the Clipboard must be compatible with the structure of the table or the selected block where they will go. For example, if you copy a block that is two cells by two cells, you must paste it in a two-by-two block.

**To paste table cells:**

1. Copy some table cells (see “Cutting and copying table cells” on page 117).

2. In your draft, do one of the following to indicate where you want to paste the cells:

   ■ To replace existing cells with the cells you are pasting, select a set of existing cells with the same layout as the cells you copied.

   For example, if you've cut or copied a three-by-two block of cells, select another three-by-two block in which to paste the cut or copied content.

   ■ To paste a full row of cells above a particular cell, click in that cell.

   ■ To paste a full column of cells to the left of a particular cell, click in that cell.

   ■ To create a new table with the pasted cells, place the insertion point outside the table.

   **Note:** If you have less than a full row or column of cells in the Clipboard, and you click in a cell and then paste the cells from the Clipboard, the cell you clicked in and its neighbors (depending on its location in the table) might be replaced with the cells you are pasting.

3. Do one of the following:

   ■ Select Edit > Paste.

   ■ Right-click (Windows) or Control-click (Macintosh), and then select Paste.

   Contribute pastes the cells from the Clipboard.

**Related topics**

• “Cutting and copying table cells” on page 117
Adding, deleting, and merging table rows and columns

You can modify an existing table by adding or deleting rows or columns. You can also merge cells to accommodate data.

Adding rows and columns

You can add a single row or column, or you can add multiple rows or columns at the same time.

**To add a single row to a table:**
1. In your draft, place the insertion point in a table cell, or select an entire row.
2. Do one of the following:
   - Click the **Insert Row Below** button in the toolbar.
   - Select **Table > Insert > Row Above** or **Table > Insert > Row Below**.
   - Right-click (Windows) or Control-click (Macintosh), and then select **Insert Row Above** or **Insert Row Below**.

**To add a single column to a table:**
1. In your draft, place the insertion point in a table cell, or select an entire column.
2. Do one of the following:
   - Click the **Insert Column to the Right** button in the toolbar.
   - Select **Table > Insert > Column to the Left** or **Table > Insert > Column to the Right**.
   - Right-click (Windows) or Control-click (Macintosh), and then select **Insert Column to the Left** or **Insert Column to the Right**.

**To add multiple rows or columns to a table:**
1. In your draft, place the insertion point in a table cell.
2. Do one of the following:
   - Select **Table > Insert > Multiple Rows or Columns**.
   - Right-click (Windows) or Control-click (Macintosh), and then select **Insert Multiple Rows or Columns**.

The Insert Rows or Columns dialog box appears.
3. Complete the dialog box.
   For information about options in the dialog box, click the Help button.
4. Click OK.
   Contribute adds the rows or columns to your table.

Related topics
• “Merging and splitting cells” on page 120

Deleting rows and columns
You can delete a single row or column, or you can delete multiple rows or columns at the same time.

To delete rows or columns from a table in your draft, do one of the following:
• Select entire rows or columns, and then press Delete or Backspace.
• Select entire rows or columns or place the insertion point in a single row or column, right-click (Windows) or Control-click (Macintosh), and then select Delete Row or Delete Column.
• Select entire rows or columns, and then select Table > Delete > Row or Table > Delete > Column.

Related topics
• “Selecting table elements” on page 113
• “Adding rows and columns” on page 119

Merging and splitting cells
You can merge any number of adjacent cells—as long as the entire selection is a line or a rectangle of cells—to produce a single cell that spans several columns or rows. You can split a cell into any number of rows or columns, regardless of whether it was previously merged.

To merge table cells:
1. In your draft, select the cells you want to merge.
   Note: You must select at least two cells.
2. Do one of the following:
   • Select Table > Merge Cells.
   • Right-click (Windows) or Control-click (Macintosh), and then select Merge Cells.
   Contribute merges the content into a single cell.
To split table cells:
1. In your draft, place the insertion point in the cell you want to split.
   
   **Note:** Contribute only splits one cell at a time, even if you select multiple cells.

2. Do one of the following:
   - Select Table > Split Cell.
   - Right-click (Windows) or Control-click (Macintosh), and then select Split Cell.
     
     The Split Cell dialog box appears.

3. Select a radio button to indicate whether to split the cell into rows or columns, and then enter the number of new rows or columns in which to divide the cell.

4. Click OK.
   
   Contribute splits the cell into multiple rows or columns.

**Related topics**
- “Selecting table elements” on page 113
- “Adding rows and columns” on page 119
- “Deleting rows and columns” on page 120

**Modifying table appearance**

You can modify a table’s appearance by doing any of the following:

- Changing properties for an entire table (see “Modifying table properties” on page 122)
- Changing properties for individual cells, rows, or columns in a table (see “Modifying row or column properties” on page 123 and “Modifying cell properties” on page 124)
- Applying a preset design scheme to a table (see “Using a preset table format” on page 125)

**Note:** Before you change properties, it’s a good idea to understand how Contribute resolves formatting conflicts for cells, rows, and tables (see “About conflicts in table formatting” on page 111).
Modifying table properties

You can modify the alignment, width, border width and color, and background color of a selected table.

To modify table properties:
1. In your draft, select the table you want to modify (see “Selecting table elements” on page 113).
2. Do one of the following to open the Table Properties dialog box:
   ■ Click the Table button in the toolbar.
   ■ Right-click (Windows) or Control-click (Macintosh), and then select Table Properties from the pop-up menu.
   ■ Select Table > Table Properties.
   The Table Properties dialog box appears.

3. Change table properties as necessary.
   For information about options in the dialog box, click the Help button.
4. Click Apply to apply changes without closing the dialog box, or click OK to apply changes and close the dialog box.
   Your table property changes appear in your draft.

Related topics
• “Modifying cell properties” on page 124
Modifying row or column properties

You can modify horizontal and vertical alignment, background color, height or width, and text wrap for a selected row or column.

**Note:** To understand how Contribute resolves formatting conflicts for cells, rows, and tables, see “About conflicts in table formatting” on page 111.

To modify table row or column properties:

1. In your draft, select the row or column you want to modify (see “Selecting an entire table, row, or column” on page 113).

2. Do one of the following to open the Table Properties dialog box:
   - Click the **Table** button in the toolbar.
   - Right-click (Windows) or Control-click (Macintosh), and then select **Table Cell Properties** from the pop-up menu.
   - Select **Table > Table Cell Properties**.

   The Table Properties dialog box appears with the appropriate tab selected.

3. Change the row or column properties as desired.

   For information about options in the dialog box, click the Help button.

4. Click **Apply** to preview your changes, or click **OK** to apply changes and close the dialog box.

**Related topics**

- “Modifying table properties” on page 122
Modifying cell properties

You can modify horizontal and vertical alignment, background color, and text wrap for a selected cell.

Note: To understand how Contribute resolves formatting conflicts for cells, rows, and tables, see “About conflicts in table formatting” on page 111.

To modify table cell properties:
1. In your draft, select the cell or cells you want to modify (see “Selecting an entire table, row, or column” on page 113).
2. Do one of the following to open the Table Properties dialog box:
   ■ Right-click (Windows) or Control-click (Macintosh), and then select Table Cell Properties from the pop-up menu.
   ■ Select Table > Table Cell Properties.
   ■ Click the Table button in the toolbar.
     Note: If you placed the insertion point in the cell instead of selecting the cell, this option opens the Insert Table dialog box instead of the Table Properties dialog box for cells.

The Table Properties dialog box appears with the appropriate tab selected.

3. Change the cell properties as desired.
   For information about options in the dialog box, click the Help button.
4. Click Apply to preview your changes, or click OK to apply changes and close the Table Properties dialog box.

Related topics
• “Modifying table properties” on page 122
• “Modifying row or column properties” on page 123
Using a preset table format

You can apply a preset design to a table and select options to further customize the design.

**Note:** You can apply preset table designs to a simple rectangular grid of cells only. You can’t use these designs to format tables that contain merged cells or other unusual formatting.

**To use a preset table design:**

1. In your draft, select a table to modify or place the insertion point in any cell in the table.
2. Select Table > Format Table.
   The Format Table dialog box appears with the Basic tab selected.

3. Complete the dialog box.
   For information about options in the dialog box, click the Help button.
4. Click OK.
   Contribute formats your table with the design you selected.
Sorting tabular data

You can sort the rows of a table based on the contents of a single column. For example, if you have a Names column in a table, you can sort items in that column alphabetically.

You can also perform a more complicated table sort based on the contents of two columns.

**Note:** You cannot sort on a column that contains merged cells.

To sort a table:

1. In your draft, select the table to sort or place the insertion point in any cell in the table.
2. Select Table > Sort Table.
   The Sort Table dialog box appears.

3. Complete the dialog box.
   For information about options in the dialog box, click the Help button.
4. Click OK.
   Contribute reorders the table.
CHAPTER 9
Working with Links

A hypertext link, often called a link, creates a connection from one page to another page. In a web page, links are typically underlined and differentiated by color from the surrounding text. When a visitor to your website clicks a link in one page, another page opens.

Visitors use links to navigate your website. When you add a new page to a website, you have to add a link to the new page on an existing page. Then, users can click the link in the existing page to view the new page.

When you add a link to a page, the link is not live until you publish the page (see “Publishing Your Page” on page 151). Before you publish a page with a link, you should use the Preview in Browser feature to test the link and make sure it works.

This chapter contains the following sections:

• “Creating text and image links” on page 127
• “Setting the advanced linking options” on page 137
• “Editing links” on page 142
• “Testing links” on page 144

Creating text and image links

In Macromedia Contribute, you can make text or images in your web page act as links. When a visitor to your website clicks a link—specified text or an image—the browser takes the visitor to another web page or file, or starts their e-mail application.

Your text or image can link to any of the following:

• A current draft or a recently published page on your website
• A new web page, which Contribute creates at the same time as the link
• An existing web page on your website or on another website
• An e-mail address
• An existing file on your computer, such as a Microsoft Word or PDF file

Note: To link to items in your Macromedia Breeze account, see “Linking to Breeze content, training, and meetings” on page 135.
Related topics
• “Setting the advanced linking options” on page 137
• “Editing links” on page 142
• “Testing links” on page 144

Linking to a draft or a recently published page on your website

You can create a link on your page to a draft that you are currently editing or to a recently published page on your website. Contribute has a complete list of current drafts for you to link to, and stores a list of the last ten pages you published on your website.

For information about linking to a page that is not a current draft or was not recently published, see “Linking to a page on your website or on another website” on page 131.

To create a link to a draft or recently published page on your website:
1. In your draft, do one of the following to indicate where the link will appear:
   ■ Place the insertion point in the draft.
   ■ Select text in the draft.
   ■ Select an image in the draft.

2. Do one of the following to open the Insert Link dialog box:
   ■ Click the Link button in the toolbar, and then select Drafts and Recent Pages.
   ■ Select Insert > Link > Drafts and Recent Pages.
   ■ Right-click (Windows) or Control-click (Macintosh), and then select Insert Link.

The Insert Link dialog box appears.
3. Click **Drafts and Recent Pages** (Windows) or **Drafts** (Macintosh) at the top of the dialog box, if it’s not already selected.

4. Complete the dialog box.
   For information about options in the dialog box, click the Help button.

5. Click **OK**.
   The link appears in your draft.

**Related topics**
- “Linking to a page on your website or on another website” on page 131
- “Linking to an e-mail address” on page 132
- “Linking to a file on your computer” on page 133

**Linking to a new page**

You can create a link to a new web page on your website—that is, you can create a link to a new page that Contribute creates at the same time that it creates the link.

*Note:* The new page appears on your website when you publish the draft with the link.

For example, suppose you are working on a page listing your products and need to create a link to a product page that doesn't exist yet. Contribute lets you create the new page and link to it before you add content to the page.

The preferred way to add a new page to your website is to create a link and the new page at the same time, and then add content later. (The other way to add a new page to your website is to create the page first, and then link it later. For more information, see “Creating or copying a page on your website” on page 58.)

It's a good idea to create a link to a new page at the same time you create the new page. This way, you don't have to remember to link to the page later, and you ensure that users will be able to navigate to the page on your website.

**To create a link to a new page:**

1. In your draft, do one of the following to indicate where the link will appear:
   - Place the insertion point in the draft.
   - Select text in the draft.
   - Select an image in the draft.

2. Do one of the following to open the Insert Link dialog box:
   - Click the **Link** button in the toolbar, and then select **Create New Page**.
   - Select **Insert > Link > Create New Page**.
   - Right-click (Windows) or Control-click (Macintosh), and then select **Insert Link**.
The Insert Link dialog box appears.

3. Click the **Create New Page** button (Windows) or **New Page** button (Macintosh) at the top of the dialog box, if it is not already selected. The bottom half of the dialog box changes.

4. Complete the dialog box.
   For information about options in the dialog box, click the Help button.

5. Click **OK**.

Contribute adds the link to the draft, and then opens the new page in the Contribute editor.

   To return to the draft where you added the link, click the draft title in the Pages panel.

   **Note:** Contribute automatically saves the new page in the same folder as the draft that links to it (unless you selected another website). When you publish your draft, Contribute also publishes the new page. You can change the folder location for the new page then if you need to.

Related topics
- “Linking to a draft or a recently published page on your website” on page 128
- “Linking to an e-mail address” on page 132
- “Linking to a file on your computer” on page 133
Linking to a page on your website or on another website

You can create a link to another page on your website or on another website. If the page you’re linking to is not linked to any other pages—so you can’t browse to it—Contribute enables you to use the file system to find the page.

*Note:* If the page you want to link to was recently published or is a draft, see “Linking to a draft or a recently published page on your website” on page 128.

**To create a link to a page on your website or on another website:**

1. In your draft, do one of the following to indicate where the link will appear:
   - Place the insertion point in the draft.
   - Select text in the draft.
   - Select an image in the draft.
2. Do one of the following to open the Insert Link dialog box:
   - Click the *Link* button in the toolbar, and then select *Browse to Web Page*.
   - Select *Insert > Link > Browse to Web Page*.
   - Right-click (Windows) or Control-click (Macintosh), and then select *Insert Link*.
   The Insert Link dialog box appears.

![Insert Link dialog box](image)

3. Click the *Browse to Web Page* button (Windows) or *Browse* button (Macintosh) at the top of the dialog box, if it is not already selected.
4. Complete the dialog box.
   For information about options in the dialog box, click the Help button.
5. Click OK.
   Contribute adds the link to your draft.

Related topics
- “Linking to a draft or a recently published page on your website” on page 128
- “Linking to a new page” on page 129
- “Linking to a file on your computer” on page 133

Linking to an e-mail address
You can create a link to an e-mail address. When a website visitor clicks the link, Contribute creates a new message, with the e-mail address you specified, in the visitor’s default e-mail application.

For example, you might create the text link “Contact us about our new products!” When a visitor clicks the link, Contribute starts the visitor’s e-mail application and creates an e-mail message to the Sales department.

To create a link to an e-mail address:
1. In your draft, do one of the following to indicate where the link will appear:
   - Place the insertion point in the draft.
   - Select text in the draft.
   - Select an image in the draft.
2. Do one of the following to open the Link dialog box:
   - Click the Link button in the toolbar, and then select E-mail Address.
   - Select Insert > Link > E-mail Address.
   - Right-click (Windows) or Control-click (Macintosh), and then select Insert Link.
The Insert Link dialog box appears.

3. Click the E-mail Address button (Windows) or E-mail button (Macintosh) at the top of the dialog box, if it is not already selected.

4. Complete the dialog box.
   For information about options in the dialog box, click the Help button.

5. Click OK.
   Contribute adds the link to the page.

Related topics
- “Linking to a draft or a recently published page on your website” on page 128
- “Linking to a new page” on page 129
- “Linking to a page on your website or on another website” on page 131

Linking to a file on your computer

To add content that you have saved on your computer to your website, create a link on a page on your website to a file saved on your computer or network.

For example, you might link to a Word document saved on your hard drive or an HTML page saved on your desktop. This essentially adds a new page to your website, with the content contained in the file.

When you publish the page with the link, Contribute copies the file into your website and then links to that copy—not to the actual file on your computer—to create the new page on your website.
Tip: If you want to replace an existing page on your website, with the contents of a file saved on your computer, see “Replacing a file on your website” on page 158.

You can use the Insert Link dialog box to insert a link to a file on your computer, or you can drag the file to your page (see “Inserting a link to a Word or Excel document” on page 72).

Note: If the file you want to link to is already saved on your web server—and not your computer—see “Linking to a page on your website or on another website” on page 131.

To create a link to a file on your computer using the Insert Link dialog box:

1. In your draft, do one of the following to indicate where you want the link to appear:
   - Place the insertion point in the draft.
   - Select text in the draft.
   - Select an image in the draft.

2. Do one of the following to open the Insert Link dialog box:
   - Click the Link button in the toolbar, and then select File on My Computer.
   - Select Insert > Link > File on My Computer.
   - Right-click (Windows) or Control-click (Macintosh), and then select Insert Link.

   The Insert Link dialog box appears.

3. Click the File on My Computer button (Windows) or File button (Macintosh) at the top of the dialog box, if it is not already selected.

4. Complete the dialog box.

   For information about options in the dialog box, click the Help button.
5. Click OK.

Contribute copies the file to create a new page on your website. A link to the new page appears in your draft.

**Note:** To edit content in the linked page after you publish, see “Editing web page content in an external application” on page 52. Changes you make to the original file do not appear on your website.

**Related topics**
- “Linking to a draft or a recently published page on your website” on page 128
- “Linking to a new page” on page 129
- “Linking to a page on your website or on another website” on page 131
- “Linking to an e-mail address” on page 132

**Linking to Breeze content, training, and meetings**

If you are a Macromedia Breeze customer, you can link to Breeze content, training, and meetings in a web page.

Breeze is a communication program comprised of three components: Macromedia Breeze Live, Breeze presentations, and Breeze Training. A fourth component, Breeze Manager, is a web application that is your access and control point for the other three components.

In Breeze Manager, content (which includes any files used in training, meetings, and so on), training, and meetings are organized in folders called libraries. Contribute provides an easy way for you to access and link to items in your Breeze Manager libraries.

**Note:** The content, training, and meetings that you can access depend on your Breeze configuration and your permissions.

**To link to Breeze content, training, and meetings:**

1. In your draft, place the insertion point where you want the link to appear.

   The link text Contribute inserts is the title of the content you link to. For example, if you link to a meeting named My Meeting, the link text in your draft is My Meeting. You can change the link text after you insert the link.

   **Note:** If you select text in your draft instead of placing the insertion point, Contribute changes that text to match the name of the content you link to. If you select an image in your draft, Contribute places the link text next to the image.
2. Select **Insert > Breeze Link.**

The Breeze Log In dialog box appears if this is the first time you're inserting a Breeze link since you started Contribute.

![Breeze Log In dialog box](image1)

3. If the Breeze Log In dialog box appears, enter your Breeze server URL and user information, and then click **OK.**

The Select Breeze Account dialog box appears if you have multiple Breeze accounts.

4. If the Select Breeze Account dialog box appears, select a Breeze account, and then click **OK.**

The Insert Breeze Link dialog box appears. This dialog box displays folders that contain the Breeze library items for the Breeze account you're connected to.

![Insert Breeze Link dialog box](image2)
5. (Optional) If you want to access another Breeze account, click the **Settings** button; enter information in the Macromedia Breeze Log In dialog box, and then click **OK**.

6. Find and select the item you want to link to, and then click **OK**.

   Contribute inserts a link to the item you selected.

   **To change link text to Breeze content:**
   - In your draft, select the link text, and then type over it.

### Setting the advanced linking options

The Insert Link dialog box has three advanced linking options: editing the link's URL, setting a target, and linking to a specific place on a page.

**Related topics**
- “Creating text and image links” on page 127
- “Editing links” on page 142

### Editing the URL for a link

If you are familiar with creating links in HTML, you can use Contribute to edit a link's URL.

When you link to a web page on a website, the link's URL appears in the Web Address (URL) text box and in the HREF text box in the Advanced section of the Insert Link dialog box. Use this HREF text box to alter the URL that Contribute places in the page's HTML.

**Note:** If the page is new, you'll see (new) appended to the end of the URL. Contribute removes (new) when you publish the new page.

The Web Address (URL) text box always shows the full URL, and the HREF text box shows the URL that's written in the page's HTML. The HREF might be a different, usually shorter, version of the URL.

**To edit a link's URL:**

1. In your draft, select an existing link.

   **Note:** To insert a link, see “Creating text and image links” on page 127.

2. Do one of the following to open the Insert Link dialog box:
   - Select **Format > Link Properties**.
   - Right-click (Windows) or Control-click (Macintosh), and then select **Link Properties**.

   The Insert Link dialog box appears.

3. Click the **Advanced** button (Windows) or the expander arrow (Macintosh) to expand the dialog box, if it is not already expanded.

4. Change the web address (URL) in the HREF text box.

   **Note:** You might notice that text in the Link text box changes as you enter text in this text box. It is the text in the HREF text box that Contribute places in the page's HTML for the URL.

5. Click **OK**.
Setting a target for your page

You can specify where a linked page opens by creating a target for the link. For example, you can have your linked document open in a new window instead of the current window.

If you create a link in a document with frames, you can indicate which frame, or target, displays the new content. For more information about creating targets for frames, see “Targeting frame content” on page 149.

Note: You cannot control where an e-mail link opens. When an e-mail link is clicked, the default e-mail application automatically starts.

You can specify the target when you create the link (see “Setting a target for a new link” on page 138), or you can edit an existing link to change or add the target (see “Setting a target for an existing link” on page 139).

Setting a target for a new link

You can specify the target for a link when you create the link.

To create a new link with a target:
1. In your draft, create a link (see “Creating text and image links” on page 127).
2. In the Insert Link dialog box, click the Advanced button (Windows) or the expander arrow (Macintosh) to expand the dialog box, if it is not already expanded.
3. Select a target from the pop-up menu:
   - Default opens the linked document in the current window. If the page contains frames, the linked page opens in the frame that contains the link.
   - Entire window opens the linked document in the current window. If the page contains frames, the linked page fills the entire window, not just the frame that contains the link.
   - New window opens the linked document in a new browser window, instead of the current window.
4. Click OK.

Contribute adds the link to your draft.
Setting a target for an existing link

You can edit an existing link to change or add the target.

To specify a target for an existing link:
1. In your draft, select an existing link.
2. Do one of the following to open the Insert Link dialog box:
   - Select Format > Link Properties.
   - Right-click (Windows) or Control-click (Macintosh), and then select Link Properties.
   The Insert Link dialog box appears.
3. Click the Advanced button (Windows) or the expander arrow (Macintosh) to expand the dialog box, if it is not already expanded.
4. Select a target from the pop-up menu:
   - Default opens the linked document in the current window. If the page contains frames, the linked page opens in the frame that contains the link.
   - Entire window opens the linked document in the current window. If the page contains frames, the linked page fills the entire window, not just the frame that contains the link.
   - New window opens the linked document in a new browser window, instead of the current window.
   
   *Note:* If the page you’re linking from was in a frame, a list of frame names appears here. if you choose a frame or type a frame name, the linked page appears in that frame when the website visitor clicks the link.
5. Click OK.
Contribute modifies the existing link with the target information.

Linking to a specific place in a page

You can place an invisible marker, called a section anchor, on your page to mark a specific topic or place. You can then create links to the anchor, which take website visitors to the specified position on the page with the anchor.

For example, you might add an anchor to the company address and phone number on the Company Information page. Then you might add a link with the text “Contact Us!” to your home page. When a website visitor clicks this link, the Company Information page opens to the address and phone number section. This way, the user does not need to search the Company Information page to find the contact information.

Adding a section anchor

You can add a section anchor to a page, and then link to that anchor from the same page or from another page. For more information about section anchors, see “Linking to a specific place in a page” on page 139.
To add an anchor to a page:

1. In your draft, place the insertion point at the beginning of the section where you want the page to open when a website visitor clicks the link.

2. Select Insert > Section Anchor.
   
The Section Anchor dialog box appears.

3. Enter a name for your anchor.
   
The name cannot begin with a number and cannot contain any spaces. You cannot have two anchors with the same name on a web page.

4. Click OK.
   
Contribute inserts an anchor marker in your draft.

Note: If you have invisible elements turned off, Contribute turns invisible elements on so that you can see the anchor marker. To turn invisible elements off again, select Edit > Preferences and then select Invisible Elements.

Related topics
• “Editing section anchors” on page 142

Linking to a section anchor

You can link to a section anchor when you create the link, or you can edit an existing link to indicate or change a section anchor. For more information on section anchors, see “Linking to a specific place in a page” on page 139.

To link to a section anchor:

1. In your draft, create a link (see “Creating text and image links” on page 127).

2. In the Insert Link dialog box, click the Advanced button (Windows) or the expander arrow (Macintosh) to expand the dialog box, if it is not already expanded.

3. Select a named anchor from the Section anchor pop-up menu.
   
Note: All anchors in the page you are linking to appear in the list.

4. Click OK.
   
Contribute adds the link to your draft.
To indicate an anchor for an existing link:

1. In your draft, select an existing link.

2. Do one of the following to open the Insert Link dialog box:
   - Select Format > Link Properties.
   - Right-click (Windows) or Control-click (Macintosh), and then select Link Properties.
     The Insert Link dialog box appears.

3. Click the Advanced button (Windows) or the expander arrow (Macintosh) to expand the dialog box, if it is not already expanded.

4. Select a named anchor from the Section anchor pop-up menu, or type an anchor name.
   All anchors in the page you are linking to appear in the list.

5. Click OK.
   Contribute modifies the existing link.

Related topics
- “Adding a section anchor” on page 139
- “Editing section anchors” on page 142
Editing section anchors

After you create a section anchor, you can change its name or delete it.

**Note:** If you edit a section anchor, links to that anchor will be broken until you fix the link on the page that links to the section anchor.

**To edit a section anchor name:**
1. In your draft, select the anchor, and then do one of the following:
   - Double-click the section anchor.
   - Right-click (Windows) or Control-click (Macintosh), and then select Anchor Properties from the pop-up menu.
   - Select **Format > Anchor Properties**.
   
   The Edit Section Anchor dialog box appears.

2. Change the anchor name.
   
   The name cannot begin with a number and cannot contain any spaces. You cannot have two anchors with the same name on a web page.

3. Click **OK**.

**To delete a section anchor:**
- In your draft, select the section anchor, and then press Delete.

**Related topics**
- “Adding a section anchor” on page 139
- “Linking to a section anchor” on page 140

Editing links

You can change the text or destination of a link, remove it, or change its properties.

**Changing link text and destination**

After you insert a link, you can later change link text or change the page that the link opens.

**To change link text:**
1. In your draft, select the link text you want to change.
2. Type new text.
To change link destination:
1. In your draft, select an existing link.
2. Do one of the following to open the Insert Link dialog box:
   ■ Select Format > Link Properties.
   ■ Right-click (Windows) or Control-click (Macintosh), and then select Link Properties.
   The Insert Link dialog box appears.
3. If you want to change the type of page you link to, click a button at the top of the dialog box; otherwise, skip this step.
4. Select or browse to a new page.
5. Click OK.

Related topics
• “Changing link properties” on page 143

Removing a link
After you insert a link, you can easily remove the link from your text or image.

To remove a link:
1. In your draft, select the link you want to remove.
2. Do one of the following:
   ■ Select Format > Remove Link.
   ■ Right-click (Windows) or Control-click (Macintosh), and then select Remove Link from the pop-up menu.
   The link text or image in the draft is no longer a link.

Related topics
• “Changing link text and destination” on page 142

Changing link properties
You can change link properties, including link text and destination and advanced link settings.

To change link properties:
1. In your draft, select an existing link.
2. Do one of the following to open the Insert Link dialog box:
   ■ Select Format > Link Properties.
   ■ Right-click (Windows) or Control-click (Macintosh), and then select Link Properties.
   The Insert Link dialog box appears.
3. Change any of the following link properties:
   - Link text
     Tip: You can also change link text by selecting the text in your draft and typing over it.
   - Linked file, web page, or e-mail
   - Web address
     For more information about the web address, see “Editing the URL for a link” on page 137.
   - Anchor
     For more information about anchors, see “Linking to a specific place in a page” on page 139.
   - Target
     For more information about setting a target, see “Setting a target for your page” on page 138.
4. Click OK.

Related topics
- “Changing link text and destination” on page 142
- “Removing a link” on page 143

Testing links
Contribute enables you to preview a temporary copy of a draft in a web browser so that you can test links and view content before you publish a draft.

Note: If you belong to a role that cannot publish, you cannot use the Preview in Browser feature to test links.

To test a link:
1. In your draft, select File > Preview in Browser.
   Your page appears in your default web browser.
2. Click the links to make sure they open the correct pages (or start your e-mail application).
3. Close the browser preview to return to the draft you’re editing.
Framesets divide a browser window into multiple frames or regions, each of which can display different content. You design pages with frames in an HTML design application, such as Macromedia Dreamweaver. You can edit pages with frames in Macromedia Contribute.

**Note:** For more information about creating pages with frames in Dreamweaver, see Dreamweaver Help (Help > Using Dreamweaver).

This chapter contains the following sections:

- “About frames” on page 145
- “Editing frame content” on page 147
- “Saving and publishing a page with frames” on page 148
- “Targeting frame content” on page 149

**About frames**

A web page designed with frames displays different content in different regions of a web browser. This design is typically used to display content that doesn’t change, such as a navigation bar, in one area and content that changes in the main content area.
For example, a web page might have one narrow frame on the left side that contains navigation links, one frame along the top that contains the logo and title of the website, and one large frame that takes up the rest of the page and displays the main content.

Related topics
- “Editing frame content” on page 147
- “Saving and publishing a page with frames” on page 148
- “Targeting frame content” on page 149

Understanding frames and framesets
A page that contains frames is called a frameset. A frameset is an individual file that defines the layout and properties of all the frames on a page, including the number of frames, the size and placement of the frames, and the web address (URL) of the page that initially appears in each frame.

A frame is an organizational element of a frameset page. It’s easy to think of the page that’s currently displayed in a frame as an integral part of the frame, but each frame is just a container for a page. Pages that initially load in the frames are referenced by the frameset, but any page can be loaded in a frame.

The content that appears in each frame is saved in separate files. A page with three frames—navigation, logo, and main content—actually has four files: the frameset and three web pages, one for each frame. When a website visitor clicks a link in one frame, a new page can be loaded in another frame. There can be a different page for each link in a frame.

A frame can load pages from the same or different websites. So you might be able to edit content in some, but not all, frames.

Related topics
- “Editing frame content” on page 147
About targeting a frame

To use a link in one frame to open a new page in another frame, you must set a target for the link. Selecting a frame in which to open a page is called targeting a frame.

Each link in a frameset should have a target—a frame in which to open the page when the user clicks the link. For example, the main frame might be the target for multiple links, so that the content of the main frame changes each time the user clicks a link in the navigation frame.

Note: If you don’t specify a target for a link, Contribute uses the Default option and opens the new page in the frame that contains the link.

When you add a link to a page in a frameset, you can indicate a target frame for the page you’re linking to. The frameset designer should have given each frame a name so that you can select specific frames as targets. You can also change the target after you’ve inserted the link by editing the link properties (see “Editing links” on page 142).

Related topics
• “Targeting frame content” on page 149

Editing frame content

When you browse to a page with frames, you can use Contribute to change content in any of the frames, as long as you have permission.

For more information about frames and framesets, see “About frames” on page 145.

To edit content in a frame:

1. Browse to the page with frames that you want to edit, and then click the Edit Page button.

   The Select a Frame to Edit dialog box appears, with a list of page titles and web addresses (URLs) for the frame pages.

2. Select the frame you want to edit.
When you select a frame, a border appears around that frame in the Contribute editor.

3. Click **Edit**.

A draft for the frame you selected appears in the Contribute editor without the other frames.

4. Edit the content as you normally would.

5. When you are ready to publish, see “Saving and publishing a page with frames” on page 148.

**Saving and publishing a page with frames**

A frameset is made up of individual web pages. When you edit a page that appears in a frame, you alter only the page you edit—not the frameset. Publishing a page that appears in a frameset is the same as publishing a page that isn’t in a frameset. Because you do not actually alter the frameset page, you do not need to publish it.

After you finish editing a frame page (see “Editing frame content” on page 147), you have the following options before you publish the page:

- Click **Cancel** in the toolbar (see “Canceling a draft or new page” on page 54).
  
  The individual frame in the frameset appears in Contribute without your changes. Click **Back** in the toolbar to return to the frameset page.

- Select **File > Preview in Browser** (see “Previewing a page in your default browser” on page 152).
  
  The individual frame showing your changes appears in a browser.

- Click **Send for Review** in the toolbar (see “Getting drafts and files reviewed by others” on page 42).
  
  Contribute sends the draft to another use for review.
To publish a page that appears in a frame:

- In your draft, click Publish (see “Publishing a page to your website” on page 152).

  **Note:** Depending on the role the Contribute administrator assigned you, you might not be able to publish.

  Contribute displays the frameset with the updated page loaded in the correct frame.

  **Note:** If you publish changes to a frameset that is nested (a frameset within a frameset), then the child nested frameset that you changed appears in Contribute. If there are multiple nested framesets, only the first frameset containing the edited page appears.

**Targeting frame content**

You can change the content that appears in a frame by creating links in one frame that open pages in another frame.

For more information, see “About targeting a frame” on page 147.

**To insert a link and select a target frame for the linked page:**

1. Browse to the page with frames that you want to edit, and then click the Edit Page button.
   
   The Select a Frame to Edit dialog box appears.

2. Select the frame in which you want to add a link that opens a new page in another frame, and then click Edit.
   
   A draft for the frame you selected appears in the Contribute editor.

3. Place the insertion point in your draft where you want the link to appear or select text or an image.

4. Do one of the following:

   - Select Insert > Link, and then select a type of page from the pop-up menu.
   - Click Link in the toolbar, and then select a type of page from the pop-up menu.

   The Insert Link dialog box appears.

5. Complete the dialog box.

   The options in the dialog box vary according to the type of page you are linking to.

   For more information on completing the dialog box, see “Creating text and image links” on page 127.

   For information about options in the dialog box, click the Help button.

6. In the Insert Link dialog box, click the Advanced button to expand the dialog box, if it is not already expanded.

7. In the Target frame pop-up menu, select the frame where you want the linked page to open.

   You can either enter a custom-named frame in the Target frame text box (which opens the page in that frame) or select one of the following frame targets:

   - **Default** opens the page in the same frame as the current page.
   - **Entire Window** replaces the frameset with the page.
   - **New Window** opens the page in a new browser window.
8. Click OK.
   The link appears in your draft.
   **Note:** If you created a link to a new page, the new page draft appears and you need to return to the
draft where you added the link.

9. Click Publish.
   The frame page appears, with updated content in the frame you edited.

**Related topics**
- “About targeting a frame” on page 147
Publishing a draft makes it *live* on your website, so your website visitors can view the page.

Before you publish your draft, you can preview it in your browser. You can also make the draft available to others for review, to get approval or feedback, before you publish the draft (see “Getting drafts and files reviewed by others” on page 42). If you decide not to publish your draft, you can cancel it, leaving the published version of the page as is.

If the draft you’re publishing was already on your website, Macromedia Contribute replaces the existing page with your updated version. You can also make updates to an existing page, and then publish it as a new page without altering the original page.

If the draft you’re publishing is a new page that was not on your website, Contribute adds it to your website. For new pages, Contribute asks you to name the file for the page before you publish.

After you publish a draft, if you realize that you need to *unpublish* it, don’t worry—you can undo publishing by reverting to a previous version of the page if your Contribute administrator has enabled the Page Rollback feature.

This chapter contains the following sections:

- “About the Rollback feature” on page 152
- “Previewing a page in your default browser” on page 152
- “Publishing a page to your website” on page 152
- “Publishing a file from your computer to your website” on page 157
- “Replacing a file on your website” on page 158
- “Rolling back to a previous version of a page” on page 160
About the Rollback feature

You can use the Rollback feature to revert to a previous version of any published page. You do not have to roll back to the last published version; you can select any version that Contribute has saved as a rollback file.

When you roll back to a previous version of a page, Contribute reverts to the previous text contained in the version of the page you select. However, any assets imported into the page may or may not be recovered. For example, suppose you update an image file outside of Contribute and then replace the original image with another image using the same filename. In this case, Contribute cannot roll back to the previous version of the image because Contribute does not manage assets outside the web pages it creates.

Contribute does, however, maintain the older version of an image if you use Contribute to edit the image in an external application. Contribute considers images, Microsoft Word documents, and other content that you edit in an external application as assets. You can roll back assets that you’ve edited through Contribute the same way that you roll back pages.

For example, suppose you roll back from version C of a page to version A, and you used Contribute to edit an image in version B. When you roll back to version A, you will not see the current version of the image. You need to also roll back the image, independently of the page rollback.

Related topics
• “Rolling back to a previous version of a page” on page 160

Previewing a page in your default browser

When you edit a draft in Contribute you can easily view your changes in a browser at any time, to ensure that your changes appear as you intend in the browser. Previewing your page also gives you an opportunity to test your links before you publish the page.

Tip: You can view the source code for a page when you preview it in the browser.

Note: If the Contribute administrator assigned you to a role that cannot publish, you cannot use the Preview in Browser feature.

To preview a page in your browser, do one of the following:
• Select File > Preview in Browser.
• Press the F12 key.

Publishing a page to your website

After you finish editing and reviewing a draft, you are ready to publish it to your website. When you publish a draft, Contribute makes it live on your website—and, if the page was previously published, Contribute replaces the existing page with the updated page.

Note: Depending on the role the Contribute administrator assigned you, you might not be able to publish.
You can publish any of the following types of pages to your website:

- Updates to an existing page
- New page, not previously published
- Existing page as a new page

Publishing updates to an existing page

When you publish updates to an existing page, Contribute replaces the currently published version of the page on your website with the new version.

When Contribute publishes your draft, it also publishes any new pages that your draft links to (but not pages that link to your draft). Contribute prompts you to name any linked pages that haven't been published before. Publishing all new pages that are linked from the draft helps ensure that you do not have broken links in your website.

**Note:** If you need to replace an existing page on your website with a page that has the same filename, delete the existing page on your website (see "Deleting a web page" on page 55) and then publish the replacement page. If you do not have permission to delete pages, contact your Contribute administrator.

To publish updates to an existing page:

1. In your draft, click the Publish button in the toolbar.

   **Note:** Depending on the role the Contribute administrator assigned you, you might not be able to publish.

   If the draft contains links to any new pages, the Publish New Linked Pages dialog box appears.

2. If the Publish New Linked Pages dialog box appears, for each unpublished linked page, click the page name to select it, change the filename and folder location if you want, and then click Publish All.

   For information about options in the dialog box, click the Help button.

   Contribute publishes the draft (and any new pages it links to) to your website, and then displays it in the Contribute browser.
Publishing a new page

When you publish a new page to your website, Contribute asks you to name the file for the page and any other new pages the page links to. Then Contribute publishes the new page, and any pages that the new page links to, on your website. Publishing all pages that are linked from the new page helps ensure that you do not have broken links on your website.

If you haven’t added a link on an existing page to your new page, website visitors won’t be able to view the page. Remember to go to an existing web page before (or just after) you publish a new page, and add a link to the new page (see “Linking to a draft or a recently published page on your website” on page 128).

Tip: You can create a link to the page at the same time that you create the page. For more information, see "Linking to a new page” on page 129.

To publish a new page:

1. In the new page draft you’re editing, click the Publish button in the toolbar.

   ![Publish](Image)

   Note: Depending on the role the Contribute administrator assigned you, you might not be able to publish.

   The Publish New Page dialog box appears.

2. You can change the filename, and then click the Choose Folder button if you want to save this draft in another location on your website.

   For information about options in the dialog box, click the Help button.

   Note: Contribute automatically saves the file with the same name as the page title.

3. Click Publish or Next.

   Note: Contribute warns you if you have not linked the new page draft from an existing page. After you publish the new page, be sure to create a link to it (see "Linking to a draft or a recently published page on your website” on page 126).
If your new page draft links to any other new pages, the Publish New Linked Pages dialog box appears.

4. If the Publish New Linked Pages dialog box appears, for each unpublished linked page click the page name to select it, change the filename and folder location if you want, and then click Publish All.

For information about options in the dialog box, click the Help button.

Contribute publishes the new page to your website and displays it in the Contribute browser.

**Publishing an existing page as a new page**

Contribute enables you to update an existing page and then publish it as a new page without overwriting the original page. This feature is similar to the Save as feature in other applications.

For example, suppose you open the product page for men’s cargo pants and start updating the page with information about women’s cargo pants. Then you realize that you forgot to make a copy of the existing page before you made edits. As long as you don’t click Publish, the original page is unchanged. Use the Publish as New Page feature to publish the modified page as a new page on your website.

This is possible because when you click Edit Page for an existing page, Contribute creates a copy of the page (known as a draft) for you to edit. Saving changes to the draft does not alter the page on your website.

**To publish an existing page as a new page:**

1. Browse to an existing page, and then click the **Edit Page** button.
2. Make changes to the draft.
3. Select **File > Actions > Publish as New Page**.

*Note:* Depending on the role the Contribute administrator assigned you, you might not be able to publish.
Contribute warns you if you have not linked the new page from an existing page. After you publish the new page, be sure to create a link to it (see “Linking to a draft or a recently published page on your website” on page 128).

The Publish as New Page dialog box appears.

4. You can change the page title and filename for the draft, and then click the **Choose Folder** button beside the filename if you want to save this draft in another location on your website.

   **Note:** Contribute automatically saves the file with the same name as the page title.

   For information about options in the dialog box, click the Help button.

5. Click **Publish** or **Next**.

   If your new page draft links to any other new pages, the Publish New Linked Pages dialog box appears.

6. If the Publish New Linked Pages box appears, for each unpublished linked page click the page name to select it, change the filename and folder location if you want, and then click **Publish All**.

   For information about options in the dialog box, click the Help button.

   Contribute publishes the draft to your website and then displays it in the Contribute browser.
Publishing a file from your computer to your website

You can add a document or file (except HTML pages) directly to your website from your computer.

You can also add documents or files, including HTML pages, to your website by linking to them from a draft. For more information, see "Linking to a file on your computer" on page 133.

**Note:** Depending on the role the Contribute administrator assigned you, you might not be able to add files to your website.

**Tip:** If you want to replace an existing page on your website with the contents of a file that’s saved on your computer, see "Replacing a file on your website" on page 158.

To publish a file from your computer to your website:

1. Select **File > Publish File from My Computer**.
   
   **Tip:** If you want to have the file reviewed before you publish it, or if you can’t publish to the website, then select **File > Send File from My Computer** to send the file for review. For more information, see "Sending a file for review from your computer" on page 44.

   The Select File dialog box appears.

2. Select the file you want to add to the website, and then click **Select**.

   **Note:** You cannot select HTML, executable, or template files. If you select an invalid file type, Contribute warns that you cannot select this file and provides a complete list of invalid file types.

   If you have connections to more than one website, the Select Website dialog box appears.

3. If the Select Website dialog box appears, select the website where you want to add the file from your computer.

   The website list includes any website you are connected to and have permission to publish to.

   The Publish New Page dialog box appears.

4. Change the filename, if you want, and then click the **Choose Folder** button if you want to save this draft in another location on your website.

   **Tip:** If you want to replace an existing file on your website with the file you are publishing, then change the name of the file to match the name of the existing file and make sure you choose the folder that contains the file you want to replace.
5. Click **Publish**.

If the draft has the same name as an existing file on your website, the Replace File dialog box appears.

![Replace File dialog box](image)

6. If the Replace File dialog box appears, select to either replace the existing file with the one you are trying to publish or leave the existing file on the website and publish the new file with a similar filename, and then click **OK**.

The file is added to your website. Remember the web address (URL) for the page or go ahead and link the new page from another page, so that you can easily get back to it.

**Tip:** Use Contribute to edit this file after you publish. Changes you make to the original file on your computer after publishing do not appear on your website.

**Related topics**

- “Adding Microsoft Word and Excel documents to a website” on page 71

### Replacing a file on your website

You can replace a file on your website with a file on your computer.

For example, suppose you post the quarterly earnings spreadsheet on your website each quarter. You can easily replace the current live version with the new spreadsheet saved on your computer.

There are two ways to replace a file:

- Publish the file directly from your computer.
- Link to the file from a draft.

**To replace an existing file on your website by publishing another file directly from your computer:**

1. Select **File > Publish File from My Computer**.

   The Select File dialog box appears.

2. Select the file you want to add to the website, and then click **Select File**.

   **Note:** You cannot select HTML, executable, or template files. If you select an invalid file type, Contribute warns that you cannot select this file and provides a complete list of invalid file types.

   If you have connections to more than one website, the Select Website dialog box appears.
3. If the Select Website dialog box appears, select the website that contains the current version of the file you are replacing, and then click OK.

The Publish New Page dialog box appears.

4. Change the filename, if necessary, to make sure it matches the name of the file you’re replacing; also, make sure you choose the folder that contains the file you want to replace.

5. Click Publish.

The Replace File dialog box appears.

6. Select the Replace the existing file option, and then click OK.

Contribute replaces the existing file on your website with the file from your computer.

Tip: Use Contribute to edit this file after you publish. Changes you make to the original file on your computer after publishing do not appear on your website.

To replace a file on your website by linking to a file on your computer:
1. Browse to the page that contains the link to the file you want to replace, and then click the Edit Page button.

2. In the draft, select the link to the file you’re replacing, and then click the Link button in the toolbar and select File on My Computer.

The Insert Link dialog box appears. The File on My Computer button should be selected at the top of the dialog box.
3. Click the **Browse** button, and then navigate to and select the file on your computer you want to link to.

   **Note:** You cannot select HTML, executable, or template files. If you select an invalid file type, Contribute warns that you cannot select this file and provides a complete list of invalid file types.

   The filename for the new file must exactly match the filename for the file you are replacing. If the names do not match, Contribute does not replace the file.

4. Click **OK** to close the Insert Link dialog box.

5. In your draft, click the **Publish** button.

   The Replace File dialog box appears.

6. Select the **Replace the file** option, and then click **OK**.

   Contribute publishes the file from your computer and updates the link in the draft to replace the old file with the new file from your computer.

   **Tip:** Use Contribute to edit this file after you publish. Changes you make to the original file on your computer after publishing do not appear on your website.

---

**Rolling back to a previous version of a page**

To provide an extra degree of safety in publishing, Contribute enables you to **undo** any page you publish and roll back to a previously published version of that web page.

For more information about rollbacks, see "About the Rollback feature" on page 152.

**Note:** The Rollback feature is only available if your Contribute administrator enabled it. For more information, see your Contribute administrator or see "Enabling and disabling rollbacks" on page 221.
To roll back to a previous version of a page or asset:
1. Browse to the page that you want to roll back.
2. Select **File > Actions > Roll Back to Previous Version**.
   The Roll Back Page dialog box appears.

3. Select a previous version of the published page from the list of available pages.
   *Note:* The list of previously published pages shows a number of previous versions of the page, depending on your Contribute administrator's setting.

   Contribute displays the page in the **Preview** section.

4. If the page you selected is the one you want to publish, click the **Roll Back** button. If the page is not the one you want to publish, select another page from the list, and then click **Roll Back**.
   Contribute replaces the currently published version of the page with the previously published version that you selected. The version you selected becomes the current version on the website.

   *Note:* The page you replace with the selected rollback page appears in the Roll Back Page dialog box the next time you open the dialog box so you can roll back to that version if you need to.
Learn how to configure Contribute to work with your organization’s websites, create and distribute site connections for users, help contributors get started using Contribute, and manage the website’s settings and user permissions.

This part contains the following chapters:

Chapter 12: Learning to Administer Contribute .................................................. 165
Chapter 13: Deploying Contribute to Departments and Enterprises ........ 169
Chapter 14: Creating and Managing Website Connections .................. 207
Chapter 15: Managing Users and Roles ......................................................... 239
Chapter 16: Troubleshooting ................................................................. 259
CHAPTER 12
Learning to Administer Contribute

Macromedia Contribute lets content contributors create new web pages, edit existing pages, and publish content without having to learn complicated authoring tools or HTML coding.

This chapter describes how to configure Contribute to work with your organization’s websites and how to help contributors to your websites get started using Contribute.

This chapter contains the following sections:
• “Intended audience” on page 165
• “Typographical conventions” on page 166
• “Learning to administer Macromedia Contribute” on page 166

Intended audience

This information is intended for:
• Information technology (IT) staff responsible for maintaining your organization’s website and web servers
• Independent users who want to use Contribute to manage their personal websites
• Web professionals responsible for maintaining website content and appearance

If you will be responsible for deploying and administrating Contribute for your organization, you should be familiar with the setup and administration of websites and web servers, user permissions on the server hosting your website, and web page markup languages such as HTML and Cascading Style Sheets (CSS). This information is also intended for Macromedia Dreamweaver users who are responsible for overseeing the design and implementation of the website. Using Dreamweaver, these users can manage Contribute websites and create web page templates for use by Contribute users.
Typographical conventions

The following typographical conventions are used in this guide:

- Menu commands are shown in this format: Menu name > Menu command. Commands in submenus are shown in this format: Menu name > Submenu name > Menu command.
- **Code font** indicates HTML tag and attribute names as well as literal text used in examples.
- *Italic code font* indicates replaceable items (sometimes called *metasymbols*) in code.
- **Bold roman text** indicates menu selections, option names, button and icon names, and text for you to enter verbatim.

Learning to administer Macromedia Contribute

Contribute includes a variety of media resources to help you learn the program quickly. These resources include an online help system, a tutorial, a printed Quick Start guide, and the How Do I reference panel.

As an administrator, you have resources available to learn about Contribute. These resources are described in the following sections:

- “About the Contribute Quick Start guide” on page 166
- “About the Contribute How Do I panel” on page 166
- “About the Contribute tutorial” on page 167
- “About Contribute Help” on page 167
- “About the Contribute Support Center” on page 168

About the Contribute Quick Start guide

The Contribute Quick Start guide helps you get started with Contribute. The guide provides instructions on installing Contribute, connecting to your website, and completing common Contribute tasks. Use this guide to learn the basics.

The Quick Start is a printed guide included with Contribute. You can also select **Help > Quick Start Guide** to access the guide.

About the Contribute How Do I panel

The Contribute How Do I panel in the sidebar provides quick step-by-step instructions on completing some common Contribute tasks. If you don't find a task in the How Do I panel or need more information about a task, use Contribute Help to get more detailed information.
About the Contribute tutorial

The Contribute tutorial guides you through representative Contribute tasks, step by step. As you complete the tutorial, you’ll update the web pages of a sample website and quickly become familiar with Contribute features.

A link to information about the tutorial appears on the Start page when you first start Contribute. The tutorial is available in the How Do I panel in the sidebar. Click the Contribute Tutorial link to start the tutorial.

When you install Contribute, the sample website for the tutorial is copied to your computer at c:\documents and settings\yourname\Application Data\Macromedia\Contribute\Content\Tutorial.

About Contribute Help

Contribute Help provides comprehensive information about all Contribute features, optimized for online reading. Contribute Help appears in the help viewer provided by your operating system: Microsoft HTML Help (Windows) or Help Viewer (Macintosh).

The online help system has two sections: Using Contribute, for Contribute users, and Administering Contribute, for Contribute administrators.

To use Contribute Help:

1. Select Help > Macromedia Contribute Help, or click the Help button in any dialog box for information specific to that dialog box.

2. Use any of the following features to find information in the help system:

   ■ Use the table of contents to see all the information organized by subject. Click top-level entries to view subtopics.

   ■ Use the index to look up specific terms or concepts. It is organized the same as a traditional book index.

   ■ Use the search feature to find instances of a term or topic. Type any character string in the Search text box to find that text anywhere in the help system.

   ■ Use the Previous and Next arrows to move through the topics in a section.

About Contribute Publishing Server Help

Contribute Publishing Server (CPS) Help provides information for using CPS and configuring the CPS services. CPS Help is available through the CPS Console. Click any Help link in the console to access Help.

About the Deploying Contribute Publishing Server PDF

Deploying Contribute Publishing Server provides complete information for installing CPS and for accessing the CPS Console to enable and configure the services. It is available on the Contribute documentation website at www.macromedia.com/go/contribute_docs_en.
About the Contribute Support Center

The Contribute Support Center website at www.macromedia.com/support/contribute is updated regularly with the latest information on Contribute, plus examples, tips, TechNotes, and other updates.
Macromedia Contribute is a website editor that lets people connect to departmental and other websites so that they can update web page content. Administrative assistants, product managers, human resource managers, and other people in an organization can use Contribute to update their workgroup's web pages without having to contact a web team or other departmental resources.

The following examples show how Contribute might be used in an organization:

- Updating schedules
- Posting job requisitions
- Updating an employer’s work-related policies and guidelines
- Editing organizational charts
- Sharing information among team members through a departmental intranet

This chapter, which is intended for website administrators and IT professionals, describes the best practices for deploying Contribute within an organization. It explains how to set up Contribute in a variety of IT environments so that content editors and website administrators can enjoy the power and flexibility of this application.

This chapter contains the following sections:

- “Contribute deployment responsibilities” on page 170
- “Deployment tasks” on page 171
- “Deployment issues” on page 172
- “User management models” on page 185
- “Contribute user roles” on page 185
- “Contribute and website security” on page 187
- “Website connection distribution” on page 190
- “Deploying Contribute across an organization” on page 190
- “The draft review process and site structure” on page 191
- “Content design considerations” on page 193
- “Contribute Publishing Server” on page 198
Contribute deployment responsibilities

As a system or website administrator, you play a large part in deploying Contribute. The deployment responsibilities include the following tasks:

- Installing the Contribute software.
- Creating connections to websites that users of Contribute (called content editors) access.
- Defining roles (a collection of privileges that you assign to a specific user or group of users). Roles determine which users have, or are denied, access to a specific website.
- Installing Contribute on individual computers throughout your organization.
- (Optional) Integrating Contribute with Contribute Publishing Server (CPS).

The size of your organization and the job roles associated with your organization's websites determine who assumes responsibility for deployment. A single system administrator may be responsible for all deployment, or other members of the organization's web team or IT staff may be involved. Administrators manage Contribute websites by controlling who has access to the site and by specifying what kinds of changes content editors can make to a site.

Administrators, web masters, and web designers

If you are a system administrator, this might be your first time to work with web pages and web content. Your role as a system administrator may intersect with the role of web designer. A web designer can help you determine the editing and access requirements of your site and help you construct the site so that users with limited web-design skills can easily update content.

Contribute gives you a great deal of power and flexibility in determining who can edit web pages on a website and what types of changes they can make. For example, you might decide that all Contribute users, with the exception of the web-design staff, are limited to editing text on web pages, and that the web-design staff can edit text, apply new text styles (for example, change the type font), and insert new images.

Contribute job functions

The following table describes the function of each role that relates to Contribute:

<table>
<thead>
<tr>
<th>Role</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Contribute administrator</td>
<td>Responsible for installing Contribute, setting up user roles and privileges, and determining the degree to which users can access and update websites. Contribute administrators are often members of an organization’s IT staff, responsible for maintaining server and network infrastructure, managing user and file permissions across an organization’s network.</td>
</tr>
<tr>
<td>System administrator</td>
<td>Maintains web servers and web server access. This role often overlaps with that of the Contribute administrator and may be handled by the same person in smaller organizations.</td>
</tr>
</tbody>
</table>
These roles vary from organization to organization. In smaller organizations and workgroups, a single person may handle the job of administering Contribute and determining the design of the website. Larger workgroups and departments may have a team of people involved in maintaining their website.

Deployment tasks

The following table describes the tasks you need to perform to successfully deploy Contribute.

<table>
<thead>
<tr>
<th>Task</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Gather website information</td>
<td>Gather information about your website’s infrastructure. You’ll need this information to properly install and configure Contribute. For more information, see “Information about your website” on page 172.</td>
</tr>
<tr>
<td>Configure network and server permissions</td>
<td>Ensure that the network and server permissions allow read, write, and modify access so that Contribute users can connect to the site and update pages. For more information, see “Understanding network and server permissions” on page 173.</td>
</tr>
<tr>
<td>Install Contribute</td>
<td>Install Contribute on the computer from which you’ll administer the site, create a connection to the website using Contribute, and establish yourself as the Contribute administrator for the site. To learn more about creating an administrative connection, see “Contribute administrative connections” on page 173.</td>
</tr>
<tr>
<td>Install Contribute Publishing Server (CPS) (optional)</td>
<td>CPS is a suite of Java server applications that lets you integrate Contribute with Lightweight Directory Access Protocol (LDAP) or Active Directory services, and implement e-mail notifications to keep Contribute users informed about the status of their drafts in progress. If you want to use CPS, you must install and configure the Publishing Service server on a Java application server. For more information, see “Contribute Publishing Server” on page 198.</td>
</tr>
<tr>
<td>Configure Contribute to work with your website</td>
<td>After you establish yourself as an administrator of a site, you can configure the administrative settings so that Contribute works more efficiently with your website. For more information, see “About Contribute administrative settings” on page 174.</td>
</tr>
</tbody>
</table>
In addition to the basic tasks described in the preceding table, you might want to further enhance your website by designing it to be more easily maintainable or by adding additional functionality by using CPS.

Deployment issues

The following sections describe issues you should be aware of when deploying Contribute in your organization. As with all client software that provides access to centralized servers on a network, Contribute requires that certain network and server file permissions be appropriately configured for users. Before installing Contribute and deploying it to users, ensure that you have considered the following issues and have appropriately configured your website environment for use with Contribute.

This section covers the following topics:

• “Information about your website” on page 172
• “Understanding network and server permissions” on page 173
• “Contribute administrative connections” on page 173
• “About Contribute administrative settings” on page 174
• “Contribute site structure” on page 175
• “Understanding overlapping website connections” on page 177
• “Contribute network connection types” on page 180
• “Contribute and directory services” on page 183

Information about your website

Before you install Contribute, you must gather information about your organization's website infrastructure. You need to find the answers to the following questions:

• Where is the server on the network?
• Who can access the server?
• Do new users and permissions need to be created on the server?
• What type of network connection will you use to connect to the website?
• If you are using File Transfer Protocol (FTP) or Secure FTP (SFTP) to connect to the website, what FTP software is being used?
• What web server software is in use, and where is the website’s root folder?
• What is the URL of the website?

Although these questions may seem obvious, it’s good to think about them before you create a connection to your website with Contribute. The sections below will help to provide you with background information on these questions, and how they relate to installing and configuring Contribute.

Understanding network and server permissions

Contribute is unique in that it allows editing of web pages directly on the server hosting your website. This level of server access makes network permissions and access control especially important.

There are at least three levels of permissions for every Contribute site:
• Permissions defined by the network operating system (for instance, Windows or UNIX server software)
• Permissions defined by the web server software
• Roles you define within Contribute

Network permissions can be set in several ways through a variety of systems. Contribute always adheres to the network permissions for read and write access to folders. It also obeys permissions set through LDAP and similar systems. Contribute can never overwrite any server- or network-level permissions.

Note: The server’s network and operating system permissions, and the web server software’s permissions, always take precedence over Contribute permissions.

Whenever you provide access to a web server, you should take precautions to ensure that the operating system of the server hosting the site, as well as the web server software itself (and the FTP server, if you are using FTP), are secure. For the best practices related to securing your website from accidental and malicious tampering, see the documentation provided with your server’s operating system, FTP, and web server software.

Note: You can set folder permissions to allow a user or group of users to modify a folder and later define more restrictive folder- or file-editing options when you define the Contribute user roles.

Related topics:
• “Contribute user roles” on page 185
• “Contribute and website security” on page 187

Contribute administrative connections

After you gather information about your website infrastructure and configure the network and server permissions for appropriate read, write, and modify permissions, you must install a copy of Contribute and create a Contribute administrator connection to the website.

As an administrator, you are responsible for configuring Contribute administrative settings, identifying users, defining user roles, installing Contribute on each user’s computer, and distributing connection information so that users can connect to the website.
When you set up the Contribute administrator user role, consider whether you will be the only administrator of the website. If more than one person will be administering the site, you might need to create a group e-mail account that notifies all administrators when a user encounters a problem.

To learn more about creating a connection, see “Creating and Managing Website Connections” on page 207.

About Contribute administrative settings

Contribute administrative settings are a collection of settings that apply to all users of your website. These settings let you fine-tune Contribute to provide a better user experience. The Contribute administrative settings are as follows:

**Users and Roles** lets you add users to the site, and create, edit, and delete roles.

**Administration** lets you specify a primary administrator for the site, set an administrator password, and remove administration.

**Tip:** Contribute does not require that you set an administrator password; however, you should create a password to protect access to the administrative functions. If you fail to assign an administrator or an administrative password, anyone with a Contribute connection to the site can make themselves an administrator of that site.

**Publishing Server** lets you enable your website connection to use CPS—a suite of applications running on a server that lets you extend the capabilities of Contribute, as well as provide additional functionality for users.

**Note:** If you will be using the CPS User Directory service, you should enable CPS and the User Directory service before adding users to the site. When you start the User Directory service, any users who have connected to the site are removed, and any connection keys you might have sent to users become disabled. To learn more about CPS, see “User management models” on page 185 and “Contribute Publishing Server” on page 198.

**Web Server** lets you configure Contribute to work with your website’s specific web server configuration. Because all websites vary somewhat in how they are set up, the configuration options in the Web Server dialog box let you specify settings specific to your website, which Contribute might not be able to determine automatically.

To learn more about the web server configuration settings you can specify, see “Web server index pages” on page 208 and “Alternate website addresses” on page 209.

**Rollbacks** lets you enable rollback files and specify the number of rollback files to maintain on the server.

To learn more about rollbacks, see “Enabling and disabling rollbacks” on page 221.

**New pages** lets you specify the encoding used for characters in web pages and the default page extension (.htm, .html, and so on) to use when creating new pages.
By default, the character encoding for new pages is set to Western, which applies to all English and Western European languages. The default encoding is set from your computer operating system’s default encoding. Additional options include Central European, Cyrillic, Greek, Icelandic, Japanese, Traditional Chinese, Simplified Chinese, and Korean. If you want to create pages that display characters for multiple languages, select UTF-8.

To learn more about preference settings for new pages, see “Specifying new page preferences” on page 221.

Related topics
• “Configuring Contribute administration settings” on page 218

Contribute site structure

The connection you create to a website with Contribute determines the network protocol to use when accessing the site, the web address (URL) of the site, and the degree to which the site’s structure is accessible to content contributors. Before creating a connection to a website, carefully consider how users will access the site and what areas of the site they will need to access.

Network paths and web addresses (URLs)

When creating a connection to the website, Contribute prompts you to provide the web address (URL) of the website, and the network connection information of the server and folder storing the website. Both the web address and network path must point to the same folder in the website.

For example, suppose your website is located at the directory path:
\MyServer\wwwroot\sites\MySite

And the corresponding web address for this site is:

When creating the connection, you must enter these values correctly, so they point to the same folder.

To ensure that the website and network folder (or in the case of FTP and SFTP, the FTP folder) are the same, Contribute uploads a temporary file using the path information you provide. Contribute then attempts to read the temporary file through HTTP, using the web address you provide. If Contribute succeeds in locating the temporary file, the paths match, and Contribute creates the connection. If the paths don’t match, Contribute prompts you again for the correct path.

**Note:** If your users will use FTP to connect to a website folder beneath the FTP Host folder, you must provide an absolute path to the folder.

Contribute connection paths

A Contribute website is defined when you create an administrative connection and select the website folder to connect to. All folders from the folder you connect to and below make up the the Contribute site.
As the administrator, you can establish a connection to the root folder in a website if you need access to all the folders in that site. Or, you can establish a connection to a lower-level folder, depending on the access you and your users require.

Tip: Macromedia recommends that you create a connection at the root of your website (www.mysite.com/intranet/, for example), and use the Contribute Permissions settings to limit user access to specific folders in the site.

As an alternative to creating one website connection for all your users, you can create separate connections for different parts of the website. For example:

connection1: www.mysite.com/intranet/marketing
connection2: www.mysite.com/intranet/finance

It is also possible to create overlapping connection paths. This occurs when you create a website connection to a folder, and then create another website connection at a lower level, to a folder that is contained in the first website connection. For example:

connection1: www.mysite.com/intranet/
connection2: www.mysite.com/intranet/marketing

In this case, the connection paths overlap, and the second connection is a child website of the first connection, which is the parent website.

Tip: Macromedia recommends that, if you create child sites, you make any users who are connected to a parent site, also connect to any child sites.

When you create website connections to different parts of your website, it is important to remember that each website connection represents a Contribute website. So your entire website can consist of multiple websites (as many websites as connections you create). Users who connect to each website are limited to editing pages and sending drafts for review within their website.

This is a valid way to set up connections in Contribute. It just requires careful consideration. For more information, see “Understanding overlapping website connections” on page 177.

Contribute administrative files and folders

Contribute creates a special administrative folder (labeled _mm) that contains a shared settings file in each website you create a connection to. The shared settings file contains information about all users roles site-wide permissions you define. Storing this information on the server enables you to make changes to Contribute role and site-wide permissions, without having to resend connections to users. The changes are automatically applied when the user connects to the site.

If you are creating multiple site connections for various sets of users, make sure you consider the connections carefully (see “Understanding overlapping website connections” on page 177). As the administrator, you should create your connection at the highest level of access pertinent to the website; you can define connections and user roles to allow users’ access at lower levels of the site, depending on their specific access requirements.

To learn how to secure the administrative folder and the shared settings file it contains, see “Restricting access to administrative folders” on page 188.
Understanding overlapping website connections

An overlapping website connection occurs when you create a website connection to a folder in your website and then create another website connection to a folder that is contained in the original website connection. For example:

connection1: www.mysite.com/intranet/
connection2: www.mysite.com/intranet/marketing

The first connection, at the higher level, is the parent website, and the second connection, at the lower level, is the child website.

Child websites do not inherit from the parent website. This includes administrative settings, roles, templates, and other assets. Each website connection is its own distinct website and is not related to any other website connections you create.

When you have website connections that overlap, the most nested website that contains the page a user is editing or viewing takes priority for administrative settings and roles, the draft review process, and templates and other assets.

For example, consider the marketing website (www.mysite.com/intranet/marketing), which is a child of the intranet website (www.mysite.com/intranet/). When a user edits a page in the marketing website, the settings and roles for that connection apply, the user can send only a draft for review to other users who are connected to that website, and the user has access to template and shared assets for that website only.

**Tip:** Macromedia recommends that, if you create overlapping website connections, you make any users who are connected to a parent site, also connect to any child sites.

This section covers the following topics:

- "Understanding Administrative settings and roles in overlapping websites" on page 177
- "Understanding the draft for review process in overlapping websites" on page 178
- "Understanding templates, shared assets, and images in overlapping websites" on page 179

Understanding Administrative settings and roles in overlapping websites

Contribute creates a special administrative folder (labeled _mm) that contains a shared settings file in each website you create a connection to. The shared settings file contains information about each role you define, including the administrator role and any site-wide permissions you define.

When you establish overlapping website connections, you might have users who have multiple connections to different parts of your entire website. When those users edit a page, the settings file for the most nested website connection applies for the page and the user.
For example, consider a user with the following connections:

connection1: www.mysite.com/intranet/
connection2: www.mysite.com/intranet/marketing

A page in the marketing folder, marketinganalysis.htm for example, is technically part of both websites that user is connected to. But because these are two separate connections—and therefore two separate websites—there are two different administrative folders. When the user edits the marketinganalysis.htm file, the roles and settings for the most nested website connection applies; in this example, www.mysite.com/intranet/marketing.

Now suppose the same user edits a file in the intranet/marketing/contacts folder, and the user does not have a website connection to that folder. The user can still edit pages in that folder because it is part of the marketing website, but the user does not have a separate connection to that folder, so it is not a separate website. Again, the settings for www.mysite.com/intranet/marketing apply because that is the deepest website connection in the path to the page the user is editing.

Understanding the draft for review process in overlapping websites

When you send drafts for review, your list of possible reviewers are users who are connected to your website. And the draft you send for review is temporarily placed in the root of your website (that is, the root of your Contribute website connection).

**Tip:** To avoid potential problems with the draft review process, users who are connected to websites that have child websites, should also connect to all the child websites.

When you have overlapping sites, depending on your website connections, the draft review process might not work as you expect:

- You might not be able to send to users you expect to send to.

For example, consider the following website connections:

User 1’s connection: www.mysite.com/intranet/
User 2’s connection: www.mysite.com/intranet/marketing

If User 1 edits a page in the marketing folder and then clicks the Send for review button, the list of possible reviewers will be users connected to the same website as User 1 (www.mysite.com/intranet/). In this case, User 1 could not send to User 2, who belongs to the marketing website.

Now suppose that User 1 has website connections to both websites (www.mysite.com/intranet/ and www.mysite.com/intranet/marketing) and User 2 has a connection to the marketing website only (www.mysite.com/intranet/marketing). If User 1 edits a page in the marketing folder, and then clicks Send for review, the list of possible reviewers will be users connected to the User 1’s most nested website, www.mysite.com/intranet/marketing. In this case, User 1 could send the draft to User 2.
• Reviewers might not receive drafts.
Consider the same website connections from the previous example:

User 1’s connection: www.mysite.com/intranet/
User 2’s connection: www.mysite.com/intranet/marketing

If User 1 edits a page in the marketing folder and then clicks the Send for review button, the list of possible reviewers will be users connected to the same website as User 1 (www.mysite.com/intranet/).

If both websites have a group with the same name, Writer, then User 1 might send to the Writer group for www.mysite.com/intranet/ but think that he's sending the draft to the Writer group for the marketing website. In this case, the marketing Writer group would not receive the draft from User 1.

• Reviewers might not be able to take action on a draft.
Now, consider the following website connections:

User 1’s connection: www.mysite.com/intranet/
User 2’s connections: www.mysite.com/intranet/ and www.mysite.com/intranet/marketing

Suppose User 1 edits a page in the marketing folder and sends it to User 2 for review. The draft for review is temporarily placed on the website at the root of User 1’s website connection (www.mysite.com/intranet/). (Remember, User 1 does not have a website connection to the marketing website.) When User 2 receives the draft, there is a conflict because User 2 has website connections to the site where the draft for review was placed and also to the website that contains the original page.

In this case, Contribute has a conflict on how to handle the draft for review, because it expects the draft for review to be in the same folder as the original page. Because of this conflict, User 2 can send the draft for review or delete the draft only. User 2 cannot edit or publish the draft for review.

Understanding templates, shared assets, and images in overlapping websites

Templates in Contribute reside in a folder named Templates in the root folder of each website connection (for example, /Templates/contactPage.dwt). Shared assets and images are also stored separately for each website and are available to users depending on the role the website administrator assigned to them for that website.

When you have overlapping website connections within your website, you might have users who have multiple connections to different parts of your website. When those users edit a page, they have access to the templates and shared assets for the most nested website connection for the page and the user.

You must carefully consider where you place your templates, shared assets, and images. For example, if you place the company logo in the root of the intranet website (www.mysite.com/intranet/), users who have connections to the marketing website only (www.mysite.com/intranet/marketing) won’t have access to the logo.
Contribute network connection types

Contribute lets you connect to websites using one of several network connection types. The connection type you choose depends upon the infrastructure of your website. For example, if you are deploying Contribute to update a workgroup’s intranet site, you can, in most instances, use a local area network connection. However, if the site is hosted through an ISP or other external resource, you might need to use either an FTP, SFTP, or WebDAV connection.

This section covers the following topics:

- “Local area networks” on page 180
- “File transfer protocol (FTP)” on page 180
- “Secure FTP” on page 181
- “FTP and SFTP file permissions” on page 181
- “WebDAV” on page 182

Local area networks

When Contribute is used to connect to a web server through a local network, the web server must be visible to the local network. Contribute can also be used with virtual private network (VPN) servers to ensure that all file transmissions occur behind your firewall. If the web server is not visible to the local network, you can create an FTP connection with Contribute to work with the website (if the server you are creating a connection to has an FTP server installed).

To ensure that you are entering the correct network path, use the Browse button of the Connection wizard to locate and select the network folder. If the path to the folder is correct, but Contribute still cannot create a connection, verify that the folder has proper read/write permissions.

Tip: Depending on how the server you are connecting to is configured, you might not be able to see the complete path to the website folder. If you cannot connect to the server, make certain you are using a fully qualified path.

To learn how to check your server’s network and folder permissions, see the documentation supplied with your server operating system.

File transfer protocol (FTP)

If users will be accessing the website using FTP, ensure that the folder has delete, overwrite, and rename privileges enabled. When anonymous FTP is used, these options are typically disabled by default so that users cannot update pages or add new pages to the website.

Tip: If you will be using FTP to connect to a website, Macromedia recommends using SFTP. In addition to providing a secure connection when transferring files to and from Contribute and your website, SFTP is a more reliable connection protocol. To learn more about SFTP, and the benefits it provides, see “Secure FTP” on page 181.

When you create an FTP connection, Contribute attempts to auto-detect the FTP path, checking that the FTP folder is the same folder that contains your website files. If the folder paths don’t match, Contribute can’t write to the page displayed by your browser and prompts you to enter the correct path.
To ensure that you are entering the correct FTP path, use the Browse button of the Connection wizard to locate and select the FTP folder. If the path to the folder is correct but Contribute still can't create a connection, verify that the folder has proper read, write, and modify permissions for the user. If you are creating an anonymous FTP account, the server must be configured to support delete, rename, and overwrite permissions for the anonymous user. In some cases, file permissions on UNIX servers may be configured in a way that prevents Contribute from operating, especially if the server doubles as a file server. For more information, see “Setting up a site connection in Contribute” on the Macromedia Contribute Support Center.

To test whether FTP is set up correctly for an end user, you can transfer a test web page to the server. Then, using the login settings you provide to the user, attempt to view the page in a browser.

**Secure FTP**

SFTP is a secure version of the FTP protocol. Like SSH, SFTP prevents unauthorized users from gaining access to password and user information that is sent without encryption over the Internet. Standard FTP sends the user ID and password as clear (that is, unencrypted) text, allowing anyone monitoring your FTP data to see your user ID and password, as well the data being transmitted. With SFTP, everything you transmit is encrypted, protecting it from monitoring by intruders.

In addition to increased security, Macromedia recommends using SFTP because it’s a more robust protocol that provides more reliable performance. The following reasons describe why SFTP is a better protocol:

- A more strict protocol than FTP
- Supports functionality that FTP does not
- Is more efficient than FTP
- Does not conflict with firewalls, proxy servers, or routers
- Provides a secure connection over which to transfer files

To use SFTP with Contribute, you must have an SFTP server installed. You cannot use a standard FTP server and simply select SFTP from the connection type choice within Contribute; the connection will fail. You must also have Secure Shell 2 (SSH2) enabled on the server. Contribute provides SFTP only over SSH2-protected network connections.

To learn more about SFTP, see the documentation supplied with your server’s operating system and SFTP server. To learn more about SSH2, see the SSH Communications Security website at www.ssh.com.

**Note:** Contribute supports only password-based authentication. Other authentication methods, such as certificate-based authentication, public key, and Kerberos, are not supported.

**FTP and SFTP file permissions**

Typically, FTP servers are configured so that when they create (or write) a new file, the permissions created for the file give the person uploading the file read/write permission and give members within the permission group read-only access.
In the case of Contribute, this process can cause a problem when another user tries to edit a page. Contribute can read the file, but when it attempts to copy the updated file back to the web server, the FTP server’s file permissions prevent Contribute from writing the new file.

When configuring your FTP server to work with Contribute, be certain to configure the file permissions that the FTP server creates for new files so that members of the permission group can read and write the file. This issue typically occurs on UNIX servers. You should set the permissions for files to umask 664, which provides read and write access to the file owner (the person who created the file) and to the permissions group (which would include any users needing to connect to the website to update the file).

WebDAV

Web-based Distributed Authoring and Versioning (WebDAV) is a series of extensions to the HTTP protocol that lets users collaboratively update and manage files on a website. A key feature of the WebDAV protocol is file locking. Users connecting to a WebDAV-enabled site lock files when they open the file for editing. This prevents a user of the same website from overwriting another user’s changes.

To use Contribute with a WebDAV-enabled site, you must use a WebDAV server that supports exclusive write locks. Exclusive write locks guarantee that only the lock owner (the person who opened the file for editing) can overwrite the file.

Note: Some WebDAV servers support shared write locks, which allow two or more users to collaborate concurrently on a web page. Contribute does not support shared write locks. If a user opens a page using Contribute on a WebDAV-enabled site that uses shared locks, Contribute opens the file only if it can create an exclusive lock. If another user is editing the file, Contribute informs the user that the file is not available for editing.

When creating a connection to a WebDAV-enabled site, you must provide a WebDAV-specific URL. This might consist of a specific port number used by the WebDAV site.

For example, suppose that this is the URL of your site:

www.mysite.com/

This might be the WebDAV URL:

www.mysite.com:81/

Appending the port number 81 to the site’s domain name specifies the network address used by WebDAV.

WebDAV-enabled sites often have their own user name and password requirements. You can create these on an individual basis, or you can create a group user name and password.

When creating a connection to a WebDAV site, you must not mix connection types (such as FTP with WebDAV or local area network with WebDAV). You must use only the WebDAV connection type. When you create a connection to a website using local area network, FTP, or SFTP connections, Contribute uses its own file-locking mechanism to prevent users from overwriting each other’s files. Contribute connections using these connection types cannot detect files locked with WebDAV locks and could inadvertently open a file being edited by a WebDAV-enabled connection.
To prevent users from setting up different connection types to a WebDAV-enabled site, do one of the following:

- Tell users creating connections that they should use only the WebDAV connection type with WebDAV-enabled sites.
- Send a connection key that allows only users connecting to the site to use WebDAV.
- Restrict local area network, FTP, and SFTP access to the server hosting the WebDAV-enabled site.

For more information on WebDAV, see the WebDav Resources website at www.webdav.org.

**Contribute and directory services**

Lightweight Directory Access Protocol (LDAP) is a protocol for accessing information directories. Microsoft Active Directory and LDAP are types of directory services. In the case of directory services, a directory is like a telephone book and not like a directory (folder) on your computer.

You can integrate the User Directory service of CPS with your directory service. The User Directory is an application service that enables you to centrally manage users.

When you integrate with your LDAP directory, you control who can access your website and how they are authenticated.

**LDAP branches** Using the User Directory service, you can add your entire LDAP user directory for your website, or you can indicate specific branches to search.

You have the following options:

- Add the root node of your LDAP tree to the user directory, and enable search for users or groups in any of the branches.
- Add specific branches to the user directory and determine the scope of the search—whether you want to search only the branch or the branch and any subbranches. This way, you can exclude certain branches of your LDAP tree from the search.

For each branch you add, you can define a user search only or you can define a user and a group search.

For example, suppose your LDAP directory has three branches: East, Central, and West. You want to integrate with the LDAP directory your entire company, so in the following example, you add one branch for a user search to the user directory:

```
User branch with baseDN:o=MyCompany, Search Scope:SUBTREE_LEVEL, filter:(objectClass=organizationalPerson)
```

Now, suppose you want to include only the Central and West branches and you want to define user and group searches. You add the following four branches to the user directory:

```
User branch with baseDN:ou=Central,o=MyCompany, Search Scope:SUBTREE_LEVEL, filter:(objectClass=organizationalPerson)
User branch with baseDN:ou=West,o=MyCompany, Search Scope:SUBTREE_LEVEL, filter:(objectClass=organizationalPerson)
```
LDAP permissions and Contribute permissions

Integrating your company LDAP directory with CPS adds another layer of permissions. When connecting to an LDAP or Active Directory server, CPS respects any file/folder permissions set by the LDAP or Active Directory service. Contribute permissions are layered on top of the directory service or the network/server permissions and are applied globally.

Contribute permissions, which are settings stored in an XML file at the root of your website, are specific controls for the Contribute editing environment. These permissions are not assigned on a per-user basis; they are simply groups of settings that Contribute reads when first connecting to a website. Contribute then conforms to these settings during the editing process. Contribute administrators can specify access to certain folders for different user roles.

LDAP authentication types

CPS authenticates users against the LDAP directory. For CPS to authenticate a user, the LDAP server must verify the user's display name. This is usually a unique name in the LDAP tree that is associated with the user. CPS receives only a user name, so it must retrieve the user's display name, based on the user name, to authenticate the user.

In your User Directory service configuration, you can select one of four types of LDAP authentication:

- **LDAP bind** authenticates users by pre-pending a specified prefix and appending a specified suffix to the user ID. With this method, you can specify only a single prefix and a single suffix. Use this method if all the DNs in your LDAP directory are stored as prefix + <username> + suffix.

  If all DNs are not stored according to this pattern, then this method does not enable you to construct a path to all the users in your system.

- **LDAP bind (auto-find user DN)** authenticates users in a two-step process: CPS looks up the user ID of the user who's trying to log in to determine that user's DN, and then uses the DN to authenticate the user. Use this method if all your DNs are *not* stored according to the same prefix + <username> + suffix pattern. For example, if you have set up CPS to search multiple branches (OUs) of your LDAP tree, and those branches store DNs in different ways, then you should use this authentication method.

  Although this method requires an extra LDAP search (compared to the LDAP bind method), it gives you more flexibility.

- **Password in file** authenticates users using passwords that you specify when you add users to the file-based User Directory.

  *Note:* If you use the file-based authentication with an LDAP Directory, you must have a file entry for each user in your LDAP directory.

- **Windows domain** uses your organization's Microsoft Windows authentication solution.

  If you use this method, the User IDs in your LDAP directory must match your Windows user IDs.
User management models

User management lets you add and remove user access to websites and create user roles that restrict editing privileges within a site. User management also provides a mechanism that lets users easily connect to a website.

Contribute has two user management models: manual site connections and sites managed using the CPS User Directory service.

**Manual connections** let you communicate connection information to users, who then create their own connections, either by entering connection information in the Connection Wizard or by importing a connection key file that you give them.

This user model works best for smaller workgroups and organizations. It allows you to quickly set up Contribute, create a connection to your website, define the necessary user roles, generate connection information for the website connection/user role, and send it to users in the form of a connection key file.

**Contribute Publishing Server** lets you integrate Contribute with your organization's LDAP or Active Directory services, giving you the ability to add and remove user access to a website and modify user roles without having to resend connection key files to users. You can also create a file-based database, using an XML file to manually enter user names and passwords.

CPS is intended for larger organizations that have several Contribute users to manage. CPS lets you add and remove users from websites and roles without having to resend connection information. When you create a connection to a website that uses CPS, you simply add users to a list that grants access to a given website and user role. When the user access the website, CPS prompts them for a user name and password. After entering their user name and password, they are granted access to the website and the role you've assigned to them.

To use CPS, you must have a J2EE application server such as Macromedia JRun installed.

To learn more about CPS, see the CPS website at www.macromedia.com/go/cps.

**Related topics:**
- “Contribute user roles” on page 185
- “Website connection distribution” on page 190
- “Contribute Publishing Server” on page 198

Contribute user roles

Contribute lets you control access to your website by creating roles. Roles are collections of settings that you create, each of which may be assigned privileges by the administrator of the site. The roles you create reflect different levels of access to page creation, editing and deletion of content, page design, and approval.

You can define any number of Contribute roles and specify various options for each role you create. Contribute roles are not based on system or network user groups. You can create the same role for members of various workgroups and send them a connection. As long as the recipients have appropriate access to the network and server, they can edit the website.
Default roles

Contribute has three default roles: Administrator, Publisher, and Writer

**Administrator** identifies the administrator of the site, who can create new roles and modify existing ones, add users to the site, and send connections to new users so that they can access the site. A site can have more than one person assigned to the administrative role.

**Publisher** identifies users who can create and edit pages as well as publish pages to the website.

**Writer** identifies users who can create and edit pages, but cannot publish pages to the website. A user in the Writer role must send their pages for review to a user in a Publisher or Administrator role who can publish the page to the site or send it back to the Writer for additional editing.

Depending on your website publishing needs, and the number of people adding content to your site, you might only need to use the Administrator and Publisher roles. If you deploy Contribute in an organization where website content must be approved before it's published, you should use the Administrator, Publisher, and Writer roles.

In general, you shouldn't need to create too many roles for a website. If you are deploying Contribute in a large organization that uses many internal websites to communicate information, consider creating connections to Contribute from the individual websites and sending appropriate roles to the users who are responsible for each site's content.

Example role assignments

As an example of roles you might create, consider an online magazine. The job functions associated with producing a magazine include a publisher, managing editor, copy editor, writer, and web designer. In addition, Contribute adds an administrator to maintain the magazine’s website. Each role reflects separate access to article creation, approval, editing and deletion, page design, and site maintenance.

The following table describes the roles and privileges related to Contribute.

<table>
<thead>
<tr>
<th>Job Title</th>
<th>Contribute Role</th>
<th>Privileges</th>
</tr>
</thead>
<tbody>
<tr>
<td>System administrator</td>
<td>Administrator</td>
<td>Installs Contribute, creates connections to the website, and defines Contribute roles appropriate to the magazine’s job functions. The system administrator consults the designer on how to set up role settings so that other members of the magazine’s staff have appropriate editing privileges within their area.</td>
</tr>
<tr>
<td>Publisher</td>
<td>Publish</td>
<td>Gives final approval to all articles on the website and can publish final drafts of pages or send them back for additional editing or writing.</td>
</tr>
<tr>
<td>Managing editor</td>
<td>Publish</td>
<td>Monitors drafts as they go from writers to copy editors and keeps track of who is working on what article. The managing editor approves articles before sending them to the publisher for final approval and publication to the website.</td>
</tr>
<tr>
<td>Copy editor</td>
<td>Writer</td>
<td>Can edit any unlocked text on a page. The copy editor cannot publish pages to the site; they send the edited articles to the managing editor for approval.</td>
</tr>
</tbody>
</table>

186  Deploying Contribute to Departments and Enterprises
Contribute and website security

As an administrator, one of your primary concerns is in maintaining the integrity of your IT infrastructure. Contribute works within the security parameters of your network and server operating systems, ensuring that those system’s safeguards take precedence over any access rights granted within Contribute.

This section documents security issues that are specific to Contribute. For best practices on securing your website, see to the documentation provided with both your server’s operating system and web server software.

This section covers the following topics:

- “Web page rollbacks” on page 187
- “Restricting access to administrative folders” on page 188
- “Staging servers and Contribute” on page 189

Related topics:

- “Understanding network and server permissions” on page 173
- “Secure FTP” on page 181
- “Contribute user roles” on page 185

Web page rollbacks

Rollbacks let you revert to a previous version of any published web page, providing you with a level of file recovery. You do not have to roll back to the last published version; you can select any version that Contribute has saved as a rollback file.

When you roll back to a previous version of a page, Contribute reverts to the previous text contained in the version of the page you select. However, any assets imported into the page may or may not be recovered. For example, suppose you update an image file outside of Contribute and then replace the original image with another image using the same filename. In this case, Contribute cannot roll back to the previous version of the image because Contribute does not manage assets outside the web pages it creates.
Contribute does maintain the older version of an image if you use Contribute to edit the image in an external application. Contribute considers images, Microsoft Word documents, and other content that you edit in an external application as assets. You can roll back assets that you’ve edited through Contribute the same way that you roll back pages.

For example, suppose you roll back from version C of a page to version A, and you used Contribute to edit an image in version B. When you roll back to version A, you will not see the current version of the image. You need to also roll back the image, independently of the page rollback.

To learn more about rollbacks, see “Enabling and disabling rollbacks” on page 221.

Restricting access to administrative folders

When you create a site connection, Contribute creates special files that are stored in folders whose names begin with an underscore (such as _mm, _baks, and _notes). These folders may contain files with user names, e-mail addresses, previous versions of web pages, and other types of meta information used by Contribute. The underscore allows Macromedia Dreamweaver and Contribute to distinguish between those folders and the other folders in your site.

Contribute and Dreamweaver use this naming convention to filter these special files and prevent them from appearing in the Dreamweaver Site panel and in the Contribute Remote File Browser. These hidden folders can’t be browsed, overwritten, or inadvertently altered by users. Additionally, some search engines and automated programs are designed not to return pages found in folders whose names begin with an underscore.

To ensure that these folders and files remain protected, review the configuration of your web server software and make certain that you block HTTP access to folders whose names begin with an underscore (_mm, _baks, and _notes), the MMWIP folder, and files identified by the file extensions .lck, .mno, .bak, .lbi, .csi, and .dwt.

In particular, you might want to block HTTP access to the MMWIP folder. The MMWIP folder contains interim drafts of files (works in progress) that you might want to protect. Macromedia recommends that you restrict access to the MMWIP folder so that only members of your organization can browse files within that folder.

**Note:** In addition to using the computer’s operating system and web server software configuration settings, you might consider using a third-party URL scanner to block HTTP access to secure these files and folders.

Related topics

- “Contribute site structure” on page 175
- “Staging servers and Contribute” on page 189
- “The draft review process and site structure” on page 191
Apache web servers

If your website uses Apache, you can explicitly disable browsing folders and files that begin with an underscore. If you know how to modify the Apache web server's httpd.conf file and have permission to do so, you can use the DirectoryMatch directive to prevent visitors from viewing any file in a folder beginning with an underscore.

If you're not sure how to edit the Apache httpd.conf file or don't have permission to do so, ask your system administrator or Internet service provider (ISP) to do it for you. To learn more about limiting access to files and folders, and other security issues relevant to the Apache web server, see the documentation supplied with your Apache distribution.

Microsoft IIS web servers

To prevent unauthorized users from accessing Contribute administrative folders under Microsoft IIS, use access control lists (ACLs) to prevent read access by unauthenticated users of the operating system as well as by clients connecting to IIS. When you use ACLs to restrict access, only properly authenticated users can view the contents of the Contribute administrative folder. Anonymous web clients, or other users with access to the server, cannot view the administrative folder and its contents.

**Note:** When setting permissions for Contribute administrative folders, ensure that Contribute has read/write access to the administrative folders and the files they contain. Contribute uses the settings in these files to enforce role settings of users connecting to the site.

In addition to securing the administrative folders using the operating system's permissions and access control lists, you should consider using UrlScan to further secure IIS web servers. UrlScan is a security tool provided by Microsoft that screens incoming requests to the server by filtering the requests based on rules that you create. Filtering requests helps secure the server by ensuring that only valid requests are processed.

To learn more about the UrlScan utility, see the Microsoft website at [www.microsoft.com](http://www.microsoft.com).

Other web servers

If you are using another vendor's web server, refer to the documentation supplied with your web server software to learn how to prevent users from accessing specific folders and files.

Staging servers and Contribute

If you use Contribute to update information published to a website that is accessible to the public (not protected by a firewall), but need to ensure that temporary drafts of pages and user information remains protected, consider using a staging server. Staging servers let you update website content in a protected environment and only publish those pages approved for public viewing to a production server. To protect Contribute administrative files, do not copy any folders whose names begin with an underscore (_mm, _baks, and _notes), the MMWIP folder, and files identified by the file extensions .lck, .mno, .bak, .lbi, .csi, and .dwt.

If you use a staging server, you need to create Contribute connections to the staging server and not your production web server.

To learn more about using a staging server, see “Staging servers and Contribute” on page 203.
Website connection distribution

To set up Contribute users, you need to provide them with the basic site connection information for the web server. You do this by sending them a connection key.

A connection key is a file generated by Contribute that contains all the information that Contribute requires to connect to a site. The information in the connection key is encrypted with a 128-bit algorithm for security purposes. Users cannot read or change the connection or role information in the connection key. Administrators create these password-protected connection keys using the Send Connection Key feature of the Administer Websites dialog box. The keys can be sent to users by e-mail, or saved to the network.

You do this in Contribute through the Administer Websites dialog box (Edit > Administer Websites). If a user uses a connection key that refers to a deleted role, an alert appears, asking the user to contact the site administrator.

When you use this option, Contribute automatically starts the default e-mail application and generates an e-mail message containing the connection key as an attachment, along with simple instructions to help the user get started. As the administrator, you must send users the connection key password information they need to access the website. Typically, you send the password information in a separate e-mail message or contact the users by phone.

After receiving a connection key, a Contribute user simply double-clicks it to start the connection process. Because the file is encrypted, the user must know the password that the administrator defined for the key. Connection keys also specify what role settings to apply. When the user supplies the correct password, Contribute automatically makes a connection to the site and allows page edits as defined for the associated Contribute role.

Related topics
- “About creating and sending connections” on page 207
- “Sending connection keys for websites” on page 227

Deploying Contribute across an organization

Macromedia uses an extensible installation application that lets you install Contribute to multiple Windows computers within your organization. The Contribute installer can interface with Microsoft Active Directory, letting you push the application out to multiple users based on the group policies you have in place. You can also configure the installer to include additional templates or other assets specific to your organization's needs.

The Windows Installer Service lets you use either the freely available Microsoft Windows Installer SDK or you can purchase InstallShield DevStudio and InstallShield Tuner. The InstallShield tools let you open an Microsoft Windows Installer (MSI) installer database, modify the installation settings and contents, and save your changes as either a transform or as a new MSI database that will install your customizations.

To learn more about the Contribute MSI installer, see the Contribute Developer Center at www.macromedia.com/devnet/contribute.
The draft review process and site structure

The draft review process enables you to send drafts to users for final approval before publishing pages to your site. When you enable the draft review process, Contribute creates a series of folders and files used in tracking pages as they make their way through the collaborative approval workflow. Although there are no site maintenance or planning tasks involved in enabling approvals for your website, you should be aware of the additional files and folders that Contribute creates to manage the workflow.
The following figure shows an example of a file sent for review, and the files and folders that are created when you send a user of your website a page for review.

This figure shows the main folders and files that are created when you enable the draft review process for a given site and a user sends a page for review. The following folders are created:
_nm/ct2004/messaging/users contains a folder for each user for whom the draft review process is enabled. Each user folder is populated with a series of XML files that identify what drafts the user has within the system. In the previous example, the file notifyWIPjr615v2v4p.csi indicates that notification has been sent to one or more users that there is a page that needs review.

**WIPMetaData** contains a series of files that maintain the draft history and the current state and location of the draft within the draft review process. The files contained in this folder include an XML file (wipMeta.mje1d0lz4vxc.csi in this example) that serves as a pointer to files in the draft review process and also include contact information for the sender and recipient of the draft. A corresponding file with the extension .fre indicates that the file is free (available for review).

**MMWIP** stores drafts in progress. For each file in the draft review process, a random folder name and filename are generated. In the preceding example, the actual filename is myPage.htm. Contribute generates the folder name 8eba150d and the filename 3629c837.htm.mno to represent the file as it progresses through the draft review process.

When the recipient of the page requiring review chooses to view it, Contribute creates a LCK (lock) file for the page within the website, and a CHK (checkout) file in the WIPMetaData folder. These files indicate that the file is in use by the recipient and tracks changes made to the file.

The filename extensions (.mno and .csi) used by the draft review process help to prevent interim drafts of web pages and their associated XML messaging files from being served by your web server. This helps to prevent users from inadvertently sending a link to a draft of a file or from using a web browser to view files in the draft review process. In addition, Contribute places a guard page in each of the folders used to store files for review. The guard page (labeled index.html in the previous example) redirects users to the website’s home page.

**Related topics**
- “Contribute Publishing Server” on page 198
- “Contribute and website security” on page 187

**Content design considerations**

When integrating Contribute with your website, it’s important to remember the design elements that the web designer used in the site. Web page design can be as simple as the base set of HTML tags and a page that is completely modifiable, or it can use a series of web standards that allow for enhanced typography, sophisticated layout, and templates that maintain consistency from one web page to the next.

This section provides an overview of web-design methods that make a website easy to update, protect stable content from being inadvertently deleted, and maintain consistency among design elements.

If you’re not familiar with web page design or the HTML elements used to design a website, contact your web team or the people responsible for creating your organization’s website. If you’re in a smaller organization without access to web design resources, review the design-related articles available on the Contribute Developer Center at www.macromedia.com/devnet/contribute.
This section covers the following topics:

- “Dreamweaver MX 2004 and Contribute” on page 194
- “Cascading Style Sheets (CSS)” on page 195
- “Web page templates” on page 195
- “Shared assets” on page 196
- “Secure content using SSIs” on page 197

**Dreamweaver MX 2004 and Contribute**

Macromedia Dreamweaver MX 2004 provides several features that make it an ideal environment for designing and authoring pages in Contribute-enabled websites. When using Dreamweaver and Contribute together, you need to remember several issues related to site design and to the concurrent content updating by Contribute users.

Before you can use Dreamweaver to administer a Contribute site, you must enable Contribute compatibility. Depending on the site to which you are connecting, you might be automatically prompted to enable Contribute compatibility.

**Note:** When you enable Contribute compatibility, Dreamweaver automatically enables Design Notes (including the Upload Design Notes for Sharing option) and the Check In/Check Out system.

To learn more about enabling Contribute compatibility in Dreamweaver, see “Managing Contribute Sites with Dreamweaver” in Dreamweaver Help.

**File Check In/ Check Out**

Dreamweaver users should ensure that the Check In/Check Out feature is enabled, so that files are not overwritten as they work in a collaborative environment. All Dreamweaver users should ensure that any pages they are editing have been properly checked out to prevent the inadvertent overwriting of pages.

When a user checks out a file from the remote server, Dreamweaver locks the file. No other member of the web team can work on that file. Macromedia Contribute constantly checks the status of files that the user is browsing.

For instance, suppose that user A has checked out a file and that user B attempts to edit it. User B sees a message in the status bar, and the Edit Page button is disabled in user B’s Contribute toolbar. For this reason, it is impossible for user B to overwrite the file accidentally.

After user A finishes working on the file and publishes it to the site (by “checking it in” to the server), user B’s Edit Page button becomes active.

Check In/Check Out is part of the Dreamweaver site settings options. To learn how to enable Check In/Check Out, see Dreamweaver Help.
Design notes

When using Macromedia Dreamweaver MX and Dreamweaver MX 2004, enable Design Notes and upload them to the web server. Design Notes are notes associated with a page, but stored in a separate file, that let you keep track of extra file information associated with your documents, such as image source filenames and comments on file status.

Note: Dreamweaver 4 and Contribute are not compatible when Design Notes are enabled. For this reason, Macromedia recommends using Dreamweaver MX or later for collaborative work on Contribute websites.

Design Notes are part of the Dreamweaver site settings options. To learn how to enable Design Notes, see Dreamweaver Help.

Cascading Style Sheets (CSS)

Web designers use CSS to specify formatting rules that can be applied to text and other design elements in a web page. These rules—called CSS styles—can be defined within a page, or in a separate style sheet that can be applied to multiple pages (or templates on which multiple pages are based). This makes it easy to apply styles consistently throughout a site.

Contribute recognizes CSS styles attached to a page and lets the user apply these styles. Contribute users can apply styles defined in the page itself, or in an attached style sheet. You cannot use Contribute to attach a CSS to a page. Use Dreamweaver to define CSS styles for an individual document or to create a style sheet that you can attach to multiple documents.

Tip: Give CSS styles names that make sense to Contribute users. For example, instead of Heading, use a more descriptive name such as MainHeading, Title, or Headline, depending on how you intend the style to be applied.

Each style you define in a style sheet appears in the Styles pop-up menu. If you want to keep certain styles from appearing in the menu, add mmhide before the style name (for example, mmhideNavTable).

To learn more about using CSS with Contribute, visit the Contribute product page at www.macromedia.com/software/contribute.

Web page templates

Templates are powerful design tools that help control which areas of a page can be updated. If you use the same or similar layout across several web pages, templates let you quickly redesign or update multiple pages at once. Templates are also well suited for groups that update a website’s content collaboratively because they let you standardize web page layouts while preventing contributions from accidentally deleting or altering locked elements.

Templates are made up of editable and non-editable regions, allowing content contributors to make edits only in predefined, editable regions of the page. You can also use the permissions settings within Contribute to define what templates a user role can access.

Templates are similar to other web pages with the exception that certain areas are locked. In fact, the entire template is locked by default. You must create editable regions within the template that others can modify.
When designing templates, keep the following tips in mind:

- If certain information should appear on all pages, make it noneditable.
- Create editable regions for page-specific information that varies across pages.
- Test your template before creating many pages based on it, to make sure that the template accommodates all kinds of content you intend to place on the pages. Although you can update all template-based pages at once, this works best when the changes are minor. If you make major changes to a template, you may have to manually update all pages based on it.

**Templates in Contribute**

To be used in a Contribute site, the Dreamweaver template files, identified by the .dwt file extension, must reside in a folder named Templates in the root folder of the website (for example, `/Templates/contactPage.dwt`). When you create templates in Dreamweaver, they are automatically saved in a Templates folder, but you need to publish the folder to the web server. If users do not have access to the root folder or are restricted to a subfolder in the website, you need to copy the Templates folder to the appropriate site subfolder to provide access to the templates.

**Note:** If you create a folder containing Dreamweaver templates but don’t see your templates in Contribute, you need to add the .dwt extension to the list of MIME types supported by the web server. For information on configuring MIME types, see the documentation supplied with your web server.

**Editable regions in templates**

You cannot make only one area editable while locking others and yet also allow the user to change a single attribute of a tag within an otherwise protected area. Additional abilities include optional content and repeating regions.

The key to designing templates for Contribute is precision. If you designate an entire section of a page as an editable region, you give the Contribute user too much power. A better solution is to create multiple editable regions with precise uses.

To learn more about creating successful templates for use with Contribute, see the Contribute product page at [www.macromedia.com/software/contribute](http://www.macromedia.com/software/contribute).

**Shared assets**

The shared assets feature lets you create a library of assets (such as images, Macromedia Flash content, or Dreamweaver library items) that users can insert into web pages. You can restrict access to shared assets to specific roles, or let any Contribute user accessing the website insert the assets into their pages.

Examples of shared assets include corporate logos and other image files created by graphic designers, Flash movies designed by web designers, and feedback forms (in the form of a Dreamweaver library item) developed by web developers. You can add each of these items to a shared assets library and specify which users (based on their assigned roles) can insert the items into a page.

When creating shared asset libraries, give each asset a descriptive label that is different from its filename. These labels can help users understand what they are about to insert into their web page.
**Note:** All items added to a shared asset library must reside on the server (local files cannot be added unless the site is locally hosted).

**Dreamweaver library items** are special Dreamweaver files that contains a collection of individual assets or copies of assets created for placement in your web pages. These assets in a library are called library items. You can store all sorts of page elements, such as images, tables, sounds, and Flash files in a library.

Dreamweaver library items must be stored on the remote server and located in the Library folder. The Contribute administrator can set library files as locked or unlocked shared assets. A locked library item cannot be edited in Contribute; unlocked library items are editable in Contribute when inserted into a draft.

In Dreamweaver, a user can detach library items on the page. But in Contribute, the administrator determines whether the library item should be locked or unlocked for a given role. Typically, you can update all the pages that use a library item whenever you change the item’s contents. However, in Contribute, this depends on whether the library item is locked or unlocked.

When Contribute inserts unlocked library items, Dreamweaver library tags are not inserted into the page code. Because Dreamweaver cannot recognize the content as a Dreamweaver library without these tags, the published page’s unlocked library content is not updated if the library item is modified or otherwise changed. (In Dreamweaver, modifying the source library of the library item automatically updates the instance of the library item on the page).

If the library item is locked, the published page’s library item is updated from Dreamweaver when the item changes.

For more information about Dreamweaver library items, see the Dreamweaver documentation.

**Secure content using SSIs**

Server-side includes (SSIs) let you maintain consistent page elements such as navigation, headers, and footers. In most cases, the content contained in an SSI is not intended to be edited by a content provider, and Contribute will not allow SSI material to be modified inline. Determined users can, however, locate the server-side include file from the Choose File on Website dialog box, if they know its name and path. But if you don’t include the .inc extension in the name of the SSI file, the file cannot be edited in Contribute. By default, Contribute can open files with the following extensions: .htm, .html, .shtm, .shtml, .asp, .aspx, .ascx, .cfm, .cfml, .php, .php3, .php4, .phtml, .jsp, and .inc.

Files with common system extensions, such as .txt or .doc, can be opened with their associated editor. If you choose an extension for your include file that does not fall into either of these categories, such as .ssi, the file is effectively locked from editing in Contribute.

To be effective in Contribute, server-side includes must adhere to a particular format. Contribute requires that SSIs not contain any of an HTML page’s structural tags, including the HTML, HEAD, and BODY tags. An SSI used in Contribute must consist only of the material found inside either the HEAD or BODY tag.
Contribute Publishing Server

You can use Contribute with Contribute Publishing Server (CPS), a suite of optional services that enables you to add functionality to your website. Using CPS you can more easily manage Contribute as well as provide additional functionality for Contribute users.

CPS has the following services:

**User Directory service** lets you integrate Contribute with an LDAP or Active Directory service, or create a file-based user directory so you can easily manage users and their access to websites.

By integrating Contribute with a directory service such as LDAP or Active Directory, you can easily assign users to roles, and provide them with easy-to-access connections to websites. All the connection information and role assignments for users is stored on the server, which you install on a centrally accessible Java application server within your computing environment. CPS then controls who has access to what websites and a specific user’s role within the website.

**Log service** records all events within a specified Contribute site to a log file that you can use to troubleshoot potential problems with the website. You can specify how many log files to archive for reference.

**E-mail Notification service** keeps users informed about the status of drafts they are working on without requiring the user to start Contribute. The service sends e-mail to users whenever someone sends them a draft requiring their attention and keeps them informed about the status of drafts they’ve sent, such as when a page is published to the site.

**Simple File Deployment service** enables you to easily move files from a staging or testing server to a live server.

**RSS Activity Feed service** produces a syndication feed that lists changes that occur in any folder on your website.

CPS is a Java application that runs within a J2EE application server. To learn more about CPS, see the CPS website at www.macromedia.com/go/cps.

Contribute case studies

Now that you know how shared settings work and how an administrator can set up specific roles to limit user access, you can consider various scenarios for setting up Contribute for large or multi-team organizations.

This section describes three primary configurations for you to consider as you set up a Contribute site. Remember the following issues to successfully set up multiple users:

- Determining where the shared settings file is stored
- Preventing connection paths from overlapping
- Sending connections to users

Depending on how your website is structured, you need to use separate strategies for setting up access for various groups of users.

Use the information in this section to help you determine where to create the shared settings file for the following common website structures:
**Simple intranet website**  Typically, this is a website where users have read access to the root of the site and read/write access to specific folders in the site as controlled by the file server or network permissions. There is a single root folder and all users access the site using the same Contribute connection. If this applies to your site, see "Deploying Contribute to a simple intranet website" on page 199.

**Several distributed websites within an intranet**  In this structure there is a single root folder. The root folder contains folders for each section or organizational function within the website. Contribute roles are used to control user access to particular folders on the site and to assign a subset of the common templates used on the site. Although not required, file server permissions are usually used in addition to Contribute roles to restrict user access to sections of a site. If this applies to your site, see "Deploying Contribute to an intranet using multiple connections" on page 200.

**Contribute Publishing Server**  In this example, CPS has been deployed, and the User Directory service has been integrated with the organization's LDAP service and is being used to manage users. If this applies to your site, see "Contribute and directory services" on page 201.

**Staging Servers and Contribute**  Many websites use a staging web server with their production web server. Staging servers let you create and test web content without making it live on your public facing website. Only when content has been approved are web pages and their associated files copied from the staging to the production web server. When used with Contribute, a staging server adds an extra measure of security because you can configure your staging server so that Contribute specific files (such as administrative folders, rollback files, and interim drafts) are not copied to the publicly accessible website outside your network firewall. For more information, see “Staging servers and Contribute” on page 203.

**Deploying Contribute to a simple intranet website**

In this example, Contribute is deployed to a simple intranet consisting of a single web server hosting a departmental website. The website has a single, common root folder with subfolders for individual departments. The site uses Dreamweaver templates and CSS styles to enforce the look and feel of the website and SSIs to maintain page elements such as navigation menus, headers, and footers.

The key to this arrangement is that all users have the same Contribute site connection. In other words, there is a single connection point for all users that controls the behavior of Contribute when editing the website. If you want to restrict users to editing content in their workgroup’s folder, you would need to create a role that limits access to a specific folder.

An advantage to this type of Contribute deployment is that users in all departments can collaborate by sending pages for review to one another. If separate connections had been created for each department (as in the example "Deploying Contribute to an intranet using multiple connections” on page 200), then only the users with access to that folder could receive and edit drafts sent to them for review.
It is important that the Templates folder, which is located at the same level as the Contribute shared settings folder (_mm), is accessible by all users, and the site's CSS (CSS folder), and server side includes (SSI folder) are protected by role settings that restrict access to those folders. Web pages and associated files stored in these folders cannot be edited using Contribute, preventing them from being inadvertently modified or damaged. If you want to restrict users to editing content in their workgroup's folder, you need to create a role that limits access to a specific folder.

Deploying Contribute to an intranet using multiple connections

In the following example, there are several departmental intranet sites, each of which needs access restricted to members of the given department. To accomplish this, the administrator creates a separate Contribute connection for each department's folder within the website. In addition, each department has its own set of Dreamweaver templates on which to base new pages.

When connecting users to their respective sites, the administrator will create and distribute a connection key for each website connection.

In this scenario, three administrator connections are created. The site administrators create a connection to their department's section of the website (for example, /myIntranet/sales). Additional roles can be created to define any restrictions for users in the site (for example, to specific subfolders in the Sales folder or to set editing options).
Users can browse the entire site but are restricted to editing within their department’s folder. By restricting user's editing privileges to their department's web pages, each group can maintain control over their web content and can act more independently with the content they make available to the entire organization. A potential drawback to this arrangement is that users in different departments cannot collaborate on pages. Each department must work independently.

**Contribute and directory services**

Using CPS, you can integrate your organization's user directory services (such as LDAP or Active Directory) with Contribute. This gives you individual control over which user is granted access to a particular website and the role to which they are assigned.

For this case study, consider a large organization with several decentralized websites. In addition to a public facing site that provides information about the organization, there are several internal sites in use by individual departments and workgroups. The organization uses LDAP as both a directory service that lets users look up other employees as well as an authentication service through which administrators set permissions limiting users' access to file-sharing servers and other network resources.
Unlike sites that don’t use CPS to manage users, when a user logs in to a CPS website, the User Directory service retrieves the connection information associated with that user, and provides access to the sites the administrator has assigned. By maintaining site connection information within the User Directory, administrators can add or remove access to websites without having to resend connection information.

This example provides a partial listing of employees from an organization’s user directory. The employees, their workgroup affiliations, and the sites they can access are listed in the following table:

<table>
<thead>
<tr>
<th>User</th>
<th>Workgroup</th>
<th>Websites</th>
</tr>
</thead>
<tbody>
<tr>
<td>John Lydon</td>
<td>Product Management</td>
<td>Sales, Production, Marketing</td>
</tr>
<tr>
<td>Malcolm McClaren</td>
<td>Product Management</td>
<td>Sales, Production, Marketing</td>
</tr>
<tr>
<td>Martin Atkins</td>
<td>Marketing</td>
<td>Marketing</td>
</tr>
<tr>
<td>Keith Levine</td>
<td>Sales</td>
<td>Sales</td>
</tr>
<tr>
<td>John Savage</td>
<td>Production</td>
<td>Production</td>
</tr>
<tr>
<td>Laura Logic</td>
<td>Web Design</td>
<td>Sales, Production, Marketing</td>
</tr>
<tr>
<td>Jah Wobble</td>
<td>Contribute Administrator</td>
<td>Sales, Production, Marketing</td>
</tr>
</tbody>
</table>

Although this user list is oversimplified, it demonstrates one possible scenario for the way that users within an organization might be assigned access to websites. This scenario divides users according to their role within the organization, and assumes that they have full editing and publishing privileges within their respective sites. Certain users have access to all the sites. For example, the product managers, John Lydon and Malcolm McClaren, work with all the teams in developing and launching products, and need to contribute to all the sites.
Likewise, web designer Laura Logic and Contribute administrator Jah Wobble have access to all sites. As the web designer, Laura provides templates that are easy to add content to and that fit the needs of users collaborating internally. The templates she maintains include those for taking meeting minutes, for scheduling, and for providing product specifications, marketing launch plans, and sales projections, to name a few. Laura also collaborates with Jah Wobble, the Contribute administrator, to help determine the editing and publishing privileges for individual users and roles.

CPS integrates with the organization’s LDAP service, which authenticates user access to various network resources. In this case, the LDAP authentication is the first step in granting access to websites hosted on various servers within the organization. The Contribute roles further define user privileges within a website, determining the degree to which users can modify pages within the site.

**Staging servers and Contribute**

Many organizations use a staging web server with their production web server. A staging server lets you create websites on a non-production web server, so you can generate and test content without making it live on your organization’s public website. The use of a staging server also lets you maintain an automatic backup copy of all your website content.
In regard to Contribute, the use of a staging server lets you copy only folders and files that you specify as necessary for your website. This enables you to use Contribute to update web content on the staging server, but only publish the necessary web pages to your production web server for public access.

By configuring Contribute to work with content on your staging server, you can provide an extra measure of security by not copying Contribute's administrative files and folders to your production server. This also lets you eliminate the presence of unnecessary files from a server with public access.

To use Contribute with a staging server, you create a connection to the staging server's website. Users can update content on the staging server. Any temporary drafts that are created during the review process, or drafts of files that are in the process of being updated, but not yet published to the website, remain on the staging server, protected by your network's firewall.

When using a staging server, configure the software you use to copy web pages and related files from the staging to the production server to not copy the following folders and the files they contain:

_mm contains Contribute administrative files and the messaging folders used to notify users when they have a draft that requires their attention.

_baks archives rollback copies of files.
_notes contains design notes. These files record information about who last published a given page, and other information.

MMWIP contains drafts of pages that have been sent for review but have not yet been published to the site.

Keeping these folders, and the files that Contribute stores inside them, off your production website provides an additional level of security. Although every effort has been made to make these folders and their files secure, the best security measure is to keep them on a server protected by your network's firewall. In addition, you should consider using ACLs to secure these folders further by restricting access to network addresses within your organization's network.

To learn more about the Contribute administrative files, see “Contribute site structure” on page 175 and “The draft review process and site structure” on page 191.

Resources

For more information about designing websites with Macromedia Dreamweaver for use with Contribute, and the best practices to use when deploying Contribute, see the following resources:

- To help you learn more about Contribute and the best practices for creating web content, see the Macromedia Contribute Designer and Developer Center at www.macromedia.com/devnet/contribute.

- To learn more about using Dreamweaver to design content for your website as well as general information about website design, see the Macromedia Dreamweaver Designer and Developer Center at www.macromedia.com/devnet/mx/dreamweaver.

- If you use Dreamweaver to design website content, see Using Dreamweaver (available from the Dreamweaver online help) to learn about the best practices for creating CSS, web page templates, Dreamweaver library items, and other types of web content for use with Contribute.
CHAPTER 14
Creating and Managing Website Connections

After you have installed Macromedia Contribute, you must create a connection to a website before you can begin to edit its pages or create new pages.

This chapter explains how to use the Contribute Connection Wizard (Windows) or Connection Assistant (Macintosh) to create a connection. It also explains how to set administrative settings for a website and how to rename and remove website connections.

After you’ve created the website connection, you can create roles (see “Managing Users and Roles” on page 239) and then export site connection information to your users.

This chapter contains the following sections:

• “About creating and sending connections” on page 207
• “Preparing to connect to a website” on page 210
• “Creating a Contribute website connection” on page 211
• “Enabling and Disabling CPS for a website” on page 213
• “Becoming an administrator of an existing Contribute website” on page 217
• “Configuring Contribute administration settings” on page 218
• “Sending connection keys for websites” on page 227
• “Sending connections for CPS managed sites” on page 229
• “Adding users to websites managed by CPS” on page 230
• “Removing users from sites managed by CPS” on page 232
• “Managing website connections” on page 232

About creating and sending connections

When you connect to a website, depending on your web server configuration and the complexity of your website, Contribute may not be able to automatically detect all possible web server configurations. The Web Server settings of the Administer Website dialog box let you specify alternate configurations for your website’s index files and alternate web addresses.
After you have set up a connection to a website, you can send that connection information in a connection key file to users. Or, if the website is managed by Contribute Publishing Server (CPS), you can use the URL.

Web server index pages

The index page for a website is the default web page that appears when a visitor enters a website (such as www.mysite.com) but doesn't specify a page on the website. A web server can be configured to look for a page with a particular filename if no page is specified; the most common default index page filenames are index.htm, index.html, default.htm, and default.html. If you are unsure of the index page filenames that your web server uses, see your web server’s documentation.

In addition to the primary index page filename, most web servers are configured with alternate index page filenames, specifying pages to be displayed if there is no page with the filename requested as the primary index page.

For example, a web server might look for the following index page names (in this order):

index.htm
index2.htm
404error.htm

If there is a page named index.htm, the server sends that page to the browser to be displayed; if there isn't such a page, then the server sends index2.htm to the browser. If neither of those index pages is available, the server sends the 404error.htm page to the browser. Secondary pages such as these often provide an alternate entrance to the website or inform the visitor that the website is unavailable.

Contribute includes a list of popular index page filenames, using most of the popular document type extensions (.htm, .html, .cfm, .asp, .jsp, .php, and so on). If the index page filename that you use for your website is listed in the Index files section of the Index and URL Mapping dialog box (index.cfm, for example), then you can most likely ignore this configuration option. If, however, your index page filenames are not included among those listed in the dialog box, you must add your index page filenames to the list, and arrange the names in the order in which your web server is configured to look for them.

For example, if your website uses a Macromedia ColdFusion application server that uses the document type extension .cfm, and the index page for your website uses the filename main.cfm, you need to add the filename main.cfm to the list of index pages in the Index and URL Mapping dialog box, and list that filename as the first page that Contribute should look for on the website. The next section explains how to add an index page filename to your Contribute settings.

Related topics

- “Adding index page filenames” on page 222
- “Removing index page filenames” on page 224
Alternate website addresses

Web servers can be configured in a variety of ways to respond to varying user needs. One common part of web server configuration is the mapping of web addresses to either different IP addresses (often for either load balancing or localization issues), or multiple web addresses pointing to a single IP address. The following common web server configurations involve URL mapping:

**Multiple DNS aliasing** occurs when two or more domain name server (DNS) aliases point to a single server (for our purposes, a single server consists of a single IP address). When connecting to a server configured with multiple DNS aliases, Contribute views the defined website and the aliases as separate websites, even though from the users’ perspective they are the same.

For example, if your server hosts the website www.carsonline.com, and you set up two additional web addresses that refer to that same website (for example, www.cars.com and www.mycars.com), you must configure Contribute to recognize these separate web addresses as the same website.

**Virtual server** configurations have two or more DNS aliases pointing to the same server, but users view them as different websites. When a server configured in this way receives a request to retrieve a web page, it serves different pages depending on the address used in the request. There are two types of virtual server configurations:

- DNS-based virtual servers use a single IP address that has two or more DNS aliases pointing to that address. In this configuration, the web server differentiates the page request based on the web address, serving different pages to the different addresses.
- IP-based virtual servers use multiple IP addresses to differentiate web servers.

A common use of virtual server configurations is to provide localized content to different geographic locations. For example, a news website might provide different local information to users viewing the website based on their location.

**Port numbers** are often used to further divide a domain name into multiple websites. Often this is to allow the website to provide different software functionality based on a port that may be listening for incoming requests.

A web address that uses a different port number is considered to be a different website. However, this is not always the case. As with web server configurations using multiple DNS aliases, it’s important that you map host names using different port numbers to the correct website.

For example, if your organization’s website can be accessed through two different web addresses differentiated by port numbers, then you must add these web addresses to the Alternate addresses field. In this example, assume that your organization maintains the following web addresses:

- www.cars.com
- www.cars.com:8080

Both these web addresses point to the same website, with the exception that those sites using port number 8080 read the browser’s cookie file to check whether the visitor is a new or returning user. If the user is already registered, the website appears without prompting for registration. If a user is new, a dialog box appears requesting the user to register to gain access to the website.
Connection keys

Using the Connection Wizard (Windows) or Connection Assistant (Macintosh), you can easily set up connections to websites for other users. The wizard provides an efficient mechanism through which Contribute users can share website connections for collaboration.

Contribute lets you share website connection information by embedding website information in a connection key file. Because the connection key is encrypted with a password, any network or File Transfer Protocol (FTP) login information you send in the file remains secure and can be accessed only through Contribute. The connection key file uses the filename extension .stc. You can either e-mail the file to users, or save it to your computer for users to download and import. If you double-click the file, either on the desktop or as an e-mail attachment, Contribute starts and imports the connection.

FTP and Secure FTP (SFTP) connection keys can be used across platforms; LAN connection keys are platform specific.

The procedure for sending a connection key varies depending on the type of user model you’ve chosen to manage your website. If you’re letting users connect to a site by manually entering connection information or by using a connection key file, see “Sending connection keys for websites” on page 227. If you’re managing users with a connection server, see “Sending connections for CPS managed sites” on page 229.

Preparation to connect to a website

Before you begin, gather the following information:

• Your user name and e-mail address
  The user name and e-mail address identify users and the web pages they are working on. Contribute prevents multiple users from simultaneously editing the same web page. (Contribute uses a system much like the Macromedia Dreamweaver check in/check out system to avoid editing conflicts.)

  Tip: If you have multiple copies of Contribute, use a different user name for each copy. For example, Chris(laptop), and Chris(Mac). Using the same user name can cause problems because you can override checkouts you make on the other computer.

• Web address (URL) of the website
  A website’s Uniform Resource Locator (URL) is its address either on the Internet or on an organization’s intranet. Website URLs usually have the following form:
  http://www.mysite.com/
• Network path to the website (for connecting to local networks)

The network path is the location of the website within your organization’s local network. The network path includes the name of the server on which the website is stored and the directory path of the website's files on that server. For example, your network path might be \mycomputer\wwwroot\ (Windows) or afp://server:volume: (Macintosh).

Note: If you are a Mac OS X user, to create a LAN connection, make sure to mount the network volume of the server you are creating a connection to on your computer desktop before you create your connection. In the Finder, select Go > Connect to Server to mount the network to which you want to connect.

• FTP or SFTP connection information

FTP provides a secure way to transfer files to your local or remote web server. If you will connect to your website from a remote location (for example, telecommuting from home or another office) you may need to connect to the website using FTP, to transfer files from a remote location across the Internet to your website (for example, if you don’t have a local network connection to the website).

If you or your users will connect to your website using FTP or SFTP, you must know the address of the FTP server as well as the user name and password to connect to the FTP server. For example, your FTP server’s address might be ftp.mysite.com.

Creating a Contribute website connection

The Contribute Connection Wizard (Windows) or Connection Assistant (Macintosh) guides you through the steps of creating a new connection to a website, prompting you for the information needed to establish a website connection.

Note: If you are a Macintosh user and have a .Mac account, you can easily create a connection to your .Mac account. In the Connection Assistant, select the .Mac check box. For information about selecting a folder to connect to in your .Mac website, see “Creating a connection to a .Mac account” on page 212.

To create a new website connection:

1. Start Contribute.

2. Select Edit > My Connections (Windows) or Contribute > My Connections (Macintosh).

The My Connections dialog box appears. The options in this dialog box let you create and manage your Contribute connections.
3. Click Create.

The Connection Wizard (Windows) or Connection Assistant (Macintosh) appears.

This wizard or assistant guides you through setting up a new website connection. As you complete each screen in the wizard or assistant, click Next (Windows) or Continue (Macintosh) to go to the next screen.

Tip: Click Back or Go Back to return to a previous screen, if necessary. If you need more information about how to complete a screen, click the Help button.

4. On the Summary screen, review the connection settings to verify that they're correct and click Done (Windows) or Finish (Macintosh) to complete the connection.

Contribute creates a connection to the website.

After Contribute has successfully created a connection to the website, the Connection Wizard or Assistant closes, and the main page of the website appears in the Contribute browser.

Related topics
• "Enabling and Disabling CPS for a website” on page 213
• “Managing website connections” on page 232

Creating a connection to a .Mac account

You can use Contribute with your .Mac account and seamlessly set up a connection to your website. This integration of Contribute and .Mac is available on Mac OS X 10.2 and later.

Note: On 10.1.X, you need to mount your iDisk so that Contribute can detect your .Mac account. To mount your iDisk, in the Finder, select Go > iDisk.

If Contribute detects that you have an active .Mac account, you will be prompted to create a connection to your account when you start Contribute. If you dismiss the prompt, and later want to create a connection, use the Connection Assistant to create the connection to your account.

To create a connection to a .Mac account:
1. Select Contribute > My Connections (Macintosh).

The My Connections dialog box appears.

2. Click Create.

The Connection Assistant appears.

3. Select .Mac website from the What do you want to connect to pop-up menu.

Using the .Mac information stored in your computer’s system preferences, Contribute mounts your iDisk and creates the connection to the root folder of your website. For information about selecting a different folder to connect to see “Selecting a .Mac website folder to connect to” on page 213.

Note: If Contribute does not detect your .Mac account, you will be asked if you want to set up a .Mac account.

4. Click Continue to go to the next screen; on the Summary screen, click Finish to complete the website connection.
Selecting a .Mac website folder to connect to

When you select Get connection information from my .Mac account, Contribute automatically detects the path to your .Mac website’s root folder. If you want to create a connection to a subfolder of your .Mac website, you should let Contribute complete the path information, and then edit the path to the desired folder.

1. Select Contribute > My Connections (Macintosh).
   The My Connections dialog box appears.
2. Click Create.
   The Connection Assistant appears.
3. Select .Mac website from the What do you want to connect to pop-up menu.
4. In the Connection Assistant, click Continue to add the .Mac connection information.
5. In the Connection Assistant, click Go Back and deselect the Get connection information from my .Mac account check box so you can select the path you want to connect to.
   The .Mac website connection information will not be deleted; you can make the changes you want in the Connection Assistant screens.
6. Click Continue to update the settings as desired. On the Summary screen, click Finish to close the Connection Assistant.

Enabling and Disabling CPS for a website

After you install and configure Contribute Publishing Server (CPS), you can enable CPS for your website. At any point, you can disable CPS or the User Directory service.

Note: If you need to disable other services, you must use the CPS Console. For more information, see the CPS Console Help.

Enabling CPS to work with your website

Before you can start using CPS with your website, you must install and configure CPS (see CPS Console Help for information about configuring). You must also create a Contribute connection to your website (see “Creating a Contribute website connection” on page 211).

After you’ve completed those tasks, you can enable CPS for your website.

Tip: Before you enable CPS to use the User Directory with your website, make sure that any users who previously connected to the site using a connection key publish all outstanding drafts. After you enable CPS for your website, those users will not be able to connect to the website until you add them to the website from your LDAP, Active Directory, or file-based user database.

To start using CPS with your website:

1. Start Contribute.
2. Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Macintosh), and then select the website you want to administer from the submenu.
   The Administer Website dialog box appears.
3. Select **Publishing Server** from the list of administrative categories on the left.

4. Click the **Enable Publishing Server** button.
   The Enable Publishing Server dialog box appears.

![Enable Publishing Server dialog box]

5. Enter the Publishing Server web address in the address field, and then click **OK**.
   For more information about options in this dialog box, click the Help button in the dialog box.
   Contribute establishes a connection to CPS. Now you can launch the CPS Console, if you want.

**Note:** When you enable the User Directory, any users who previously connected to the site are removed, and any connection keys you may have previously sent will no longer work. You must add users from your LDAP, Active Directory, or file-based user database. To learn how to add users to sites managed by CPS, see “Adding users to websites managed by CPS” on page 230.
6. (Optional) In the Administer Website dialog box, click the **Publishing Server Console** link if you want to launch the CPS Console.

**Related topics**
- “Contribute Publishing Server” on page 198
- “Adding users to websites managed by CPS” on page 230

**Disabling CPS for a website**

You can disable CPS for a website that is managed by CPS. This can be useful when you need to temporarily prevent users from connecting to the server; for example, when you move the server or perform server maintenance.

When you disable CPS, users who were connected to the website will not be able to connect until you re-enable CPS. Contribute does not remove the administrative settings file for the website when you disable CPS, so roles and permissions are unaffected.

**To disable a CPS website connection:**

1. Publish any open drafts for the website.
   
   You might not be able to access outstanding drafts after you disable the service.

   **Note:** Make sure that users connected to the website also publish any outstanding drafts.

2. Select **Edit > Administer Websites** (Windows) or **Contribute > Administer Websites** (Macintosh), and then select the website you want to administer from the submenu.
   
   The Administer Website dialog box appears.

3. Select **Publishing Server** from the category list on the left.
4. Click the **Disable Publishing Server** button.  
   A confirmation dialog box appears.

5. Click **Yes** to continue.  
   Contribute disables CPS for this website. Contribute does not remove the administrative settings file for the website, so roles and permissions are unaffected. You still have a connection to the website as a non-managed site.

   **Note:** Users who were connected to this website will not be able to connect until you re-enable CPS or send them connection keys with new connection information.

6. Click **Close** to close the Administer Website dialog box.

**Related topics**
- “Enabling Contribute websites to work with CPS” on page 17  
- “Disabling website connections” on page 236  
- “Removing website connections” on page 235

**Disabling the User Directory service for a website**

You can disable the User Directory service for any website that is managed by CPS.  

**Note:** If you need to disable other services, you must use the CPS Console. For more information, see the CPS Console Help.

When you disable the User Directory service, users who were connected to the website will not be able to connect until you send them connection keys with new connection information.

**To disable the User Directory service for a website:**

1. Publish any open drafts for the website.  
   You might not be able to access outstanding drafts after you disable the service.

   **Note:** Make sure that users connected to the website also publish any outstanding drafts.

2. Select **Edit > Administer Websites** (Windows) or **Contribute > Administer Websites** (Macintosh), and then select the website you want to administer from the submenu.
   The Administer Website dialog box appears.

3. Select **Publishing Server** from the category list on the left.

4. Click the **Disable User Directory** button.
   Contribute disables the User Directory service for this website.

   **Note:** Users who were connected to this website will not be able to connect until you send them connection keys with new connection information.

5. Click **Close** to close the Administer Website dialog box.

**Related topics**
- “Enabling CPS to work with your website” on page 213  
- “Disabling CPS for a website” on page 215
Becoming an administrator of an existing Contribute website

When you create a Contribute website connection, you have the option of becoming the administrator of the website you are creating a connection to. If you choose not to become the website administrator when you create the connection, you or another user can become the administrator at a later time.

You can become the website administrator of any website that does not have an administrator associated with it. The website administrator is responsible for setting website permissions and for being a point of contact for users who need assistance.

Note: If someone inadvertently becomes the administrator for a website, or you forget the administrator password, you can reset the password and create a new administrative login. For more information, see "Contribute freezes when sending a connection key" on page 269.

To become the website administrator of a Contribute website:

1. Select Edit > My Connections (Windows) or Contribute > My Connections (Macintosh) to display the My Connections dialog box, which lists all the websites that you have a connection to, as well as the administrator (if any) assigned to each website.

   If a website does not have an administrator associated with it, the text No administrator appears in the Administrator column of the dialog box.

   If a website does not have an administrator, you can become the administrator by completing this procedure.

2. Select the website you want to administer, and click Administer.

3. A dialog box asks whether you want to become the administrator of the website. Click Yes to become the website administrator.

   After this selection, Contribute sets you as the administrator for the site, and the Administer Website dialog box appears. You can optionally set an administrative password for the site.

4. (Optional) Select the Administration category in the Administer Website dialog box.

5. Click Set Administrator Password.

   The Administrator Password dialog box appears.
6. Enter and confirm an administrative password for the website, and click OK.

After you assign an administrative password to the website, the Administer Website dialog box appears, allowing you to configure the website's settings and permission groups.

Related topics
• “Changing the website administrator” on page 219
• “Changing the administrator’s password” on page 220

Configuring Contribute administration settings

The Administer Website dialog box lets you configure a variety of settings that specify how Contribute interacts with your website as well as letting you manage users.

You can set settings that affect the whole website, such as the administrator's contact or password information, the number of rollback versions of pages to save, and filename conventions for website default home pages.

To open the Administer Website dialog box:
1. Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Macintosh), and select the website you want to set options for.
2. If prompted, enter the Administrator password, and then click OK.

Assigning an administrator to a site and assigning a password for the administrative account are optional. For more information, see “Becoming an administrator of an existing Contribute website” on page 217.
The Administer Websites dialog box appears.

3. Select the administrative settings category you want to modify from the list on the left side of the dialog box.

See the following topics for information about using the options in this dialog box:

- “Changing the website administrator” on page 219
- “Changing the administrator’s password” on page 220
- “Enabling and disabling rollbacks” on page 221
- “Specifying new page preferences” on page 221
- “Adding index page filenames” on page 222
- “Removing index page filenames” on page 224
- “Specifying alternate website addresses” on page 224
- “Specifying a guard page” on page 226
- “Enabling compatibility with older versions of Contribute” on page 226

Changing the website administrator

You can change the administrator of a Contribute website by changing the e-mail address associated with the website. Users send e-mail to this address when they need to contact the website administrator for assistance.

Note: Changing the e-mail address of the website administrator does not change the administrator password. If you want to change the administrator password, see “Changing the administrator’s password” on page 220.
To change the administrator e-mail address:

1. Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Macintosh), and select the website you want to administer from the submenu.

2. Do one of the following:
   - If the Administrator Password dialog box appears, enter the administrator password and click OK.
   - If the website has no administrator, click Yes when a dialog box asks whether you want to become the website administrator. Then enter and confirm an administrator password for the website, and click OK.

The Administer Website dialog box appears.

3. Select the Administration category on the left side of the dialog box.

4. Enter a new e-mail address in the Administrator contact e-mail text box.

5. Select another category to modify, or click Close to exit the Administer Website dialog box.

Changing the administrator’s password

You can change the password used by the administrator.

To change the administrator password:

1. Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Macintosh), and select the website you want to administer from the submenu.

2. If prompted, enter the Administrator password, and then click OK.

Assigning an administrator to a site and assigning a password for the administrative account are optional. For more information, see “Becoming an administrator of an existing Contribute website” on page 217.

The Administer Website dialog box appears.

3. Select the Administration category on the left side of the dialog box.

4. Click Change Password in the Administrator Information section of the dialog box.

The Change Administrator Password dialog box appears.

5. Enter your current password and the new password you want to use in the text boxes. You must enter the new password twice to confirm that you are entering it correctly.

6. Click OK.

7. Select another category to modify, or click Close to exit the Administer Website dialog box.
Enabling and disabling rollbacks

Rollback pages are backup versions of each web page published with Contribute. Enable Rollback is on by default. You can disable rollback or change the number of rollback versions. Each rollback page is a copy of the last published version of that page before the currently published version.

For example, if you browse to a page for editing in Contribute, modify the content, and publish your changes without having previously updated and published that page, there is only one rollback version of the page (in this case, the rollback version is the original page).

Contribute can maintain as many as 99 rollback versions of each published page. When you specify the number of rollback pages, carefully consider the amount of disk space that will be consumed by storing the rollback pages. The pages are stored on the web server. The default number of rollback pages is three.

To enable and disable rollback pages:

1. Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Macintosh) and select the website you want to administer from the submenu.

2. If prompted, enter the Administrator password, and then click OK.

Assigning an administrator to a site and assigning a password for the administrative account are optional. For more information, see “Becoming an administrator of an existing Contribute website” on page 217.

The Administer Website dialog box appears.

3. Select the Rollbacks category on the left side of the dialog box.

4. Select Enable rollbacks to activate rollbacks, or deselect it to turn rollbacks off.

5. Enter the number of rollback versions to maintain in the Keep previous versions of each page text box, or use the arrow buttons to change the number. Contribute can maintain as many as 99 rollback versions of each web page.

6. Select another category to modify, or click Close to exit the Administer Website dialog box.

Specifying new page preferences

The New Pages category lets you determine the document encoding that should be used for your web pages as well as the file extension to use when creating new pages from a blank page or templates in a site.

Document encoding specifies the encoding used for characters on a web page. For English and Western European languages, select Western. Additional options include Central European, Cyrillic, Greek, Icelandic, Japanese, Traditional Chinese, Simplified Chinese, and Korean. If an option for the encoding you want is not available, select UTF-8 to create a page using the encoding that your operating system is using.
To specify document encoding for new pages:
1. Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Macintosh), and select the website you want to administer from the submenu.
2. If prompted, enter the Administrator password and click OK.
   Assigning an administrator to a site and assigning a password for the administrative account are optional. For more information, see “Becoming an administrator of an existing Contribute website” on page 217.
   The Administer Website dialog box appears.
3. Select the New Pages category on the left side of the dialog box.
   The New Pages panel appears.
4. Select the document encoding format you want to use from the Default encoding pop-up menu.
5. Select another category to modify, or click Close to exit the Administer Website dialog box.

To specify the default file extension for new pages:
1. Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Macintosh), and select the website you want to administer from the submenu.
2. Do one of the following:
   ■ If the Administrator Password dialog box appears, enter the administrator password, and click OK.
   ■ If the website has no administrator, click Yes when a dialog box asks whether you want to become the website administrator. Then enter and confirm an administrator password for the website, and click OK.
   The Administer Website dialog box appears.
3. Select the New Pages category on the left side of the dialog box.
   The New Pages panel appears.
4. Enter the default file extension you want to use for both new blank pages, and new pages created from templates.
   The default file extension is .htm, but you can specify any file extension appropriate to your website. For example, if your website exclusively uses Macromedia ColdFusion pages, you will want to create new pages with the file extension .cfm.
5. Select another category to modify, or click Close to exit the Administer Website dialog box and save your changes.

Adding index page filenames

You can add new index filenames to your website settings that correspond to your website’s index files.

Note: For more information about index page filenames, see “Web server index pages” on page 208.
To add an index page filename:

1. Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Macintosh), and select the website you want to administer from the submenu.

2. If prompted, enter the Administrator password, and click OK.

Assigning an administrator to a site and assigning a password for the administrative account are optional. For more information, see “Becoming an administrator of an existing Contribute website” on page 217.

The Administer Website dialog box appears.

3. Select the Web Server category on the left side of the dialog box and click the Index Files tab. The Index Files panel appears.

4. Click the Add button.

The Add or Edit Index Filename dialog box appears.

5. Enter an index filename and, click OK.

The new index filename appears at the bottom of the list of possible index filenames.

6. Using the arrow buttons, arrange the index pages in the order specified by your web server’s configuration. For example, if your web server is configured to use three index pages—index.htm, index2.htm, and 404error.htm—and the primary page is index.htm, the designated order is:

   index.htm
   index2.htm
   404error.htm

   This is the order in which the web server retrieves and displays the index pages if one or more of the pages are unavailable.
7. When you have added and ordered the filenames in the Index file list, click Close to exit the Administer Website dialog box and save your changes, or select another category to modify.

**Related topics**
- “Web server index pages” on page 208

**Removing index page filenames**

You can remove index page names from the default list supplied with Contribute. When deleting index page filenames, ensure that your Contribute sites don’t rely on the page names you are removing from the Index files list.

**To remove an index page filename:**
1. Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Macintosh), and select the website you want to administer from the submenu.
2. If prompted, enter the Administrator password, and click OK.
   Assigning an administrator to a site and assigning a password for the administrative account are optional. For more information, see “Becoming an administrator of an existing Contribute website” on page 217.
   The Administer Website dialog box appears.
3. Select the Web Server category on the left side of the dialog box, and click the Index Files tab.
   The Index Files panel appears.
4. Select the filename you want to remove from the Index files list.
   **Note:** You cannot select multiple index files from the list; you must select each file individually and click Remove.
5. Click Remove.
6. When you have removed the filename from the Index file list, click Close to exit the Administer Website dialog box and save your changes, or select another category to modify.

**Related topics**
- “Web server index pages” on page 208
- “Adding index page filenames” on page 222

**Specifying alternate website addresses**

If Contribute users will visit a website using a different host name, different directory path, or different port number, you must configure Contribute to recognize these alternate web addresses and associate them with the appropriate website connection.

**Note:** For more information about alternate web addresses, see “Alternate website addresses” on page 209.

If you don’t configure Contribute in this way, users may try to connect to a website by using a different web address from the one defined in Contribute, which may cause inconsistent or unpredictable behavior when editing or publishing web pages.
You need not configure Contribute to recognize all possible website aliases, but only the ones that Contribute users will actually use to access the website.

To specify an alternate web address for a website:
1. Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Macintosh), and select the website you want to administer from the submenu.
2. If prompted, enter the Administrator password, and click OK.
   Assigning an administrator to a site and assigning a password for the administrative account are optional. For more information, see “Becoming an administrator of an existing Contribute website” on page 217.
   The Administer Website dialog box appears.
3. Select the Web Server category on the left side of the dialog box, and click the Web Address tab.
   The Web Address panel appears.
4. Click the Add button.
   The Add or Edit Alternate Address dialog box appears.
5. Enter an alternate URL, and click OK.
   The new URL appears in the Alternate addresses list.
6. When you have entered all the alternate web addresses, click Close to exit the Administer Website dialog box and save your changes, or select another category to modify.

Related topics
• “Alternate website addresses” on page 209
Specifying a guard page

Guard pages are web pages that Contribute places in folders containing administrative files and temporary copies of pages that have been sent for review. The guard page prevents users from browsing to a Contribute folder containing files that you don’t want them to access.

To specify a guard page for a website:
1. Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Macintosh), and select the website you want to administer from the submenu.
2. If prompted, enter the Administrator password, and click OK.
Assigning an administrator to a site and assigning a password for the administrative account are optional. For more information, see “Becoming an administrator of an existing Contribute website” on page 217.
The Administer Website dialog box appears.
3. Select the Web Server category on the left side of the dialog box, and click the Guard Page tab.
The Guard Page dialog box appears.
4. Click Find Guard Page.
The web page you specified as an index page for the site is set as the guard page. By placing a copy of the website’s index page in a folder, Contribute can redirect users to the home page of the website.
5. When you have specified a guard page, click Close to exit the Administer Website dialog box and save your changes, or select another category to modify.

Related topics
• “Web server index pages” on page 208
• “Adding index page filenames” on page 222

Enabling compatibility with older versions of Contribute

Contribute 3 offers administrators two compatibility options—one that allows users with earlier versions to work on the website, and one that does not:
• Transition Mode
  In this mode, users of earlier versions of Contribute can continue working on the website, along with Contribute 3 users. This enables you to evaluate the new version and set up new roles and permissions without disrupting users with earlier versions of Contribute.
• Compatibility Mode
  In this mode, all users must use Contribute 3. Users with earlier versions cannot work on the website.

Contribute 3 starts in Transition mode by default when you migrate from Contribute 2. You should use this mode temporarily; when you’re ready, transition all users to Contribute 3 and enable Compatibility Mode.
To enable Compatibility Mode:
1. In Contribute 3, select Edit > Administer Websites, and then select a website.
   The Administer Website dialog box appears.
2. Select Compatibility from the category list on the left.
   The Compatibility options appear in the Administer Website dialog box.
3. Select Compatibility, and then click Close.
   Once you enable Compatibility Mode, all users connected to the website must use Contribute 3.

Sending connection keys for websites
Using the Export Connection Wizard (Windows) or Export Connection Assistant (Macintosh), you can easily set up connections to websites for other users by sending them a connection key. For more information about connection keys, see “Connection keys” on page 210.

Note: To send a website connection key to other users, you must create one or more Contribute website connections that you want to share. If you need to create a Contribute website connection, see "Creating a Contribute website connection" on page 211.

If your website is managed by CPS, see "Sending connections for CPS managed sites" on page 229 for information about sending connection keys.
To create a website connection key to share with users:

1. Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Macintosh), and select the website you want to administer from the submenu.

2. Do one of the following:
   If the website has no administrator, click Yes when a dialog box asks whether you want to become the website administrator. Then enter and confirm an administrator password for the website, and click OK.
   The Administer Website dialog box appears.

3. Select the Users and Roles category on the left side of the dialog box.
   The Users and Roles dialog box appears.
4. You can send a connection key file to a new user, or you can send a connection key to a user who has already connected to the site, and assign them a new role.

- To send a connection key to a new user, click **Send Connection Key**.
- To send a connection key to an existing user, assigning them a new role, select the user’s name from the list of connected users, and click **Send Connection Key**.

The Send Connection Key Wizard (Windows) or Export Connection Key Assistant (Macintosh) appears.

5. Follow the instructions in the wizard or assistant, and click **Next** (Windows) or **Continue** (Macintosh) to proceed to the next screen.

6. After completing the wizard or assistant, a new connection key file is created for the user, assigning them to a new role.

   You can e-mail the connection key file to the user or save the file to your computer.

7. Select another category to modify, or click **Close** to exit the Administer Website dialog box and save your changes.

**Related topics**

- “Connection keys” on page 210
- “Creating a Contribute website connection” on page 211

**Sending connections for CPS managed sites**

If you’re using Contribute Publishing Server (CPS) to manage your website, you send users a connection key that connects them to the server. For more information about connection keys, see “Connection keys” on page 210.

**Note:** Before users can use a connection key to connect to a CPS managed website, you must add users to the website. If you haven’t already done so, see “Adding users to websites managed by CPS” on page 230.
If you’re not using CPS to manage your website, see “Sending connection keys for websites” on page 227 for information about sending connection keys.

To send a CPS connection key:
1. Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Macintosh), and select the website you want to administer from the submenu.
   If the website has no administrator, click Yes when a dialog box asks whether you want to become the website administrator. Then enter and confirm an administrator password for the website, and click OK.
   The Administer Website dialog box appears.
2. Click Send Connection Key.
   The Send Connection Key dialog box appears.
3. You can select to e-mail the connection link to the user, or save the file to your local computer.
4. Select another category to modify, or click Close to exit the Administer Website dialog box and save your changes.

Related topics
• “Enabling and Disabling CPS for a website” on page 213

Adding users to websites managed by CPS

The User Directory service of Contribute Publishing Server (CPS) enables you to add users from your organization’s LDAP or Active Directory service.

Note: To add users to sites managed by CPS, you must have enabled CPS to work with your website. For more information on, see “Enabling and Disabling CPS for a website” on page 213.

For websites managed by CPS, you must manually add users to a website’s user list before those users can connect—unlike non-managed websites where anyone with a connection key or connection information can connect to the site.

After you add a user to a website, you can send them a connection key or connection information to connect to the website.

To add users to CPS managed sites:
1. Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Macintosh), and then select the website you want to administer from the submenu.
   If the website has no administrator, click Yes when a dialog box asks whether you want to become the website administrator. Then enter and confirm an administrator password for the website, and click OK.
   The Administer Website dialog box appears.
2. Select the Users and Roles category from the list on the left.
   The Users and Roles panel of the Administer Website dialog box appears.
3. Click **Add Users**.
   The Add Users dialog box appears.

![Add Users dialog box]

4. Select a role for the users you want to add from the **Role for the new users** pop-up menu.
   The role you assign determines the editing permissions the new users have for modifying the site's pages.

5. Use **Search** to find users, and then add them to the role you selected.

6. (Optional) Select **Send connection key e-mail to users** to send an e-mail to the users you’ve added to the role.

   *Tip:* You can also have users type `connect:server domain name` (where `server domain name` is the name of the server where CPS is installed) in the Contribute browser address bar to connect to the website.

   For more information about options in this dialog box, click the Help button in the dialog box.

7. Click **OK**.
   Contribute adds the specified users to the website and generates an e-mail with a connection key attached that you can send to users, if you selected that option.

**Related topics**
- “Enabling and Disabling CPS for a website” on page 213
Removing users from sites managed by CPS

Contribute Publishing Server (CPS) lets you add users to a website from your organization’s LDAP or Active Directory service (see “Adding users to websites managed by CPS” on page 230). You can remove any users that you’ve added so that they will no longer be able to connect to the website.

To remove users from roles of managed sites:
1. Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Macintosh), and then select the website you want to administer from the submenu.
   
   If the website has no administrator, click Yes when a dialog box asks whether you want to become the website administrator. Then enter and confirm an administrator password for the website, and click OK.
   
   The Administer Website dialog box appears.
2. Select the Users and Roles category.
   
   The Users and Roles panel of the Administer Website dialog box appears.
3. Select the name of the user who you want to remove and click Remove.
4. When you are finished removing users, click Close.

Related topics
• “Enabling and Disabling CPS for a website” on page 213
• “Adding users to websites managed by CPS” on page 230

Managing website connections

The My Connections dialog box lets you manage your website connections. Depending on the type of connection—whether it is for a site managed using Contribute Publishing Server (CPS) or not—your connection management options will differ.

For sites managed with CPS, you can either disable connections of individual sites, or you can remove CPS and any sites associated with it. You cannot rename a site connection if the site is managed with CPS.
To manage website connections:

1. Select Edit > My Connections (Windows) or Contribute > My Connections (Macintosh).
   - The My Connections dialog box appears.

2. Select a website from the list of connections.

3. Manage connections by doing any of the following:
   - “Editing website connections” on page 233
     - If you used the Connection Wizard or Assistant to create a connection, you can update the connection information when server or network configurations are altered (for example, changing network paths or a website’s URL).
     - **Note:** If you import a connection key, the only pieces of connection information you can edit are your name and your e-mail address.
   - “Renaming a website connection” on page 234
     - You can rename a website connection within Contribute to better identify it from other website connections you might maintain.
   - “Removing website connections” on page 235
     - You can delete an obsolete website connection from Contribute.
   - “Disabling website connections” on page 236
     - You can disable website connections so that Contribute does not connect to the website if it is not accessible or if it is being edited. Disabling websites can improve the performance of Contribute by reducing the number of active connections the application maintains.
   - “Enabling a website connection” on page 237
     - You can enable a website you have previously disabled.

4. Click Close when you are finished.

**Editing website connections**

You can edit the connection information for any opt-in Contribute website. This allows you to modify a connection if any of its parameters change (for example, if you move a website to a different network location or change its URL).

**Note:** If you import a connection key, the only connection information you can edit is your name and your e-mail address.
**Tip:** If you have drafts open, you can’t change your name or e-mail address for the website belonging to those drafts. To change that information, first close the open drafts.

**To edit a website connection:**
1. Select **Edit > My Connections** (Windows) or **Contribute > My Connections** (Macintosh).
   The My Connections dialog box appears.
2. Select a website from the list of connections.
3. Click the **Edit** button.
   The Connection Wizard or Assistant appears.
4. Navigate through the Connection Wizard or Assistant using the **Next** or **Continue** button, and modify the necessary website connections settings.
   For more information on the Connection Wizard or Assistant website settings, see “Creating a Contribute website connection” on page 211.
5. When you have modified the necessary connection settings and verified that they are correct, you will need to send a connection file to users containing the new connection setting information.

**Related topics**
- “Removing website connections” on page 235
- “Disabling website connections” on page 236
- “Enabling a website connection” on page 237

**Renaming a website connection**

You can rename a website as it appears in Contribute. The name you select appears in the Home Pages menu, the My Connections dialog box, and the Administer Websites submenu.

**Note:** You cannot rename a website connection for a site managed with CPS. Website names come from the title of the site’s home page. To ensure that sites are easily identifiable, give the home page a meaningful name.

**To rename a website as it appears in Contribute:**
1. Select **Edit > My Connections** (Windows) or **Contribute > My Connections** (Macintosh).
   The My Connections dialog box appears.
2. Select the website connection you want to edit from the list of connections.
3. Click the **Rename** button.
   The website connection name is highlighted by an editing box.
4. Click inside the editing box and enter a new name for the website connection.
5. Press **Enter** or **Return** to apply your changes.
6. Click **Close** to save your changes and close the My Connections dialog box.
Removing website connections

You can remove Contribute website connections that are no longer needed. Removing a Contribute connection does not remove the website itself; it removes only the website connection information from your local computer.

The process is slightly different, depending on whether the website uses CPS or not.

**Tip:** For information about removing unpublished drafts from a disabled website, see “Removing unpublished drafts in a disabled website” on page 237.

**To remove a website connection:**
1. Close any open drafts for the website you are removing.
   Contribute does not remove a connection to a website in which you’re editing pages.
2. Select Edit > My Connections (Windows) or Contribute > My Connections (Macintosh).
   The My Connections dialog box appears.
3. Select a website from the list of connections.
4. Click Remove.
   Contribute removes the website connection from the My Connections dialog box.

**To remove a website connection for a website managed by CPS:**
1. Close any open drafts for the website you are removing.
   Contribute does not remove a connection to a website in which you’re editing pages.
2. Select Edit > My Connections (Windows) or Contribute > My Connections (Macintosh).
   The My Connections dialog box appears.
3. Select a website from the list of connections.
4. Click Administer.
   The Administer Website dialog box appears.
5. Select Administration from the category list on the left.
6. Click Remove Administration button.
   A confirmation dialog box appears.
7. Click Yes to continue.

Contribute removes the connection information and administrative settings file (including user roles and website permissions) associated with this website. Users who were connected to this website will not be able to connect.

**Tip:** If users need to connect to this website, you need to create a new connection and recreate roles and reset permissions. Then, send connection keys with new connection information to users.

8. Click Close to close the Administer Website dialog box.

In the My Connections dialog box, the website connection no longer appears in your list of connections.

**Note:** Contribute also removes the website connection should from the Websites list in the CPS Console. The next time you log in to the console, the website will not be in your list. If the website still appears in the list, click the Delete button in the console to remove the website.

9. Click Close to close the My Connections dialog box.

**Related topics**
- “Editing website connections” on page 233
- “Renaming a website connection” on page 234
- “Enabling a website connection” on page 237

**Disabling website connections**

When Contribute starts, it verifies all the connections defined in the My Connections dialog box and opens a connection to each of the defined websites. If one or more of the websites are unavailable for any reason, Contribute can't open connections to those websites. To avoid such problems, you can disable a connection when a website is unavailable.

**Note:** If Contribute cannot connect to a website, Contribute may automatically disable the connection to that website.

Another reason to disable a site is that Contribute may run slowly when many sites are defined because it must maintain multiple network connections over an extended period. To alleviate such performance problems, you can disable sites that you don't frequently need to update or disable all site connections and enable them only when you need to edit the site.

Disabling a website connection works the same for websites managed by CPS as it does for non-managed websites. Disabling a connection affects only your connection to the website.

**Tip:** For a CPS managed website, you can disable the connection for every user connected to that website. For example, suppose you need to move the server running CPS. Then you can disable CPS for that connection and users will not be able to connect. For more information, see “Disabling CPS for a website” on page 215.
To disable individual Contribute website connections:
1. Select Edit > My Connections (Windows) or Contribute > My Connections (Macintosh).
   The My Connections dialog box appears.
2. Select the website connection you want to disable from the list of connections.
3. Click the Disable button.
   A dialog box appears, informing you that the connection has been disabled. Click OK to verify that this is the connection you want to disable. If you have inadvertently disabled the wrong connection, you can re-enable the connection; for more information, see “Enabling a website connection” on page 237.
4. Click Close to save your changes and close the My Connections dialog box.

To disable all Contribute website connections:
1. Select Edit > My Connections (Windows) or Contribute > My Connections (Macintosh).
   The My Connections dialog box appears.
2. Click the Disable sites when Contribute starts up checkbox.
3. Click Close to save your changes and close the My Connections dialog box.
   When you restart Contribute, all connections defined in the My Connections dialog box will be disabled. When you select a website for editing, Contribute tells you that the connection to the site is disabled. To enable the connection, click Connect in the toolbar.

Related topics
- “Editing website connections” on page 233
- “Renaming a website connection” on page 234
- “Removing website connections” on page 235
- “Enabling a website connection” on page 237

Removing unpublished drafts in a disabled website
When you use the My Connections dialog box to remove a connection to a website that contains unpublished drafts, Contribute warns you that it will delete the connection and move any unpublished drafts to the Recycle Bin or Trash.

If you want to recover the unpublished drafts, in most cases you can locate them in the Recycle Bin or Trash. Contribute saves the drafts in a folder named for the removed website in the Recycle Bin or Trash.

Enabling a website connection
If you disable a website connection, or if Contribute automatically disables it because it can’t connect to the website, you can re-enable it later.

To enable the current website connection:
• Click Connect in the toolbar.
To enable any website connection:
1. Select Edit > My Connections (Windows) or Contribute > My Connections (Macintosh).
   The My Connections dialog box appears.
2. Select the website connection you want to enable from the list of connections. (Disabled connections are marked with a red slash.)
3. Click the Enable button.
4. Click Close to save your changes and close the My Connections dialog box.

Related topics
• “Editing website connections” on page 233
• “Renaming a website connection” on page 234
• “Removing website connections” on page 235
• “Disabling website connections” on page 236
• Disabling your website at startup
Macromedia Contribute lets you control the extent to which users can alter a website. To do so, you create roles for each website and define permissions for each role. After a website’s permissions are defined, Contribute creates a folder labeled _mm at the root of the website and places a shared settings file in this folder. The shared settings file contains all the website settings and permissions for Contribute website connections that you create. All Contribute users who connect to the website automatically inherit the settings defined for their assigned role.

This chapter contains the following sections:

- “Understanding roles” on page 239
- “Creating Contribute roles” on page 241
- “Editing a role’s settings” on page 243
- “Managing drafts sent for review” on page 258

Understanding roles

Contribute lets you define a set of user permissions, ranging from file access to the level of typographic control, as a role. You assign the roles you create to Contribute users, which determines the degree to which a specific user can modify a site’s content.

Contribute has three default roles that you can assign to users “as-is,” or modify further to meet the content editing needs of your website. The default Contribute roles are:

**Administrator**  Users with this role are administrators of this website.

**Publisher**  Users with this role can create and edit pages as well as publish pages to the website.

**Writer**  Users with this role can create and edit pages but cannot publish pages to the website. To publish new pages or page modifications to a site, users in this role must send their updates to a user in the publisher role for review. The publisher can then choose to publish the page to the site or send it back to the writer for additional editing.

In most cases you can use the default settings specified for these roles. However, if your website has certain design features that need to be preserved, you can configure Contribute to work with those design considerations.
If you are not familiar with such web page design elements as font and paragraph usage, Cascading Style Sheets (CSS) styles, and image file formats and size limitations, consult a web page designer or other web professional who is knowledgeable about your organization's website.

**About role settings**

Contribute lets you define the following categories of permissions and website settings in the Role dialog box:

- **General** lets you select a starting (home) page that users in the selected role see when they enter the website. For more information, see "Setting general role settings" on page 245.

- **Folder/File Access** limits a role's access to the selected folder (or folders) and any subfolders they contain. For more information, see “Setting folder and file access settings” on page 247.

- **Editing** lets you specify what content users can modify and determine how Contribute processes paragraphs, line spacing, and accessibility options. For more information, see “Setting page-editing and paragraph settings” on page 249.

- **Styles and Fonts** specifies which font sets users have access to, and which users can apply style and formatting to text. For more information, see “Setting style and font settings” on page 251.

- **New Pages** specifies whether Contribute users can create new, blank pages, and which (if any) Macromedia Dreamweaver MX templates they can use to create new pages. You can also specify which pages, if any, the user can copy. The options in this category determine what options users see in the New Page dialog box. For more information, see “Settings for new web pages” on page 252.

- **New Images** lets you specify a maximum file size, width, and height for images. You can also restrict users so that they can use images only from a shared asset library that you create, or you can allow them to add any image to a web page. For more information, see “Setting options for new images” on page 253.

- **File Placement** lets you specify folder locations for files based on the file extension used to identify the file type. You can also specify that Contribute not allow files of a certain size to be uploaded to the web server. For more information, see “Setting options for file placement” on page 254.

- **Shared Assets** lets you create a library of assets (such as images, Macromedia Flash content, or Macromedia Dreamweaver library items) that users can add to web pages. You can restrict access to shared assets to specific users or let any Contribute user accessing the website add the assets to their pages. For more information, see “Setting options for shared assets” on page 255.

**Related topics**

- “Editing a role’s settings” on page 243
Creating Contribute roles

When Contribute users connect to a website, they are prompted to indicate which role they belong to. For example, a Contribute user might choose or be assigned to the Writer role. Thereafter, while connected to that website, that user has whatever permissions you have configured for the Writer role.

To create a new role:
1. Select **Edit > Administer Websites** (Windows) or **Contribute > Administer Websites** (Macintosh), and then select the website you want to administer from the submenu.

   If the website has no administrator, click **Yes** when a dialog box asks whether you want to become the website administrator. Then enter and confirm an administrator password for the website, and click **OK**.

   The **Administer Website** dialog box appears.

2. Select **Users and Roles**.

   By default, Contribute creates three roles: Administrator, Publisher, and Writer.
3. Click **Create New Role**.
   The Create New Role dialog box appears.

![Create New Role](image)

4. Select an existing role from the **Create new role from copy of** list box.
   Selecting an existing role as a base for a new role lets you reuse the selected role's settings. You can modify the new role's settings as needed.

5. Enter a name for the role you want to create, and then click **OK**.
   The new role appears in the list of role names in the User and Roles panel of the Administer Website dialog box.

6. Select the role name, and then click **Edit Role Settings**.
   The Edit Role dialog box appears. The Edit Role dialog box lets you modify the user settings associated with each role.

7. Modify the settings for the role.
   When you are finished defining the role, click **OK** to save your changes. The Role dialog box will close, returning you to the Administer Website dialog box.

8. To create additional roles, repeat steps 4 through 7 for each role you want to add.

9. Select another administrative category to modify, or click **Close** to apply your changes and exit the Administer Website dialog box.

**Note:** You can modify a role’s settings at any time, even after you have distributed a connection key. Connection information and website permissions are maintained separately.

- To modify the roles you have created, select the role whose settings you want to modify and click **Edit Role Settings**. The Role dialog box appears. To learn more about the settings you can modify, see “Editing a role’s settings” on page 243.

- To send the connection to the users that make up the role, click **Send Connection Key**. The Export Connection Wizard appears. To learn how to export a connection key, see “Sending connection keys for websites”.

If you want to edit the role now, skip to step 4 of the next procedure. Otherwise, click **Close** to close the Define Roles dialog box, and then click **Close** to close the Administer Website dialog box.
Editing a role’s settings

The Role Settings dialog box lets you define different home pages for users based on the role they belong to, limit roles to working in specific folders, and determine the modifications a role can make to a website.

*Note:* For information about creating new roles, see "Creating Contribute roles" on page 241.

To edit settings for a Contribute role:

1. Select **Edit > Administer Websites** (Windows) or **Contribute > Administer Websites** (Macintosh), and then select the website you want to administer from the submenu.
   
   If the Administrator Password dialog box appears, enter the administrator password and click **OK**.
   
   The Administer Website dialog box appears.

2. Select **Users and Roles**.

   The User and Roles category of the Administer Website dialog box lets you see what roles already exist, add users to roles, edit and remove roles, and send connection key files to users assigning them a role.
3. Select the role whose settings you want to modify, and then click **Edit Role Settings**. The **Edit Role Name Settings** dialog box appears. The **Edit Role Name Settings** dialog box lets you modify the settings associated with each role.

4. Select a settings category to modify.

For more information about the role settings you can modify in a specific category, see the following sections:

- “Setting general role settings” on page 245
- “Setting folder and file access settings” on page 247
- “Setting page-editing and paragraph settings” on page 249
- “Setting style and font settings” on page 251
- “Settings for new web pages” on page 252
- “Setting options for file placement” on page 254
- “Setting options for shared assets” on page 255
- “Setting options for new images” on page 253
5. Modify the settings for the role.
   When you finish defining the role, click OK to save your changes. The Role dialog box will close, returning you to the Administer Website dialog box.

6. Select another administrative category to modify, or click Close to apply your changes and exit the Administer Website dialog box.

Related topics
• “Understanding roles” on page 239

Setting general role settings

The General category lets you specify a starting (home) page that users in the selected role see when they enter the website. For example, if users in a given role are assigned to a section of the site that excludes the site's home (or main) page, you might consider specifying a page elsewhere in the site as the starting page for that role.

To set general website settings for a role:
1. Open the Edit Role Name Setting dialog box, if it’s not already open. (See “Editing a role’s settings” on page 243.)
2. Click the General category on the left side of the dialog box.
3. (Optional) Select **Allow users to publish files**.

If you select this option, users assigned to this role can publish pages they create. They can also publish or delete drafts sent to them for review.

Providing publish and delete restrictions for draft reviews lets users delete and publish drafts sent to them by other Contribute users. Before allowing a user to publish and delete drafts, carefully consider if their assigned role should be given this level of control in the publishing of documents. You might need to create a specific role with this permission enabled.

Users without draft publishing and deleting permissions can only send drafts for review or edit drafts in the review process. For more information about the draft review process, see "Getting drafts and files reviewed by others" on page 42.

4. In the **Role description** text box, enter a brief description of the role and its responsibilities.

   This description appears when a user selects a role to join.

5. When you initially defined the website, you specified the website’s home page. If you want users in the selected role to have a more specific home page within the website, enter the URL in the **Home page for users in this role** text box, or click the Choose button to locate the home page.

   You can choose to specify any page on the website as the home page for the specified role.

6. Select another role settings category to modify, or click OK to apply your changes.
Setting folder and file access settings

The Folder/File Access settings category lets you limit a role's access to selected folders (or directories) and to any subfolders they contain as well as determine whether users can delete web pages and related files.

Setting folder access settings

You can choose to limit user access to specific folders within the website or to allow users to access all the folders within the defined website.

To define folder access settings:

1. Open the Edit Role Name Settings dialog box, if it’s not already open. (See “Editing a role’s settings” on page 243.)
2. Click the Folder/File Access category on the left side of the dialog box.
3. Select Allow users to edit files in any folder to let users access all folders and files within the website’s root, or select Only allow editing within these folders to limit access to a specific subfolder or group of subfolders.
4. If you’ve selected Only allow editing within these folders, specify folders by clicking Add Folder.

The Choose Folder dialog box appears.

5. The Choose Folder dialog box displays all folders and files under the website’s root.

You can preview pages in the website by selecting them. This lets you see which pages you are restricting access to.

6. Navigate to the folder you want to provide access to, and click Select Folder.

For example, if the website’s root is http://www.mysite.com and you want to specify that users can edit only those pages that are in the folder labeled marketing, click the marketing folder. The access path will appear as: http://www.mysite.com/marketing.

The Choose Folder dialog box closes, and the selected folder appears in the Folder access list.

You can add folders to the Folder access list to give users access to multiple directories in the website.

7. Click OK.

When the next Contribute user connects to this website, they will be able to edit only those pages and files that are inside the listed folders.

To change access to a folder in the list, do one of the following:

- To remove a folder from access, select the folder in the folder list, and then click Remove.
- To change a folder the user can access, select the folder in the folder list, and then click Edit.
Setting file-deletion settings

You can allow users to delete pages from the web server. When determining whether users should be able to remove a page from the website, carefully consider whether you want to maintain a backup copy of deleted pages.

If you do want to maintain backup copies, you must make sure that the Contribute rollback feature is enabled. To learn more about web page rollbacks, see “Enabling and disabling rollbacks” on page 221.

To let users delete files from the web server:
1. Open the Edit Role Name Settings dialog box, if it’s not already open. (See “Editing a role’s settings” on page 243.)
2. Click the Folder/File Access category on the left side of the dialog box.
3. Select Allow users to delete files they have permission to edit.
4. You can also choose to remove any rollback files associated with a page by selecting Remove rollback versions on delete. Carefully consider whether you want to maintain backup copies of web pages before allowing users to delete both an active web page and any rollbacks versions of that page.
5. Select another settings category to modify, or click OK to apply your changes.

Tip: If a user deletes a file, but not the rollback copies of the file, the file can be recovered from the rollback copy. For more information, see “Rolling back to a previous version of a page” on page 160.

Related topics
• “Setting folder access settings” on page 247

Setting page-editing and paragraph settings

The Editing category lets you specify what kinds of changes users can make to the website’s web pages and how Contribute treats paragraphs and typographic elements.
To set page-editing settings:

1. Open the Edit Role Name Settings dialog box, if it’s not already open. (See “Editing a role’s settings” on page 243.)

2. Click the Editing category on the left side of the dialog box.
   The Editing category provides options that let you specify which page-editing attributes Contribute will apply. When setting these options, carefully consider who the content contributors are and what page-editing capabilities they require.

3. Change options in the following sections as necessary:
   - **The General editing restrictions** section lets you specify what kinds of changes users can make to pages.
   - **The Paragraph spacing** section lets you specify how Contribute applies HTML paragraph tags, which determines whether blank lines appear between paragraphs as a user types.
   - **The Other editing options** section gives you more editing options.
     For more information about options in this dialog box, click the Help button in the dialog box.

4. Select another role settings category to modify, or click OK to apply your changes.
Setting style and font settings

The Styles and Fonts category in the Role dialog box lets you control whether typographic styles and fonts appear in the Contribute toolbar and which kinds of typographical styles users can apply to text.

To set the style and font settings for a website:

1. Open the Edit Role Name Settings dialog box, if it’s not already open. (See “Editing a role’s settings” on page 243.)

2. Click the Styles and Fonts category on the left side of the dialog box.

3. Select a style setting from the Style support pop-up menu. The style and font options vary based on what option you select from the pop-up menu.

   The Style Support options are:
   
   **Don’t allow users to create styles** prevents users from creating new styles. Users cannot modify any text and style formatting options.

   **Document-level CSS** lets you determine whether users can create CSS styles within the document and to what degree they can apply CSS styles from existing CSS style sheets.

   **HTML tags** lets you determine whether users can create HTML styles, and to what degree they can modify and apply styles within the website.
4. Modify the style settings for your chosen style support option as necessary. For more information about options in this dialog box, click the Help button in the dialog box.

5. Select another role settings category to modify, or click OK to apply your changes.

Limiting available CSS styles

Although CSS style sheets often include many style definitions, you may want to limit the number of styles available to a given Contribute user role. Limiting available styles to those necessary for updating information within the body of a web page can help to eliminate potential stylistic editing mistakes by content editors with limited knowledge of web pages and CSS styles. Contribute lets you limit the number of CSS styles available in the Style menu by selecting a CSS style sheet from which to filter styles for a given role. The filter file you select can include only those styles you want the members of that role to have access to, or you can create individual CSS style sheets for each role, and select them as the CSS styles to use for that role.

To limit the number of available CSS styles:

1. Open the Edit Role Name Settings dialog box, if it’s not already open. (See “Editing a role’s settings” on page 243.)

2. Click the Styles and Fonts category on the left side of the dialog box.

3. From the Style support pop-up menu, select Document-level CSS.

4. Select the following options:
   - Allow users to apply styles
   - Include CSS styles in the Style menu
   - Show only CSS styles included in the CSS file

5. Click Choose.
   The Choose File on Website dialog box shows all folders and files under the website’s root.

6. Navigate to the CSS style sheet whose styles you want to let users access from the Styles menu.

7. Select the CSS style sheet, and then click OK.

8. Select another role settings category to modify, or click OK to apply your changes.

Settings for new web pages

The New Pages category in the Edit Role Name Settings dialog box lets you specify whether users can create new, blank pages or create duplicate pages by copying the current page. You can also define which Dreamweaver templates users are able to see and use.
To set the new pages options for a website:

1. Open the Edit Role Name Settings dialog box, if it’s not already open. (See “Editing a role’s settings” on page 243.)

2. Click the New Pages category on the left side of the dialog box.

3. Change options as necessary.
   Contribute lets you control the types of new pages that users can create, and it lets you specify templates for creating new pages.
   When specifying the new page types that users are able to create, carefully consider the look and feel of the website. In many cases, it may be best to constrain users either to use copies of existing pages or to use only Dreamweaver templates, if they are available.
   For more information about options in this dialog box, click the Help button in the dialog box.

4. Select another role settings category to modify, or click OK to apply your changes.

Setting options for new images

You can use the New Images category of the Role dialog box to specify whether users can import images, specify whether users can edit images, limit the maximum file size of an image a user can add to a page, and reduce images larger than a size you specify.
To set the new images options for a website:

1. Open the Edit Role Name Settings dialog box, if it’s not already open. (See “Editing a role’s settings” on page 243.)

2. Click the New Images category on the left side of the dialog box.

3. Specify the options Contribute will use to restrict the adding of images to a page.
   For more information about options in this dialog box, click the Help button in the dialog box.

4. Select another role settings category to modify, or click OK to apply your changes.

Setting options for file placement

Contribute lets you specify what folders into which you can copy different file types. The file types include images, linked documents (such as Microsoft Office documents and Adobe Acrobat PDF files), and Macromedia Flash content. By default, Contribute places these files relative to the web page that they are linked to.
To set the file placement options for a website:

1. Open the Edit Role Name Settings dialog box, if it’s not already open. (See “Editing a role’s settings” on page 243.)
2. Click the File Placement category on the left side of the dialog box.
3. Specify the rules Contribute will use to place files as necessary.
   For more information about options in this dialog box, click the Help button in the dialog box.
4. Select another role settings category to modify, or click OK to apply your changes.

**Setting options for shared assets**

Contribute lets users add images, Macromedia Flash content, or Macromedia Dreamweaver library items to your website from a list of shared assets. The website administrator can make shared assets available to users by adding assets to the list so that they are available to most or all users. Then users can simply insert assets from the list as they need them.
For more information, see “Inserting shared assets into a web page” on page 96.

You can modify your Shared Assets list as follows:

- **Add image files, Flash content, and Dreamweaver library items to your list of shared assets.**
  The assets you add to your Shared Assets list must already be on the server; Contribute does not upload the files for you. You can use Contribute to browse to files and then add them to a central list for users.

- **Remove shared assets from your list.**
  You can remove shared assets from individual lists for specific roles or from one list that applies to the entire website.

- **Change shared asset properties.**
  Properties include the name used to refer to the asset, alternate text for images, and the editing attribute for Dreamweaver Library items.

You create one Shared Assets list for all roles in your website, or you customize these lists for each role.

**Tip:** If different roles are restricted to different shared assets, it’s a good idea to add all shared assets for the website at once and then modify the list for each role. It’s more efficient to add the shared assets once and delete as necessary than to add the same assets several times.
To add shared assets, delete shared assets, or modify shared asset properties for an entire website or for a specific role:

1. Open the Edit Role Name Settings dialog box, if it’s not already open. (See “Editing a role’s settings” on page 243.)
   
   *Note:* If you’re making changes that apply to all roles associated with the website, it doesn’t matter which role you select.

2. Select Shared Assets from the list on the left.
   
   The Shared Assets settings appear.

   *Tip:* If you already have shared assets in your list, they are sorted by type alphabetically. To view the list alphabetically, click the Name heading at the top of that column.

3. Do one of the following:
   
   - To add a shared asset, click the Add button, and then select Image, Library Item, or Flash.
     
     *Tip:* You can Shift-click to select multiple assets.
   
   - To delete a shared asset, select an asset in the pane, and then click the Remove button.
   
   - To view or change shared asset properties, select an asset in the pane, and then click the Edit button.

4. Do one of the following:
   
   - If you want your changes to apply to all roles associated with the website, make sure Use this list for all roles is selected.
   
   - If you want your changes to apply to the role you selected in the Define Roles dialog box only, deselect Use this list for all roles.

   *Note:* This option applies to the entire list of shared assets showing in the pane. It is not specific to any shared assets that might be selected in the pane.

   For more information about options in this dialog box, click the Help button in the dialog box.

5. Click OK.
Managing drafts sent for review

As an administrator, you can view and change the status of drafts that are currently in the draft review process for your website. You can change owners for a draft that has been sent for review, and you can also remove any draft from the draft review process.

*Note:* For more information about the draft review process, see "Understanding the draft review process" on page 37.

To view drafts in the drafts review process:
1. Select **Edit > Administer Websites > Manage Sent Drafts.**
   The Manage Sent Drafts dialog box appears.
2. Do any of the following:
   - To view a draft, select the draft, and then click **View Draft.**
   - To transfer ownership of a draft to another person, select the draft, and then click **Change Owner.**
   - To remove a draft from the draft review process, select the draft, and then click **Undo Checkout.**
   For more information about options in this dialog box, click the Help button in the dialog box.
3. Click **Close** when you are finished.
This chapter documents common problems that you may encounter as a Macromedia Contribute user and provides potential solutions.

This chapter contains the following sections:

- “Problems installing Contribute” on page 259
- “Problems starting Contribute” on page 260
- “Problems creating a connection” on page 261
- “Problems editing a page” on page 263
- “Problems canceling pages” on page 265
- “Problems sending reviews using e-mail” on page 266
- “Problems publishing a page” on page 266
- “Problems creating new documents from templates” on page 267
- “Problems administering Contribute” on page 267
- “Using Contribute with dynamic pages” on page 272

Problems installing Contribute

Contribute is designed to function properly when it is installed on the Windows platform. The following common errors can cause problems when installing the Contribute software:

- Entering an invalid serial number
- Entering the serial number incorrectly
- Installing Contribute on a system that has restricted user permissions

If you encounter problems installing Contribute, verify that you are entering a valid and correct product activation serial number and that the system on which you are installing the software has proper network and disk access for your user account.
Problems starting Contribute

The following sections describe problems you might encounter when starting Contribute:

- “Startup is slow or the application appears to freeze” on page 260
- “The Connection Failure dialog box appears when Contribute is connected to the network” on page 260
- “Contribute doesn't detect that it is disconnected from the network” on page 260
- “The Dial-up dialog box appears when Contribute is connected to the network” on page 261
- “Contribute reports that the user is not in a valid role” on page 261

Startup is slow or the application appears to freeze

When you start Contribute, it opens a connection to each website defined in the My Connections dialog box. If you have many Contribute websites defined, the application may be slow and unresponsive at first. To alleviate this problem, consider disabling websites that you don't update on a frequent basis. You can easily enable websites when you need to update them.

For more information, see the following sections:

- “Disabling website connections” on page 236
- “Enabling a website connection” on page 237
- “Improving application performance by disabling websites” on page 270

The Connection Failure dialog box appears when Contribute is connected to the network

Occasionally, the Connection Failure dialog box appears even though you have an active network connection. This sometimes occurs when Contribute is installed on a computer with other applications that regularly access the network.

Click OK to close the Connection Failure dialog box. If the Connection Failure dialog box continues to appear, verify that your computer is indeed connected to the network, or, if you are using a dial-up connection, that you have successfully established a dial-up connection.

Contribute doesn't detect that it is disconnected from the network

In some instances, Contribute may be unaware that the network connection is either disconnected or otherwise unavailable. If this occurs, Contribute attempts to connect to the first of your website connections. If it fails and there are more websites to connect to, Contribute displays a dialog box that asks whether you want to continue trying to connect to your remaining websites. If you click Yes, Contribute displays the same dialog for each website (provided you click Yes each time). If you click No, Contribute disables the remaining websites.

Even if you click Yes, Contribute disables the website if it is unable to connect to it. When this occurs, Contribute does not display the Working Offline page, but instead lists each website as disabled. If you want to work offline, select File > Work Offline (Windows) or Contribute > Work Offline (Macintosh). If you want to connect to your websites, verify that your computer is connected to the network and that the network is operational.
The Dial-up dialog box appears when Contribute is connected to the network

By default, the Microsoft Internet Explorer web browser is configured to automatically dial a network connection if a connection is not present. In some instances, when Contribute is started, this can cause Contribute to attempt to dial the network connection.

To prevent this from occurring, you can update the Internet Explorer connection settings to never dial up a network connection.

To disable dial-up networking in Internet Explorer:
1. Start Internet Explorer if it is not already running.
2. Select Tools > Internet Options.
   The Internet Options dialog box appears.
3. Click the Connections tab.
4. Select either Never dial a connection or Dial whenever a network connection is not present under Dial-up settings.
5. Click Apply.
6. Click OK.

Contribute reports that the user is not in a valid role

If the user's role is deleted or changed by the administrator, or if the user created the connection, he or she can start the Connection Wizard (Windows) or Connection Assistant (Macintosh) to create a new connection, and then select a valid role. If the user imported a changed connection key, the administrator can send the user a new connection key containing a valid role to import.

For more information, see “Sending connection keys for websites” on page 227.

Problems creating a connection

The following sections describe problems you may encounter when creating a connection with Contribute:

• “Can't view the My Connections dialog box” on page 261
• “Can't move to the next screen in the Connection Wizard” on page 262
• “Connection Wizard can't locate the remote folder” on page 262
• “LAN connection can't locate the remote folder” on page 262
• “FTP dialog box fails to accept your user name and password” on page 263

Can’t view the My Connections dialog box

If you cannot view the My Connections dialog box, or edit your connections, Contribute may be in offline mode. Click the Work Online button to connect to your server.
Can’t move to the next screen in the Connection Wizard

If you cannot navigate to the next screen of the Connection Wizard (Windows) or Connection Assistant (Macintosh), you may have entered the connection information incorrectly. Verify that you have entered the correct website address, server name, user name, password, and network path. If these items are correct, verify that the website is online using your computer’s web browser.

Connection Wizard can’t locate the remote folder

When you enter FTP or SFTP connection information into Contribute, the Connection Wizard verifies that the FTP folder is the same folder that contains your website’s files. If these folder paths don’t match, Contribute cannot write to the page displayed by your browser. For this reason, your FTP folder must have proper read/write access.

On UNIX servers, such as Apache, public-read bit is set for files and public-execute bit is set for web directories.

To ensure that the website and FTP folder are the same, Contribute uploads a temporary file using the FTP host information you provide. The Connection Wizard uses the website’s address to “guess” the FTP path. Contribute then attempts to read the temporary file through HTTP using the web address you provided. If Contribute succeeds in locating the temporary file, the paths match, and the Connection Wizard creates the connection.

If the paths don’t match, the Connection Wizard prompts you for the correct FTP path, because Contribute was unable to guess the path.

To ensure that you are entering the correct FTP path, use the Connection Wizard’s Browse button to locate and select the FTP folder. If the path to the folder is correct, ensure that the folder has the proper read/write permissions for the user. If you are creating an anonymous FTP account, the server must be configured to support delete, rename, and overwrite privileges for the anonymous user.

To learn how to check your server’s FTP and folder permissions, refer to the documentation supplied with your server operating system.

If you want to give specific permission groups access to subfolders of a read-only FTP root, you can do one of the following:

• Write-enable the root folder.

• Create a unique connection for each subfolder in the root folder, and write-enable these subfolders.

LAN connection can’t locate the remote folder

If the local area network (LAN) can’t locate the remote folder containing your web pages, consider the following solutions:

• The remote folder must be set to shared to be visible to the network and any clients attempting to connect to it.

• The folder must have proper read, write, delete, overwrite, and change permissions.
To check whether a folder is visible to your local area network:

1. Select Start > Run from the Windows Start menu.
   The Run dialog box appears.
2. Enter the network path to the folder in the Open text box, and click OK.
   For example, enter \MyServer\MyFolder.
3. Verify that the folder is visible to the network and that you have proper file access permissions.

FTP dialog box fails to accept your user name and password

Ensure that you are entering the correct user name and password for the specified FTP or SFTP server. The FTP user name and password may be different from your computer’s login information.

Note: If you enter a user name and password many times without successfully logging in to the server, the FTP server may be configured to reject all future attempts. If this appears to be the case, you may need to exit the application and attempt to log in again or contact your administrator to unlock the account if it has been locked.

Problems editing a page

The following sections describe problems you may encounter when editing a page:

• “Edit Page button is not visible” on page 263
• “Edit button is disabled” on page 264
• “Clicking the Edit button displays an error message” on page 264
• “Clicking Edit Page displays a different page” on page 265

Edit Page button is not visible

If the Edit Page button is not visible for a page you browse to, ensure that you have a connection to that website, and that you have permission to edit the displayed page. For more information, see the following sections:

• “Creating a Contribute website connection” on page 211
• “Setting folder and file access settings” on page 247

If the website has alternate web addresses (for example, you are browsing to the page using an IP address instead of the website’s DNS name), you may need to configure Contribute to recognize these addresses. For more information, see “Specifying alternate website addresses” on page 224.
You might be experiencing a network or server abnormality. Try refreshing the page or using the Back and Forward buttons to navigate to the page a second time.

**Edit button is disabled**

There are several reasons why the Edit button may be disabled for a certain page:

- When you browse to a page, Contribute checks whether you have permission to edit that page in the website. Depending on network traffic and server response, this can take a few moments (during this time, the Edit Page button is dimmed).
- The page may be locked for editing by another user. Contribute should display a message that the file is locked and provide the contact information for the user who is editing the file. In some instances, you may need to remove a lock file to allow access to the page. For more information, see “You need to override a file checkout” on page 271.
- The user may not have write permission to either the server, the folder containing the web page, or the page. To learn how to check the server's folder permissions, see the documentation supplied with the server operating system.
- The specified URL may point to a directory listing, and not to a specific page. Click a page to display it, and navigate to the page you want to edit.
- When you go to a website, Contribute will list the directory's contents if there is no index file. Click a page to display it, and navigate to the page you want to edit.
- The file type may not be editable by Contribute.
- The page may not exist because it has been deleted or because the user entered the wrong page filename.
- The path to the file may exceed the system's maximum character length.
- The correct Contribute Startup password was not entered.
- On the Macintosh, the server volume is not mounted on the computer desktop.

**Clicking the Edit button displays an error message**

The user may not have proper read/write permissions on the server to edit the page, or the shared settings file may be corrupt or changed.

To learn how to check the server's folder permissions, refer to the documentation supplied with the server operating system.

If the server's read/write permissions are properly set, you may have a corrupt shared settings file. If this is the case, you must delete the shared settings file from the web server and create a new shared settings file.
To delete the shared settings file:
1. Connect to the server, either by mounting it on your desktop (Macintosh) or by logging in to it (using an FTP client, telnet, SSH, or similar software).

   Note: You can't perform this procedure from within a web browser.

2. On the server, open the root folder of your Contribute website, and then open the _mm folder that's inside the root folder.

   A typical Windows directory path for the _mm folder might be:
   `\myServer\wwwroot\mySite\_mm`

   A typical UNIX directory path for the _mm folder might be:
   `/myServer/webServer/mySite/_mm`

   The shared settings file is stored in the _mm folder.

3. Delete the shared settings file.

4. Using Contribute, select Edit > Administer Websites, and then select the website whose shared settings file you deleted.

   A dialog box appears informing you that the website has no administrator and asking whether you want to become the administrator for the website. Click Yes to become the website administrator.

5. You are asked to enter an administrator password.

   Enter and confirm the new password, and click OK.

   The Administer Websites dialog box appears.

6. Click Done, or proceed to administer the website.

Clicking Edit Page displays a different page
If you click the Edit Page button and Contribute displays a page other than the one you want, the index page file mapping may be incorrectly configured in the Administration settings in Contribute. To learn more, see “Web server index pages” on page 208.

To check the index page mapping:
1. Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Macintosh), and select the website you want to administer from the submenu.

2. If prompted, enter the Administrator password, and then click OK.

   The Administer Website dialog box appears.

3. Select the Web Server category on the left side of the dialog box and click the Index Files tab.

   The Index Files panel appears, showing a list of index pages.

Problems canceling pages
The following sections describe problems you may encounter when canceling pages in Contribute:
The Cancel button isn't visible when you are reviewing a draft, which means you may inadvertently be working offline. Select File > Work Offline (Windows) or Contribute > Work Offline (Macintosh) to reconnect to the server.

Clicking the Cancel button reports an error if the web server is unavailable or if the user’s permissions on the server are not correctly set. Ensure that the web server is online, and that the server’s read/write permissions are properly set.

Problems sending reviews using e-mail

In some situations, Contribute might not be able to find or start your default e-mail application to create the e-mail review message.

Note: On the Macintosh, Contribute works with the following default e-mail applications: Mail, Eudora, and Entourage.

If Contribute cannot find or start your default e-mail application, you can create the e-mail message by clicking the Click here link in the message area under the toolbar. Copy the web address (URL) for the draft that appears in the browser window, and paste the address in an e-mail message to send to reviewers.

Problems publishing a page

The following sections describe problems you may encounter when publishing a page with Contribute:

Publish button isn’t visible when you are reviewing a draft:

• You may be working offline. Select File > Work Offline (Windows) or Contribute > Work Offline (Macintosh) to reconnect to the server.

• Your assigned role may not have publish permission. Confirm with the Contribute administrator if the role to which you are assigned has publishing permission.

Clicking the Publish button reports errors for a certain page and might have one of the following reasons:

• The server may be offline or otherwise unavailable.
  Ensure that the web server is running by browsing to the website using your computer’s web browser.

• The user’s permissions to either the server itself, the folder containing the web page, or the specific page may have changed.
  Ensure that the user has the correct file and folder access permissions. To learn how to check the server’s file and folder permissions, refer to the documentation supplied with the server operating system.

• The folder containing the page that the user wants to publish to may have been deleted, or does not exist.
  Save the page to another folder in the website, or create an appropriate folder for the page.

• Another user may have locked the page. This can occur if a user with Dreamweaver MX accesses the file and resets the lock file.
Check whether another user has the file checked out, or whether the lock file is invalid and needs to be forcibly removed. If you need to remove the lock file, see “You need to override a file checkout” on page 271.

Problems creating new documents from templates

The following sections describe problems you may encounter when creating new pages from templates with Contribute:

- “Page templates don’t appear in Contribute” on page 267
- “A new page has broken images or other missing elements” on page 267

Page templates don’t appear in Contribute

If your web page templates don’t show up in Contribute, click the Refresh Templates button in the New Page dialog box to download templates. If this fails to fix the problem:

- Ensure that they have been properly downloaded from the server. Sometimes the person downloading the templates clicks Cancel partway through the downloading process, canceling the entire file download.
- The permission group the user belongs to may have restricted template access. For more information, see “Settings for new web pages” on page 252.
- Make sure the template file name contains the .dwt file extension.
- Make sure that all the templates for the website reside in the Templates directory in the site root folder.

A new page has broken images or other missing elements

If a user creates a new page from a template that has images or other dependent files, and the links to those files appear broken, it may be that the user doesn’t have access to the directory storing those files. To correct this:

- Ensure that the user has read access to any folders containing images or other referenced page elements (such as Macromedia Flash movies).
- Check that the template doesn’t contain broken links or invalid syntax.
- Check that the any file upload quotas set on the server have not been exceeded.
- Verify that the server’s disk is not full.

Problems administering Contribute

The following sections describe problems you may encounter when administering Contribute:

- “The Administer Websites menu is deactivated” on page 268
- “You forgot the administrator role password” on page 268
- “Contribute freezes when sending a connection key” on page 269
- “A web page is inadvertently deleted” on page 269
- “Users don’t see enough rollback copies of pages” on page 269
The Administer Websites menu is deactivated

If the Administer Websites menu is deactivated, ensure that Contribute is working online by selecting File > Work Offline (Windows) or Contribute > Work Offline (Macintosh).

If websites within the Administer Websites pop-up menu are deactivated, they might be disabled. For more information, see “Enabling a website connection” on page 237.

You forgot the administrator role password

If you forget the password assigned to the Contribute administrator role, you can reset the password by deleting the shared settings file from the website and creating a new shared settings file.

Note: If you delete the shared settings file, all the roles you have previously created are lost; you must set up those permissions again.

To delete the shared settings file:
1. Connect to the server, either by mounting it on your desktop or by logging in to it (using an FTP client, telnet, SSH, or similar software).
   
   Note: You can’t perform this procedure from within a web browser.

2. On the server, open the root folder of your Contribute website, and then open the _mm folder that’s inside the root folder.

   A typical Windows directory path for the _mm folder might be:
   \myServer\wwwroot\mySite\_mm

   A typical UNIX directory path for the _mm folder might be:
   /<path_to_the_web_server_doc_root/mySite/_mm/>

   The shared settings file is an XML file (labeled contribute.xml) in the _mm folder.

3. Delete the shared settings file.

4. Using Contribute, select Edit > My Connection (Windows) or Contribute > My Connection (Macintosh), select the website whose shared settings file you deleted, and click Edit.

5. Re-establish a connection to the site.

6. When you re-define the website connection, select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Macintosh) and administer the website to which you are connected.

   Contribute will prompt you to become the administrator of the website.

7. Select Set Administrator Password to become the administrator for the site, and reset the administrator password.
Contribute freezes when sending a connection key

If you use a web-based e-mail account (such as Hotmail or Yahoo!) or an e-mail application that Contribute is unable to recognize, the Export Connection Wizard (Windows) or Export Connection Assistant (Macintosh) freezes when you try to automatically attach and send the connection key by e-mail.

To prevent this, save the connection key to your local computer and manually attach it to an e-mail message that you create using your e-mail application.

A web page is inadvertently deleted

If a user inadvertently deletes a web page from the web server, you can recreate the page from the rollback copies maintained on the web server. To do this, rollbacks must be enabled, and the option to delete all rollback copies of a page must not be selected. To learn more about page rollbacks, see “Enabling and disabling rollbacks” on page 221.

To replace a deleted web page:

1. Browse to the deleted page using Contribute.
   
   To do this, you can either enter the URL of the page or click a link on an existing page that links to the deleted page. When you do this, the web server responds with an HTTP 404 error (page not found).

   Note: Some web servers are configured so that they redirect you to the website’s home page or a customized error page if a “file not found” error is encountered. If this happens, you can manually copy the page from the _baks directory located at the root of the Contribute website.

2. Select File > Actions > Roll Back to Previous Version.
   
   The Roll Back Page dialog box appears.

3. Select a previous version of the published page from the list of available pages.

   Note: The list of previously published pages displays as many as 99 of the previous versions of the page.

   Contribute displays the page in the Preview section.

4. Click the Roll Back button if the page you selected is the one you want to publish. If it is not the one you want to publish, select another page from the list, and then click Roll Back.

   Contribute replaces the currently published version of the page with the previously published version that you selected. The version you selected becomes the current version on the website.

   Note: The page you replace with the selected rollback page appears in the Roll Back Page dialog box the next time you open the dialog box. You can roll back to that version if you need to.

Users don’t see enough rollback copies of pages

If users complain that they don’t see enough rollback copies of pages to revert to, consider increasing the number of rollback files that Contribute maintains.

For more information, see “Enabling and disabling rollbacks” on page 221.
Improving application performance by disabling websites

Under certain conditions, you might want to disable a Contribute website. This prevents Contribute from accessing that website, and potentially hindering the application’s performance. You might want to disable a website for any of the following reasons:

- The Contribute application has several websites defined, but only one or two websites are updated regularly.
  
  When you start Contribute, it establishes a connection to each website connection you have defined and maintains an open and active connection during the time the application is running. If you have many websites defined (for example, six or more) but are actively working with only one or two, you may improve application performance by disabling the other websites.

- You’re using a dial-up network that authenticates open connections and disables them after a specified time period.
  
  Many corporate networks terminate connections that remain inactive for extended periods of time. If you have Contribute websites defined that you are not actively working with, you may need to disable these websites to avoid website unavailable errors.

- The website is offline.
  
  If a Contribute website is offline or otherwise unavailable, you may improve performance by disabling the website. When Contribute encounters a website that is unavailable, it displays the error message: “The server serverName is not responding. Contact your system administrator.” You can retry the connection by clicking the Retry Connection button in the browser toolbar.

- The user’s permission group has been removed.
  
  If a user was a member of a permission group that has been removed, Contribute reports an error when it attempts to load the website.

- You are attempting to connect to websites outside of their firewalls, so some websites connect and others do not.
  
  For more information, see “Disabling website connections” on page 236.

You need to remove a single user from a role

If you are using Contribute Publishing Server (CPS) to manage users, you can remove an individual user from a role or you can reassign that user to a different role.

To learn more, see “Removing users from sites managed by CPS” on page 232.

If you are not using CPS to manage users, Contribute does not support the removal of a single user from a role. If you need to remove a single user from a role, do the following:

- Delete that user’s connection from their personal copy of Contribute. As an added measure, your organization’s network authentication can be configured to prevent the user from having read/write access to the website.

- Rename the role and redistribute it to the users you want to include, and then delete the old role.

To learn more, see “Creating Contribute roles” on page 241.
You need to override a file checkout

If a user has a page open for editing, Contribute creates a lock file (identified by a .lck extension) that prevents other users from editing that page. In the following instances, you may need to delete a lock file to allow another user to edit such a page:

- A user who no longer works for your organization has left a file in a locked state on the server.
- A web administrator or other web professional has locked (checked out) the page using Dreamweaver MX and has left the page in a locked state.
- A system error or other anomaly is preventing a user from checking in a page that they no longer want to edit.

Before overriding a checked out page in Contribute, ensure that the person who last worked with the page really is finished working with it and cannot unlock the page using Contribute or Dreamweaver.

To delete a lock file:

1. Using Contribute, browse to the page you want to unlock.
2. At the end of the page’s URL, append the .lck extension to the filename in the Contribute browser such as www.mysite.com/index.htm.lck.
   The File Placeholder Page appears when Contribute encounters a file type that it can’t open. Because the Contribute lock file is of a special type, Contribute cannot display it.
   Note: This menu item is disabled if you do not have permission to delete pages from your website. If this is the case, you must enable file deletion for the user’s permission group. For more information, see “Setting folder and file access settings” on page 247.
   An alert asks whether you are certain that you want to delete the file.
   5. Click Yes to confirm that you want to delete the file.
   Another alert appears, warning that you are deleting a special file and asking if you want to proceed.
   6. Click Yes to confirm that you want to delete the file.
   Contribute deletes the lock file and displays the last page you viewed.
Using Contribute with dynamic pages

Contribute is designed to edit HTML content on your website. It is not, however, designed to edit dynamic content stored in a database or to add or edit dynamic tags. Contribute works around your dynamic document code, and provides tools to protect those parts of your web pages and your website that should not be edited by Contribute users.

The Contribute browser is a full-featured web browser that lets users view dynamic pages, enter data into forms, and submit those forms.

Contribute also supports new pages and templates that include dynamic elements. For example, you can create a template that includes ColdFusion tags for initialization, includes, counters, and dynamic data elements. Users can also copy existing dynamic pages. In either case, as the Contribute website administrator, you must ensure that your website’s code is protected.

Preventing users from editing dynamic pages

To prevent Contribute users from editing dynamic elements on pages, consider the following precautions:

• Restrict editing to specific folders.

Using the Contribute permission groups, you can limit folder access. For example, if your website includes a dynamic job-listings page, put the page in its own folder and exclude the folder from the list of editable folders in the website. When a Contribute user browses to the folder, the Edit Page button is disabled.

• Lock pages you want to protect by using the server’s file-access tools.

Set the file permissions for dynamic pages to read-only. When Contribute users view a dynamic page and click Edit Page, they see a message stating that the page is read-only and is not editable.

• Select Protect scripts and forms in the Contribute administration settings.

Editing static content in dynamic pages

You can allow users to edit static content within dynamic pages and protect only the dynamic portions of the page.

Contribute users cannot edit source code, nor can they edit anything outside the \texttt{<body>} and \texttt{<title>} tags of a page. This protects initialization scripts and include files from being edited. To protect dynamic elements in the body of your page, consider the following precautions:

• Use templates to block off dynamic parts of your page. For example, if you have a page that incorporates dynamically generated content (such as \texttt{CFLOOP} in ColdFusion or repeating ASP), you can make that page into a template, ensure that those regions of the template are locked, and create an instance of the template. Contribute users can edit only within the specified regions.

You may not want users to create new pages from these templates, or copy those pages. To learn how to restrict users from creating new pages from your templates or copying those pages, see “Settings for new web pages” on page 252.
• By default, Contribute is set to allow unrestricted editing of non-template pages and to protect scripts and forms from being edited. If you deselect the option that protects forms and scripts, users can modify code embedded in your pages, such as `<script>` tags, server-side includes, ASP, JSP, ColdFusion, and PHP. This option also protects any tag with a non-text character in the tag name, such as `ASP:MyTag`. However, Contribute may not be able to recognize and protect custom tags, such as `myCustomTag`, and the data elements between ColdFusion `<cfoutput>` tags such as `#{...#}`.

Users are able to edit plain HTML enclosed in conditional tags (such as the content between `<cfif>` and `<cfelse>`, and other HTML container tags such as `<cfoutput>`).

For more information, see “Setting page-editing and paragraph settings” on page 249.

• Limit editing to text-only. Select this option in the Editing category of the Edit Role Name settings dialog box to limit users to only editing and formatting text. For any page not protected by a template, users can edit only text and common text formatting tags (such as `<b>`, `<font>`, `<span>`, and so on.). No other tags can be selected or deleted. However, HTML content between tags may be editable.

For more information, see “Setting page-editing and paragraph settings” on page 249.
This part contains the following appendixes:

Appendix A, “Windows Keyboard Shortcuts,” on page 277
Appendix B, “Macintosh Keyboard Shortcuts,” on page 283
The following sections contain tables listing the Windows operating system keyboard shortcuts for Macromedia Contribute.

**File menu**

The following table lists the keyboard shortcuts for performing File menu actions in Contribute.

<table>
<thead>
<tr>
<th>Action</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create a new page</td>
<td>Control+N</td>
</tr>
<tr>
<td>Open a file on your computer</td>
<td>Control+O</td>
</tr>
<tr>
<td>Close draft</td>
<td>Control+W</td>
</tr>
<tr>
<td>Edit page</td>
<td>Control+E</td>
</tr>
<tr>
<td>Send for review</td>
<td>Control+Shift+S</td>
</tr>
<tr>
<td>Publish</td>
<td>Control+Shift+P</td>
</tr>
<tr>
<td>Edit page source in external application</td>
<td>Control+Shift+E</td>
</tr>
<tr>
<td>Save without publishing</td>
<td>Control+S</td>
</tr>
<tr>
<td>Save for later</td>
<td>Control+Shift+L</td>
</tr>
<tr>
<td>Preview in browser</td>
<td>F12</td>
</tr>
<tr>
<td>Print</td>
<td>Control+P</td>
</tr>
<tr>
<td>Exit/Quit</td>
<td>Control+Q</td>
</tr>
</tbody>
</table>

**Edit menu**

The following table lists the keyboard shortcuts for performing Edit menu actions in Contribute.

<table>
<thead>
<tr>
<th>Action</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo</td>
<td>Control+Z</td>
</tr>
<tr>
<td>Redo</td>
<td>Control+Y</td>
</tr>
</tbody>
</table>
### Cut
- **Shortcut**: Control+X

### Copy
- **Shortcut**: Control+C

### Paste
- **Shortcut**: Control+V

### Paste as text
- **Shortcut**: Control+Shift+V

### Clear
- **Shortcut**: Delete

### Select all
- **Shortcut**: Control+A

### Find
- **Shortcut**: Control+F

## View menu

The following table lists the keyboard shortcuts for performing View menu actions in Contribute.

<table>
<thead>
<tr>
<th>Action</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open or close sidebar</td>
<td>F4</td>
</tr>
<tr>
<td>Open Draft Console</td>
<td>Control+Shift+D</td>
</tr>
<tr>
<td>Open the browser</td>
<td>Control+Shift+B</td>
</tr>
<tr>
<td>Back</td>
<td>Alt+Left</td>
</tr>
<tr>
<td>Forward</td>
<td>Alt+Right</td>
</tr>
<tr>
<td>Refresh browser</td>
<td>F5</td>
</tr>
<tr>
<td>Select file on website</td>
<td>Control+Shift+O</td>
</tr>
</tbody>
</table>

## Insert menu

The following table lists the keyboard shortcuts for performing Insert menu actions in Contribute.

<table>
<thead>
<tr>
<th>Action</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert an image from your computer</td>
<td>Control+Alt+I</td>
</tr>
<tr>
<td>Insert a table</td>
<td>Control+Alt+T</td>
</tr>
<tr>
<td>Insert a link to a web page</td>
<td>Control+Alt+L</td>
</tr>
<tr>
<td>Insert a section anchor</td>
<td>Control+Alt+A</td>
</tr>
<tr>
<td>Add a line break</td>
<td>Shift+Enter</td>
</tr>
<tr>
<td>Add a non-breaking space</td>
<td>Control+Shift+Space</td>
</tr>
</tbody>
</table>
Format menu

The following table lists the keyboard shortcuts for performing Format menu actions in Contribute.

<table>
<thead>
<tr>
<th>Action</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Check spelling</td>
<td>F7</td>
</tr>
<tr>
<td>Make selected text bold</td>
<td>Control+B</td>
</tr>
<tr>
<td>Make selected text italic</td>
<td>Control+I</td>
</tr>
<tr>
<td>Underline selected text</td>
<td>Control+U</td>
</tr>
<tr>
<td>Set left alignment</td>
<td>Control+Alt+Shift+L</td>
</tr>
<tr>
<td>Set center alignment</td>
<td>Control+Alt+Shift+C</td>
</tr>
<tr>
<td>Set right alignment</td>
<td>Control+Alt+Shift+R</td>
</tr>
<tr>
<td>Set justified alignment</td>
<td>Control+Alt+Shift+J</td>
</tr>
<tr>
<td>Indent a paragraph</td>
<td>Control+Alt+]</td>
</tr>
<tr>
<td>Outdent a paragraph</td>
<td>Control+Alt+[</td>
</tr>
<tr>
<td>Add a keyword or description</td>
<td>Control+Alt+K</td>
</tr>
<tr>
<td>Set page properties</td>
<td>Control+J</td>
</tr>
</tbody>
</table>

Table menu

The following table lists the keyboard shortcuts for performing Table menu actions in Contribute.

<table>
<thead>
<tr>
<th>Action</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select a table</td>
<td>Control+T</td>
</tr>
<tr>
<td>Insert a table</td>
<td>Control+Alt+T</td>
</tr>
<tr>
<td>Merge selected cells</td>
<td>Control+Alt+M</td>
</tr>
<tr>
<td>Split selected cell</td>
<td>Control+Alt+S</td>
</tr>
<tr>
<td>Insert a row</td>
<td>Control+M</td>
</tr>
<tr>
<td>Insert a column</td>
<td>Control+Shift+A</td>
</tr>
<tr>
<td>Show table properties</td>
<td>Control+Shift+T</td>
</tr>
</tbody>
</table>

Working in templates

The following table lists the keyboard shortcuts for navigating template regions.

<table>
<thead>
<tr>
<th>Action</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move to the next editable region</td>
<td>Control+Alt+E</td>
</tr>
<tr>
<td>Move to the previous editable region</td>
<td>Control+Shift+Alt+E</td>
</tr>
</tbody>
</table>
## Editing text
The following table lists the keyboard shortcuts for editing text in Contribute.

<table>
<thead>
<tr>
<th>Action</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create a new paragraph</td>
<td>Enter</td>
</tr>
<tr>
<td>Insert a line break <code>&lt;BR&gt;</code></td>
<td>Shift+Enter</td>
</tr>
<tr>
<td>Insert a space</td>
<td>Spacebar</td>
</tr>
<tr>
<td>Insert a non-breaking space</td>
<td>Control+Shift+Space</td>
</tr>
<tr>
<td>Move text or object to another place in the page</td>
<td>Drag selected item to new location</td>
</tr>
<tr>
<td>Select a word</td>
<td>Double-click the word</td>
</tr>
<tr>
<td>Select a paragraph</td>
<td>Triple-click a word in the paragraph</td>
</tr>
<tr>
<td>Indent paragraph</td>
<td>Control+Alt+]</td>
</tr>
<tr>
<td>Outdent paragraph</td>
<td>Control+Alt+[</td>
</tr>
<tr>
<td>Align left</td>
<td>Control+Shift+Alt+L</td>
</tr>
<tr>
<td>Align center</td>
<td>Control+Shift+Alt+C</td>
</tr>
<tr>
<td>Align right</td>
<td>Control+Shift+Alt+R</td>
</tr>
</tbody>
</table>

## Working in tables
The following table lists the keyboard shortcuts for performing table actions in Contribute.

<table>
<thead>
<tr>
<th>Action</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select cell (with insertion point inside the cell)</td>
<td>Control+A</td>
</tr>
<tr>
<td>Move to the next cell</td>
<td>Tab</td>
</tr>
<tr>
<td>Move to the previous cell</td>
<td>Shift+Tab</td>
</tr>
<tr>
<td>Insert a row (above current)</td>
<td>Control+M</td>
</tr>
<tr>
<td>Add a row at end of table</td>
<td>Tab in the last cell</td>
</tr>
<tr>
<td>Insert a column</td>
<td>Control+Shift+A</td>
</tr>
<tr>
<td>Merge selected table cells</td>
<td>Control+Alt+M</td>
</tr>
<tr>
<td>Split table cell</td>
<td>Control+Alt+S</td>
</tr>
</tbody>
</table>

## Working with images
The following table lists the keyboard shortcuts for performing image actions in Contribute.

<table>
<thead>
<tr>
<th>Action</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert an image</td>
<td>Control+Alt+I</td>
</tr>
<tr>
<td>Change image properties</td>
<td>Double-click image</td>
</tr>
</tbody>
</table>
Getting help

The following table lists the keyboard shortcuts for accessing the online help system in Contribute.

<table>
<thead>
<tr>
<th>Action</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open online help</td>
<td>F1</td>
</tr>
<tr>
<td>Open the Start Page</td>
<td>Alt+Home</td>
</tr>
</tbody>
</table>
The following sections contain tables listing the Macintosh operating system keyboard shortcuts for Macromedia Contribute.

**File menu**

The following table lists the keyboard shortcuts for performing File menu actions in Contribute.

<table>
<thead>
<tr>
<th>Action</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create a new page</td>
<td>Command+N</td>
</tr>
<tr>
<td>Open a file on your computer</td>
<td>Command+O</td>
</tr>
<tr>
<td>Close draft</td>
<td>Command+W</td>
</tr>
<tr>
<td>Edit page</td>
<td>Command+Shift+E</td>
</tr>
<tr>
<td>Send for review</td>
<td>Command+Shift+S</td>
</tr>
<tr>
<td>Publish</td>
<td>Command+Shift+P</td>
</tr>
<tr>
<td>Edit page source in external application</td>
<td>Command+Shift+E</td>
</tr>
<tr>
<td>Save without publishing</td>
<td>Command+S</td>
</tr>
<tr>
<td>Save for later</td>
<td>Command+Shift+L</td>
</tr>
<tr>
<td>Print</td>
<td>Command+P</td>
</tr>
<tr>
<td>Exit/Quit</td>
<td>Command+Q</td>
</tr>
</tbody>
</table>

**Edit menu**

The following table lists the keyboard shortcuts for performing Edit menu actions in Contribute.

<table>
<thead>
<tr>
<th>Action</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo</td>
<td>Command+Z</td>
</tr>
<tr>
<td>Redo</td>
<td>Command+Y</td>
</tr>
<tr>
<td>Cut</td>
<td>Command+X</td>
</tr>
</tbody>
</table>
### View menu

The following table lists the keyboard shortcuts for performing View menu actions in Contribute.

<table>
<thead>
<tr>
<th>Action</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open the browser</td>
<td>Command+Shift+B</td>
</tr>
<tr>
<td>Open Draft Console</td>
<td>Command+Shift+D</td>
</tr>
<tr>
<td>Back</td>
<td>Option+Left</td>
</tr>
<tr>
<td>Forward</td>
<td>Option+Right</td>
</tr>
<tr>
<td>Refresh browser</td>
<td>Command+R</td>
</tr>
<tr>
<td>Choose file on website</td>
<td>Command+Shift+O</td>
</tr>
</tbody>
</table>

### Insert menu

The following table lists the keyboard shortcuts for performing Insert menu actions in Contribute.

<table>
<thead>
<tr>
<th>Action</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert an image from your computer</td>
<td>Command+Option+I</td>
</tr>
<tr>
<td>Insert a table</td>
<td>Command+Option+T</td>
</tr>
<tr>
<td>Insert a link</td>
<td>Command+Option+L</td>
</tr>
<tr>
<td>Insert a section anchor</td>
<td>Command+Option+A</td>
</tr>
<tr>
<td>Add a line break</td>
<td>Shift+Return</td>
</tr>
<tr>
<td>Add a non-breaking space</td>
<td>Command+Shift+Space</td>
</tr>
</tbody>
</table>
Format menu

The following table lists the keyboard shortcuts for performing Format menu actions in Contribute.

<table>
<thead>
<tr>
<th>Action</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Make selected text bold</td>
<td>Command+B</td>
</tr>
<tr>
<td>Make selected text italic</td>
<td>Command+I</td>
</tr>
<tr>
<td>Underline selected text</td>
<td>Command+U</td>
</tr>
<tr>
<td>Set left alignment</td>
<td>Command+Option+Shift+L</td>
</tr>
<tr>
<td>Set center alignment</td>
<td>Command+Option+Shift+C</td>
</tr>
<tr>
<td>Set right alignment</td>
<td>Command+Option+Shift+R</td>
</tr>
<tr>
<td>Set justified alignment</td>
<td>Command+Option+Shift+J</td>
</tr>
<tr>
<td>Indent a paragraph</td>
<td>Command+Option+]</td>
</tr>
<tr>
<td>Outdent a paragraph</td>
<td>Command+Option+[*]</td>
</tr>
<tr>
<td>Add a keyword or description</td>
<td>Command+Option+K</td>
</tr>
<tr>
<td>Set page properties</td>
<td>Command+J</td>
</tr>
</tbody>
</table>

Table menu

The following table lists the keyboard shortcuts for performing Table menu actions in Contribute.

<table>
<thead>
<tr>
<th>Action</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select table</td>
<td>Command+T</td>
</tr>
<tr>
<td>Insert a table</td>
<td>Command+Option+T</td>
</tr>
<tr>
<td>Merge selected cells</td>
<td>Command+Option+M</td>
</tr>
<tr>
<td>Split selected cell</td>
<td>Command+Option+S</td>
</tr>
<tr>
<td>Insert a row</td>
<td>Command+M</td>
</tr>
<tr>
<td>Insert a column</td>
<td>Command+Shift+A</td>
</tr>
<tr>
<td>Show table properties</td>
<td>Command+Shift+T</td>
</tr>
</tbody>
</table>

Help menu

The following table lists the keyboard shortcut for accessing the Contribute Start page.

<table>
<thead>
<tr>
<th>Action</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open the Start Page</td>
<td>Option+Home</td>
</tr>
</tbody>
</table>
Working in templates

The following table lists the keyboard shortcuts for navigating template regions.

<table>
<thead>
<tr>
<th>Action</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move to the next editable region</td>
<td>Command+Option+E</td>
</tr>
<tr>
<td>Move to the previous editable region</td>
<td>Command+Shift+Option+E</td>
</tr>
</tbody>
</table>

Editing text

The following table lists the keyboard shortcuts for editing text in Contribute.

<table>
<thead>
<tr>
<th>Action</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create a new paragraph</td>
<td>Enter</td>
</tr>
<tr>
<td>Insert a line break &lt;BR&gt;</td>
<td>Shift+Enter</td>
</tr>
<tr>
<td>Insert a space</td>
<td>Spacebar</td>
</tr>
<tr>
<td>Insert a non-breaking space</td>
<td>Command+Shift+Space</td>
</tr>
<tr>
<td>Move text or object to another place in the page</td>
<td>Drag selected item to new location</td>
</tr>
<tr>
<td>Select a word</td>
<td>Double-click the word</td>
</tr>
<tr>
<td>Select a paragraph</td>
<td>Triple-click a word in the paragraph</td>
</tr>
<tr>
<td>Indent paragraph</td>
<td>Command+Option+]</td>
</tr>
<tr>
<td>Outdent paragraph</td>
<td>Command+Option-[</td>
</tr>
<tr>
<td>Align left</td>
<td>Command+Shift+Option+L</td>
</tr>
<tr>
<td>Align center</td>
<td>Command+Shift+Option+C</td>
</tr>
<tr>
<td>Align right</td>
<td>Command+Shift+Option+R</td>
</tr>
</tbody>
</table>

Working in tables

The following table lists the keyboard shortcuts for performing table actions in Contribute.

<table>
<thead>
<tr>
<th>Action</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select cell (with insertion point inside the cell)</td>
<td>Command+A</td>
</tr>
<tr>
<td>Move to the next cell</td>
<td>Tab</td>
</tr>
<tr>
<td>Move to the previous cell</td>
<td>Shift+Tab</td>
</tr>
<tr>
<td>Insert a row (before current)</td>
<td>Command+M</td>
</tr>
<tr>
<td>Add a row at end of table</td>
<td>Tab in the last cell</td>
</tr>
<tr>
<td>Insert a column</td>
<td>Command+Shift+A</td>
</tr>
<tr>
<td>Merge selected table cells</td>
<td>Command+Option+M</td>
</tr>
<tr>
<td>Split table cell</td>
<td>Command+Option+S</td>
</tr>
</tbody>
</table>
Working with images

The following table lists the keyboard shortcuts for performing image actions in Contribute.

<table>
<thead>
<tr>
<th>Action</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert an image</td>
<td>Command+Option+I</td>
</tr>
<tr>
<td>Change image properties</td>
<td>Double-click image</td>
</tr>
</tbody>
</table>
INDEX

A
accessibility
  authoring for 34
  initiatives 34
  keyboard-only navigation 32
  operating system features 32
  screen reader 32
adding
  bookmarks 29
  copy of the current page 59
  Microsoft Excel content to a page 71
  Microsoft Word content to a page 71
  new pages 59
  page separators 107
  pages based on a template 62
  section anchors 139
  special characters, to a page 75
adjusting image brightness and contrast 100
administration
  settings, about 174
  sitewide settings 218
administrator
  becoming one 217
  changing 219
  password, changing 220
  responsibilities 170
aligning
  images on a page 99
  text 83
applying
  text color 81
  text highlighting 81
autoplaying Flash movies (SWF files) 105

B
bold, applying to text 80
bookmarks
  adding to a folder 29
  deleting 29
  deleting a bookmarks folder 29
  organizing 29
  viewing 28
borders, for images 97
Breeze 135
Breeze Manager 135
brightness and contrast, adjusting for images 100
browser, encoding 31
browsing
  pages 25
  previewing a page 152
  switching to editing 25
  to a connected home page 27
  to a web page 26
  to an unlinked web page 28
bulleted lists, creating 84
buttons
  PayPal, about 92
  PayPal, descriptions 92
  PayPal, editing 110
  PayPal, inserting 109, 110
C
canceling changes to a draft 54
Cascading Style Sheets
  about 195
  limiting available styles 252
  centering text 83
Change Administrator Password dialog box 220
changes to a draft, canceling 54
changing
Contribute startup password 31
link destination 142
link text 142
link text, for a Breeze link 137
table properties 122
text alignment 83
text style 78
Check Spelling command 88
child website 176, 177
choosing a frame page to edit 147
color
text 81
connecting to a website
.Mac 212
about 17
e-mail attachment 17
managed by CPS 231
opening the home page 27
working offline 50
connection key
importing 17
sending 210
sending for websites managed by CPS 231
Connection Wizard 210
connections
.Mac account 212
about 180
child websites 176, 177
creating a website 210
disabling CPS for 215
disabling for websites 236
editing connection information 233
enabling 237
making a CPS-managed website a regular website 235
managing website connections 232
network path 211
overlapping 177
removing 235
renaming in Contribute 234
restoring 50
SFTP 181
URL 210
WebDAV 182
content, linking to Breeze content 135
contrast, adjusting for images 100
Contribute
browser toolbar 23
editor toolbar 23
Help 13
How Do I panel 24
image editing toolbar 23
installing 16
Pages panel 24
preferences 30
setup requirements 16
sidebar 24
starter web pages 60
Support Center 13, 168
text formatting toolbar 23
toolbars 22
using 15
workflow 15
workspace 22
Contribute Publishing Server
adding users to a website 230
case study 201
disabling for a website connection 215
disabling User Directory service for a website 216
E-mail Notification service 198
Log service 198
removing a website from 235
sending connection keys 231
User Directory service, about 198
Contribute startup password
changing 31
entering 18
locked out 18
conventions, typographical 13
copying
images 95
pages 59
copyright symbol, adding 75
courses, linking to Breeze courses 135
CPS See Contribute Publishing Server
creating
blank pages 59
bulleted lists 84
copy of the current page 59
CSS styles 79
linked new pages 129
marker in the page to link to 139
new page, not part of a website 63
numbered lists 83
page based on a template 62
creating links to
  a file on your computer 133
  an e-mail address 132
  Breeze library items 135
drafts or recently published pages 128
  Microsoft documents 71
  new pages 129
  other pages 127
  pages on another website 131
  pages on your website 131
  section anchors 139
cropping an image 101
CSS
  paragraph spacing 250
  styles, about 73

D
deleted page, restoring 269
deleting
  bookmarks 29
  horizontal rules 107
  links 143
  table cells 117
deploying
  responsibilities 170
  tasks 171
description of changes, adding to a draft for review 43
design notes 195
disabled website, enabling a 19
disabling
  CPS for a website connection 215
  User Directory service for a website 216
  website connections 236
DNS, multiple aliases 209
domain name server, see DNS
Draft Console 45
draft review process
  overview 37
  refreshing your list of drafts 46
  reviewing drafts 46
  sending a draft 43
  tracking drafts 45
  viewing comments 47
drafts
  adding a Google search field 53
  canceling changes to 54
  deleting 55
  editing 51
  getting review 42
  refreshing in the Pages panel 46
reviewing 46
  saving and closing 41, 42
  selecting 27
  sending for review 47
  tracking 45
  viewing 27
  viewing comments for 47
  viewing history 47
Dreamweaver
  compatibility with Contribute 194
design notes 195
  file check in/check out 194
  library items, inserting from shared assets 96
duplicating pages 59
dynamic pages
  code, protecting 272
  static content, editing in 272

E
e-mail attachment, connection key 17
e-mail links 132
e-mail review
  process 37, 38
  publishing or canceling a page 47
  sending for review 47
editing
  frames 147
  Google search field properties 53
  images 52, 100, 104
  in an external application 52
  link destination 142
  link text 142
  Macromedia Flash 52
  Microsoft Word or Microsoft Excel documents 52
  non-HTML documents 52
  pages 40
  redoing an edit 41
  switching to browsing 25
  template regions 48
  template-based page 48
  undoing an edit 41
  web page on your computer 40
  web page source 53
  website connection information 233
em dash, adding 75
enabling website connections 237
Excel print area, setting 70
F
file
  delete permissions, setting 249
  linking to a file on your computer 133
  lock (.lck) 271
  placement 254
  replacing on your website 157
File Placement role settings 254
Find and Replace command 89
Fireworks, using Contribute to edit 104
Flash movies (SWF files)
  inserting 105
  inserting from shared assets 96
  reusing assets 105
  setting properties for 105
FlashPaper
  converting a document 66
  creating in an external application 69
deleting from a draft 67
documents 57
  inserting a document 66
  setting Microsoft Excel print area 70
  toolbar 68
FlashPaper SWF files 68
  See also SWF files
folder, permission 248
fonts
  adding 77
  changing 76
  changing size 76
  editing list of available 77
  setting style and permissions 251
formatting text 80
frame pages
  about 145
targeting 149
to edit 147
frames
  adding and editing content 147
  linking a page 149
  saving and publishing 148
targeting where a page loads 149
framesets, about 145
FTP
  connection information 211
troubleshooting 262
G
Google
  adding a search field to a page 53
  editing search field properties 53
H
headings, applying style 78
Help, working with 13
highlighting text 81
history, viewing for drafts 47
horizontal rule, working with 107
How Do I panel 24
HTML
  paragraph spacing 250
  styles, about 73
I
images
  adding to a web page 93
  adding to page by dragging 95
  borders, adding and adjusting 97
  brightness, adjusting 100
  changing alignment of 99
  changing source file location 97
  changing the spacing around 97
  contrast, adjusting 100
copying and pasting 95
cropping 101
editing, in an external application 104
editing, in an external editor 52
editing, inline 100
inserting from shared assets 96
inserting in a page 93
linking 127
moving on a page 98
properties of 97
properties, changing 97
resizing 102
resizing the display area of 97
rotating 103
sharpening 101
indenting or outdenting text 83
index files
  adding new filenames 222
deleting filenames 222
inline editing, for images 100
inserting
  Flash movies (SWF files) 105
  Google search field 53
  horizontal rules 107
  images 94
  movies 106
  section anchors 139
  special characters 75
installing Contribute 16
italic, applying to text 80

K
keywords and descriptions, adding 65

L
learning
  Contribute 15
  resources 12
library items, inserting from shared assets 96
line break, adding 82
link properties
  changing 143
  changing link destination 142
  changing text for a Breeze link 137
  opening the dialog box 142
  selecting a named anchor 140
  targeting where a page opens 138
linking
  images 127
  Microsoft Word or Microsoft Excel document 71
text 127
within a document 140
linking to
  a file on your computer 133
  Breeze library items 135
drafts or recently published pages 128
e-mail addresses 132
new pages 129
pages on another website 131
pages on your website 131
section anchors 140
specific page sections 140
links
  adding section anchors 139
  creating 127
  deleting 143
  inserting in frame page 149
  previewing in a browser 144
  removing 143
setting a target for 138
testing 144
testing in a browser 152
to a file on your computer 133
to Breeze library items 135
to Microsoft documents 71
to send e-mail 132
list properties 87
lists and sublists, creating 85
locked template regions, clicking in 48
Log service 198
logging in to a Breeze account from Contribute 136
looping Flash movies (SWF files) 105

M
Macromedia Flash, editing 52
managing website connections 232
margins, setting page 64
meetings, linking to Breeze meetings 135
merging table cells 120
Microsoft Excel documents
  adding content from 71
dragging content to a page 71
editing 52
setting the print area 70
Microsoft Word documents
  adding content from 71
dragging content to a page 71
editing 52
movies
  inserting 106
  setting properties for 106
  moving an image 98

N
navigating FlashPaper SWF files 69
network
  about 173
  connection types, about 180
  connection, working without 50
  path and web addresses 175
new page, not associated with a website 63
new window
  opening a page in 138
  targeting a 138
numbered lists, creating 83
opening
FlashPaper SWF files in a new browser  69
page in a new window  138
page to edit  40
previous version of a page  160
overlapping, website connections  177

page properties
margins  64
page title  64
setting  64

pages
canceling changes to a draft or new page  54
copying a starter web page  60
creating a linked new page  129
creating new  51
deleting  55
duplicating  59
ingtoring overview  36
editing source for  53
modifying title  64
moving pages to your website  152, 153, 154
opening in a new window  138
opening to edit  40
previewing in a browser  152
printing  55
publishing to your website  152, 153, 154
reverting to a previously published version  160
saving  41
setting margins  64
setting page properties  64
See also dynamic pages

Pages panel  24

paragraphs
adding a line break  82
spacing  250
parent website  176, 177
password
administrator, changing  220
forgotten  268
resetting  268
PayPal buttons
about  92
descriptions  92
editing  110
inserting multiple  110
inserting single  109
permission groups
about  240
general permissions  245
Permission Group dialog box  243
permissions, about  173
personal spelling dictionary  88
port numbers  209
preferences
setting  30
previewing a page in the browser  152
printing  55
printing FlashPaper SWF files
properties
bulleted list  87
Flash movies (SWF files)  105
Google search field  53
movies  106
numbered list  87
publishing
linked documents  153
new pages  154
updates to an existing page  153
Publishing Server See Contribute Publishing Server
redoing and undoing an edit  41
refreshing the Pages panel  46
removing website connections  235
renaming
CSS styles  79
website connections  234
replacing
files on your website  157
text  89
resizing
an image  102
FlashPaper SWF files  68
image display area  97
return, adding a paragraph  82
reviewing drafts  42, 46
role settings, fonts and styles  251
roles
about  185
Administrator  186
default  185
default Publisher  186
Writer  186
Rollback feature 160
rollback files, number of pages 221
rollback pages, enabling and disabling 221
rollbacks, security 187
rotating images 103

S
Save for Later command 42
saving drafts 41
screen readers
   JAWS for Windows 32
   Window Eyes 32
search field
   adding to a page 53
   editing properties for 53
searching
   FlashPaper SWF files 68
   Help 13
text 89
section anchors
   about 139
   creating 139
   inserting 139
   linking to 140
security
   about 187
   rollbacks 187
selecting text in FlashPaper SWF files 68
sending a draft for review 43, 47
server permissions 173
setting
   browser encoding 31
   frames 149
   pages to open in a new window 138
   table alignment 116
SFTP connection information 181, 211
shared assets
   about 196
   creating library of assets 257
   inserting into a page 96
   role settings 255
shared settings file 239
sharpening an image 101
sidebar
   expanding and collapsing 24
   How Do I panel 24
   Pages panel 24
   panels 24
   resizing 24
   selecting a draft or new page 27
sitewide settings
   administrator, changing 219
   password, changing 220
Sitewide Settings dialog box 218
sorting table data 126
source code, viewing 152
source, editing for web pages 53
special characters
   adding to a page 75
   line break 82
   spelling 88
   splitting table cells 120
staging servers
   case study 203
   security 189
startup password
   changing 31
strikethrough, applying to text 80
styles
   applying 78
   creating 79
   CSS and HTML, about 73
   deleting 79
   managing 79
   renaming 79
SWF files 58
switching from
   browsing to editing 25
   editing to browsing 25
   working online to offline 50
T
table 122
table cells
   copying 117
   cutting and pasting 117
   merging 120
   pasting 118
   selecting 114
   splitting 120
table columns
   deleting single or multiple 120
   inserting left or right of selection 119
   inserting multiple 119
table formatting
   conflicts 111
   preset designs and colors 125
table properties
  aligning left, right, or center 122
  editing 122
  modifying 122
  row or column, changing 123
table properties, setting
  table alignment 122
  table width 122
table rows
  deleting single or multiple 120
  inserting above or below selection 119
  inserting multiple 119
  inserting single or multiple 119
tables
  aligning left, right, or center 116
  alignment, about 116
  element hierarchy 111
  inserting multiple rows or columns 119
  selecting a table, row, or column 113
  selecting cells 114
  sort by options 126
targeting frame pages 149
templates
  about 48
  clicking in locked regions 48
  Dreamweaver 48
  editable attributes 49
  editing a page based on 48
  modifying template properties 49
  overview 48
  setting template properties 49
text
  aligning 83
  bold 80
  bulleted lists, creating 84
  centering 83
  color, applying 81
  definition lists, creating 85
  finding and replacing 89
  font size, changing 76
  font, changing 76
  fonts, adding 77
  formatting 80
  highlighting 81
  indenting 83
  italic 80
  links, creating 127
  lists, indenting 85
  numbered lists, creating 83
  outdenting 83
  replacing 89
  searching for 89
  strikethrough 80
  underline 80
toolbars
  about 22
  browser 23
  editor 23
  image editing 23
  text formatting 23
  tracking drafts 45
troubleshooting
  canceling pages 265
  clicking in locked template regions 48
  connection, creating 261
  FTP remote folder 262
  launching Contribute 260
  page editing 263
  publishing pages 266
typographical conventions 13

U
  underline, applying to text 80
  undoing an edit 41
unlinked pages, viewing 28
User Directory service
  adding users to a website 230
  disabling 216
user management
  about 185
  Contribute Publishing Server 185
  manual connections 185
users
  connecting to a website 17
  connecting to a website managed by CPS 231
  using Contribute 15

V
viewing
  bookmarks list 28
  comments for drafts 47
  unlinked pages 28
  website pages 26
virtual servers 209
web addresses
  DNS, multiple aliasing 209
  port numbers 209
  virtual servers 209

web pages
  code, protecting 272
  deleted, restoring 269
  editing, restricting 250
  fonts, setting 251
  paragraph spacing, specifying 250
  permissions, setting 252
  static content, editing 272
  templates 252

web server
  port numbers 209

WebDAV connection information 182

website
  address (URL) 210
  connecting, overview 17
  disabled, enabling 19
  home page, selecting 27
  pages, viewing 26

website connections
  child websites 176, 177
  connection failure 19
  creating 210
  disabling at startup 19
  disabling CPS for 215
  disabling for a single website 236
  disabling for all websites 236
  editing connection information 233
  enabling 237
  enabling a disabled website 19
  making a CPS-managed website a regular website 235
  managing 232
  overlapping 177
  removing 235
  renaming in Contribute 234

websites
  disabling a connection to 236
  disabling all connections 236
  disabling CPS for 215
  disabling CPS for a connection 215
  disabling User Directory service for 216
  editing connection information for 233
  enabling connections to 237
  managing connections to 232
  removing connections to 235
  renaming connections to 234

wizards, Connection Wizard 210

working offline
  canceling or deleting a draft 51
  creating a new page 51
  editing a draft 51
  restoring your connection 50
  switching to 50
  without a network connection 50